summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-20 00:02:57 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-25 12:14:08 +0200
commitebdd83f6b7e5c3296e5ebd3b7b0c1e0defe5aba5 (patch)
tree9b2af5454c398e0a97d193d440c904c4d7c7cd43
parentb9fec03db878745066f91f354f82ec9c0002f34a (diff)
downloadmeta-qt5-ebdd83f6b7e5c3296e5ebd3b7b0c1e0defe5aba5.tar.gz
qtbase: explicitly enable or disable all deps
* some options are tri-state and PACKAGECONFIG doesn't support that if you need the 3rd option, you need to overwrite PACKAGECONFIG[opt] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase-5.0.2/0021-configure-make-pulseaudio-a-configurable-option.patch36
-rw-r--r--recipes-qt/qt5/qtbase-5.0.2/0022-configure-make-alsa-a-configurable-option.patch35
-rw-r--r--recipes-qt/qt5/qtbase-5.0.2/0023-configure-make-freetype-a-configurable-option.patch35
-rw-r--r--recipes-qt/qt5/qtbase-git/0021-configure-make-pulseaudio-a-configurable-option.patch36
-rw-r--r--recipes-qt/qt5/qtbase-git/0022-configure-make-alsa-a-configurable-option.patch35
-rw-r--r--recipes-qt/qt5/qtbase-git/0023-configure-make-freetype-a-configurable-option.patch35
-rw-r--r--recipes-qt/qt5/qtbase.inc154
7 files changed, 302 insertions, 64 deletions
diff --git a/recipes-qt/qt5/qtbase-5.0.2/0021-configure-make-pulseaudio-a-configurable-option.patch b/recipes-qt/qt5/qtbase-5.0.2/0021-configure-make-pulseaudio-a-configurable-option.patch
new file mode 100644
index 00000000..3c723f6f
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-5.0.2/0021-configure-make-pulseaudio-a-configurable-option.patch
@@ -0,0 +1,36 @@
1From 647c9bb3a33e8cc5093d46b1a08d38f3f2002b74 Mon Sep 17 00:00:00 2001
2From: Paul Eggleton <paul.eggleton@linux.intel.com>
3Date: Tue, 28 Feb 2012 15:10:24 +0000
4Subject: [PATCH 21/23] configure: make pulseaudio a configurable option
5
6Allows disabling pulseaudio support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 configure | 7 +++++++
14 1 file changed, 7 insertions(+)
15
16diff --git a/configure b/configure
17index 188e941..24dcd3a 100755
18--- a/configure
19+++ b/configure
20@@ -1848,6 +1848,13 @@ while [ "$#" -gt 0 ]; do
21 UNKNOWN_OPT=yes
22 fi
23 ;;
24+ pulseaudio)
25+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
26+ CFG_PULSEAUDIO="$VAL"
27+ else
28+ UNKNOWN_OPT=yes
29+ fi
30+ ;;
31 gtkstyle)
32 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
33 CFG_QGTKSTYLE="$VAL"
34--
351.8.3.2
36
diff --git a/recipes-qt/qt5/qtbase-5.0.2/0022-configure-make-alsa-a-configurable-option.patch b/recipes-qt/qt5/qtbase-5.0.2/0022-configure-make-alsa-a-configurable-option.patch
new file mode 100644
index 00000000..b5e0bf77
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-5.0.2/0022-configure-make-alsa-a-configurable-option.patch
@@ -0,0 +1,35 @@
1From 33a0f6ff196e366eb51dc2fb937636b087f1719f Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Fri, 19 Jul 2013 23:21:28 +0200
4Subject: [PATCH 22/23] configure: make alsa a configurable option
5
6Allows disabling alsa support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
11---
12 configure | 7 +++++++
13 1 file changed, 7 insertions(+)
14
15diff --git a/configure b/configure
16index 24dcd3a..2f46604 100755
17--- a/configure
18+++ b/configure
19@@ -1855,6 +1855,13 @@ while [ "$#" -gt 0 ]; do
20 UNKNOWN_OPT=yes
21 fi
22 ;;
23+ alsa)
24+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
25+ CFG_ALSA="$VAL"
26+ else
27+ UNKNOWN_OPT=yes
28+ fi
29+ ;;
30 gtkstyle)
31 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
32 CFG_QGTKSTYLE="$VAL"
33--
341.8.3.2
35
diff --git a/recipes-qt/qt5/qtbase-5.0.2/0023-configure-make-freetype-a-configurable-option.patch b/recipes-qt/qt5/qtbase-5.0.2/0023-configure-make-freetype-a-configurable-option.patch
new file mode 100644
index 00000000..f88bb7e0
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-5.0.2/0023-configure-make-freetype-a-configurable-option.patch
@@ -0,0 +1,35 @@
1From 113e48ed082315424931407717b72a7a5c011944 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 20 Jul 2013 10:56:37 +0200
4Subject: [PATCH 23/23] configure: make freetype a configurable option
5
6Allows disabling freetype support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
11---
12 configure | 7 +++++++
13 1 file changed, 7 insertions(+)
14
15diff --git a/configure b/configure
16index 2f46604..c2cf3b5 100755
17--- a/configure
18+++ b/configure
19@@ -1862,6 +1862,13 @@ while [ "$#" -gt 0 ]; do
20 UNKNOWN_OPT=yes
21 fi
22 ;;
23+ freetype)
24+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ] || [ "$VAL" = "system" ]; then
25+ CFG_LIBFREETYPE="$VAL"
26+ else
27+ UNKNOWN_OPT=yes
28+ fi
29+ ;;
30 gtkstyle)
31 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
32 CFG_QGTKSTYLE="$VAL"
33--
341.8.3.2
35
diff --git a/recipes-qt/qt5/qtbase-git/0021-configure-make-pulseaudio-a-configurable-option.patch b/recipes-qt/qt5/qtbase-git/0021-configure-make-pulseaudio-a-configurable-option.patch
new file mode 100644
index 00000000..2fe0a182
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-git/0021-configure-make-pulseaudio-a-configurable-option.patch
@@ -0,0 +1,36 @@
1From 1f5a36de9bb01192d3cdbcbef7a009ab4651040b Mon Sep 17 00:00:00 2001
2From: Paul Eggleton <paul.eggleton@linux.intel.com>
3Date: Tue, 28 Feb 2012 15:10:24 +0000
4Subject: [PATCH 21/23] configure: make pulseaudio a configurable option
5
6Allows disabling pulseaudio support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 configure | 7 +++++++
14 1 file changed, 7 insertions(+)
15
16diff --git a/configure b/configure
17index 96965b6..595c9d9 100755
18--- a/configure
19+++ b/configure
20@@ -1959,6 +1959,13 @@ while [ "$#" -gt 0 ]; do
21 UNKNOWN_OPT=yes
22 fi
23 ;;
24+ pulseaudio)
25+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
26+ CFG_PULSEAUDIO="$VAL"
27+ else
28+ UNKNOWN_OPT=yes
29+ fi
30+ ;;
31 gtkstyle)
32 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
33 CFG_QGTKSTYLE="$VAL"
34--
351.8.3.2
36
diff --git a/recipes-qt/qt5/qtbase-git/0022-configure-make-alsa-a-configurable-option.patch b/recipes-qt/qt5/qtbase-git/0022-configure-make-alsa-a-configurable-option.patch
new file mode 100644
index 00000000..76d1400c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-git/0022-configure-make-alsa-a-configurable-option.patch
@@ -0,0 +1,35 @@
1From eb93499e26486957a93b2f8f82853d3de9769cce Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Fri, 19 Jul 2013 23:21:28 +0200
4Subject: [PATCH 22/23] configure: make alsa a configurable option
5
6Allows disabling alsa support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
11---
12 configure | 7 +++++++
13 1 file changed, 7 insertions(+)
14
15diff --git a/configure b/configure
16index 595c9d9..864967c 100755
17--- a/configure
18+++ b/configure
19@@ -1966,6 +1966,13 @@ while [ "$#" -gt 0 ]; do
20 UNKNOWN_OPT=yes
21 fi
22 ;;
23+ alsa)
24+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
25+ CFG_ALSA="$VAL"
26+ else
27+ UNKNOWN_OPT=yes
28+ fi
29+ ;;
30 gtkstyle)
31 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
32 CFG_QGTKSTYLE="$VAL"
33--
341.8.3.2
35
diff --git a/recipes-qt/qt5/qtbase-git/0023-configure-make-freetype-a-configurable-option.patch b/recipes-qt/qt5/qtbase-git/0023-configure-make-freetype-a-configurable-option.patch
new file mode 100644
index 00000000..76b58355
--- /dev/null
+++ b/recipes-qt/qt5/qtbase-git/0023-configure-make-freetype-a-configurable-option.patch
@@ -0,0 +1,35 @@
1From 6729c056b4d3ab43e59ce1c8303ae58d7c6ba8cf Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 20 Jul 2013 10:56:37 +0200
4Subject: [PATCH 23/23] configure: make freetype a configurable option
5
6Allows disabling freetype support at configure time.
7
8Upstream-Status: Pending
9
10Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
11---
12 configure | 7 +++++++
13 1 file changed, 7 insertions(+)
14
15diff --git a/configure b/configure
16index 864967c..1b4225a 100755
17--- a/configure
18+++ b/configure
19@@ -1973,6 +1973,13 @@ while [ "$#" -gt 0 ]; do
20 UNKNOWN_OPT=yes
21 fi
22 ;;
23+ freetype)
24+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ] || [ "$VAL" = "system" ]; then
25+ CFG_LIBFREETYPE="$VAL"
26+ else
27+ UNKNOWN_OPT=yes
28+ fi
29+ ;;
30 gtkstyle)
31 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
32 CFG_QGTKSTYLE="$VAL"
33--
341.8.3.2
35
diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc
index f521a302..f4cce29f 100644
--- a/recipes-qt/qt5/qtbase.inc
+++ b/recipes-qt/qt5/qtbase.inc
@@ -19,80 +19,106 @@ SRC_URI += " \
19 file://0018-QOpenGLPaintDevice-sub-area-support.patch \ 19 file://0018-QOpenGLPaintDevice-sub-area-support.patch \
20 file://0019-Fix-FBO-restoring-in-QOpenGLTextureGlyphCache.patch \ 20 file://0019-Fix-FBO-restoring-in-QOpenGLTextureGlyphCache.patch \
21 file://0020-Use-BGRA-extension-in-bindTexture.patch \ 21 file://0020-Use-BGRA-extension-in-bindTexture.patch \
22 file://0021-configure-make-pulseaudio-a-configurable-option.patch \
23 file://0022-configure-make-alsa-a-configurable-option.patch \
24 file://0023-configure-make-freetype-a-configurable-option.patch \
22" 25"
23 26
24DEPENDS += "qtbase-native freetype jpeg libpng zlib openssl glib-2.0 ${ICU} udev ${XCB_DEPENDS} ${GL_DEPENDS} ${TSLIB_DEPENDS} ${FONTCONFIG_DEPENDS}" 27DEPENDS += "qtbase-native"
25 28
26# to provide xcb/xcb_icccm.h, xcb/xcb_image.h, xcb/xcb_keysyms.h and dbus/dbus.h 29# separate some parts of PACKAGECONFIG which are often changed
27# XCB_DEPENDS += "xcb-util-wm xcb-util-image xcb-util-keysyms dbus" 30# be aware that you need to add icu to build qtwebkit, default
28# reenable when we switch to "-qt-xcb" and build of 31# PACKAGECONFIG is kept rather minimal for people who don't need
29# QT_XCB = "-qt-xcb" 32# stuff like webkit (and it's easier to add options than remove)
30# src/platformsupport/glxconvenience/ is resolved to be before build of 33
31# src/plugins/platforms/xcb/ 34# gl or gles needs to be enabled in order to build qtdeclarative
32 35# http://qt.gitorious.org/qt/qtdeclarative/commit/e988998a08b1420ed10bd02d9d4b3b8ed2289df9
33XCB_DEPENDS ?= "" 36PACKAGECONFIG_GL ?= "${@base_contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
34QT_XCB ?= "-no-xcb" 37PACKAGECONFIG_FB ?= "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
35 38PACKAGECONFIG_X11 ?= "${@base_contains('DISTRO_FEATURES', 'x11', 'xcb xvideo xsync xshape xrender xrandr xfixes xinput2 xinput xinerama xcursor gtkstyle', '', d)}"
36QT_DISTRO_FLAGS ?= "-no-accessibility -no-sm" 39PACKAGECONFIG_FONTS ?= "fontconfig freetype"
37QT_DISTRO_FLAGS_linuxstdbase = "-sm" 40PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib"
38 41PACKAGECONFIG_MULTIMEDIA ?= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
39# Some can be used only for certain QT_MODULEs, so define them here, 42PACKAGECONFIG_DISTRO ?= ""
40# but add them to QT_CONFIG_FLAGS e.g. in qtbase.inc 43
41QT_SQL_DRIVER_FLAGS ?= "-no-sql-ibase -no-sql-mysql -no-sql-psql -no-sql-odbc -plugin-sql-sqlite" 44PACKAGECONFIG ??= " \
42 45 release \
43# if you want to enable egl/gles2 in your .bbappend, don't forget to add right dependencies, e.g. 46 dbus \
44# GL_DEPENDS = "virtual/libgles2 virtual/egl" 47 udev \
45# QT_GLFLAGS = "-opengl es2 -eglfs" 48 evdev \
46GL_DEPENDS ?= "virtual/libgl" 49 widgets \
47QT_GLFLAGS ?= "-opengl" 50 openssl \
48 51 ${PACKAGECONFIG_GL} \
49# if you want to enable tslib in your .bbappend, don't forget to add tslib dependencies 52 ${PACKAGECONFIG_FB} \
50# TSLIB_DEPENDS = "tslib" 53 ${PACKAGECONFIG_X11} \
51# QT_TSLIB = "-tslib" 54 ${PACKAGECONFIG_FONTS} \
52TSLIB_DEPENDS ?= "" 55 ${PACKAGECONFIG_SYSTEM} \
53QT_TSLIB ?= "-no-tslib" 56 ${PACKAGECONFIG_MULTIMEDIA} \
54 57 ${PACKAGECONFIG_DISTRO} \
55# FONTCONFIG_DEPENDS = "fontconfig" 58"
56# QT_FONTCONFIG = "-fontconfig" 59
57FONTCONFIG_DEPENDS ?= "" 60PACKAGECONFIG[release] = "-release,-debug"
58QT_FONTCONFIG ?= "-no-fontconfig" 61PACKAGECONFIG[sm] = "-sm,-no-sm"
59 62PACKAGECONFIG[tests] = ",-nomake tests"
60QT_WIDGETS ?= "-widgets" 63PACKAGECONFIG[examples] = ",-nomake examples"
61QT_XML ?= "-xmlpatterns" 64PACKAGECONFIG[accessibility] = "-accessibility,-no-accessibility"
62QT_WEBKIT ?= "-webkit" 65PACKAGECONFIG[glib] = "-glib,-no-glib,glib-2.0"
63QT_PHONON ?= "-phonon" 66PACKAGECONFIG[freetype] = "-system-freetype,-no-freetype,freetype"
64QT_DBUS ?= "-qdbus" 67PACKAGECONFIG[jpeg] = "-system-libjpeg,-no-libjpeg,jpeg"
65QT_MULTIMEDIA ?= "${@base_contains('DISTRO_FEATURES', 'pulseaudio', '-pulseaudio', '-no-pulseaudio', d)}" 68PACKAGECONFIG[libpng] = "-system-libpng,-no-libpng,libpng"
66QT_NAS ?= "-no-nas-sound" 69PACKAGECONFIG[zlib] = "-system-zlib,-qt-zlib,zlib"
67QT_NIS ?= "-no-nis" 70PACKAGECONFIG[pcre] = "-system-pcre,-qt-pcre,pcre"
68QT_CUPS ?= "-no-cups" 71PACKAGECONFIG[gl] = "-opengl -no-eglfs,,virtual/libgl"
69QT_STL ?= "-stl" 72PACKAGECONFIG[gles2] = "-opengl es2 -eglfs,,virtual/libgles2 virtual/egl"
70QT_SYSTEM_LIBS ?= "-system-libjpeg -system-libpng -system-zlib" 73PACKAGECONFIG[tslib] = "-tslib,-no-tslib,tslib"
71QT_TESTS ?= "-nomake tests" 74PACKAGECONFIG[dbus] = "-dbus,-no-dbus,dbus"
72QT_EXAMPLES ?= "-nomake examples" 75PACKAGECONFIG[xcb] = "-xcb,-no-xcb,xcb-util-wm xcb-util-image xcb-util-keysyms"
73QT_RELEASE ?= "-release" 76PACKAGECONFIG[sql-ibase] = "-sql-ibase,-no-sql-ibase"
77PACKAGECONFIG[sql-mysql] = "-sql-mysql,-no-sql-mysql,mysql"
78PACKAGECONFIG[sql-psql] = "-sql-psql,-no-sql-psql,postgresql"
79PACKAGECONFIG[sql-odbc] = "-sql-odbc,-no-sql-odbc"
80PACKAGECONFIG[sql-oci] = "-sql-oci,-no-sql-oci"
81PACKAGECONFIG[sql-tds] = "-sql-tds,-no-sql-tds"
82PACKAGECONFIG[sql-db2] = "-sql-db2,-no-sql-db2"
83PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite"
84PACKAGECONFIG[sql-sqlite] = "-sql-sqlite,-no-sql-sqlite,sqlite3"
85PACKAGECONFIG[xcursor] = "-xcursor,-no-xcursor,libxcursor"
86PACKAGECONFIG[xinerama] = "-xinerama,-no-xinerama,libxinerama"
87PACKAGECONFIG[xinput] = "-xinput,-no-xinput"
88PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2"
89PACKAGECONFIG[xfixes] = "-xfixes,-no-xfixes,libxfixes"
90PACKAGECONFIG[xrandr] = "-xrandr,-no-xrandr,libxrandr"
91PACKAGECONFIG[xrender] = "-xrender,-no-xrender,libxrender"
92PACKAGECONFIG[xshape] = "-xshape,-no-xshape"
93PACKAGECONFIG[xsync] = "-xsync,-no-xsync"
94PACKAGECONFIG[xvideo] = "-xvideo,-no-xvideo"
95PACKAGECONFIG[openvg] = "-openvg,-no-openvg"
96PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv"
97PACKAGECONFIG[xkb] = "-xkb,-no-xkb,libxkbcommon"
98PACKAGECONFIG[evdev] = "-evdev,-no-evdev"
99PACKAGECONFIG[gstreamer] = "-gstreamer,-no-gstreamer,gstreamer"
100PACKAGECONFIG[fontconfig] = "-fontconfig,-no-fontconfig,fontconfig"
101PACKAGECONFIG[gtkstyle] = "-gtkstyle,-no-gtkstyle,gtk+"
102PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb"
103PACKAGECONFIG[linuxfb] = "-linuxfb,-no-linuxfb,linuxfb"
104PACKAGECONFIG[mitshm] = "-mitshm,-no-mitshm,mitshm"
105PACKAGECONFIG[kms] = "-kms,-no-kms,kms"
106PACKAGECONFIG[icu] = "-icu,-no-icu,${ICU}"
107PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev"
108PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl"
109PACKAGECONFIG[alsa] = "-alsa,-no-alsa,alsa-lib"
110PACKAGECONFIG[pulseaudio] = "-pulseaudio,-no-pulseaudio,pulseaudio"
111PACKAGECONFIG[nis] = "-nis,-no-nis"
112PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
74 113
75QT_CONFIG_FLAGS += " \ 114QT_CONFIG_FLAGS += " \
76 ${QT_RELEASE} \
77 -reduce-relocations \ 115 -reduce-relocations \
78 -shared \ 116 -shared \
79 -silent \ 117 -silent \
80 -glib \
81 -no-pch \ 118 -no-pch \
82 -no-rpath \ 119 -no-rpath \
83 -pkg-config \ 120 -pkg-config \
84 ${QT_WIDGETS} \ 121 ${EXTRA_OECONF} \
85 ${QT_SYSTEM_LIBS} \
86 ${QT_NIS} \
87 ${QT_CUPS} \
88 ${QT_SQL_DRIVER_FLAGS} \
89 ${QT_DISTRO_FLAGS} \
90 ${QT_XCB} \
91 ${QT_GLFLAGS} \
92 ${QT_TESTS} \
93 ${QT_EXAMPLES} \
94 ${QT_TSLIB} \
95 ${QT_FONTCONFIG} \
96" 122"
97 123
98INC_PR = "r2" 124INC_PR = "r2"