summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-23 10:10:14 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-11-13 10:31:42 +0000
commitb3502fbbc08813fe46a60c230611506e4636d9dc (patch)
tree9f06075a62e05d37c02d2590f2d03bb4d3c689a0
parent5832bf2747a70257eca5c443fd487532d62c90b3 (diff)
downloadmeta-qt5-b3502fbbc08813fe46a60c230611506e4636d9dc.tar.gz
qt5: Disable ltcg for host_build
debug-prefix-map does not work correctly for static libraries when using ltcg, and since host_build compilations link agaist the libQt5Bootstrap.a library, it breaks source file packaging into debug packages. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch26
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 02ee6077..d2a45288 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -40,6 +40,7 @@ SRC_URI += "\
40 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \ 40 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
41 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \ 41 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
42 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \ 42 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
43 file://0016-Disable-ltcg-for-host_build.patch \
43" 44"
44 45
45# common for qtbase-native and nativesdk-qtbase 46# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index d4709013..c58c7f37 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -35,6 +35,7 @@ SRC_URI += "\
35 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \ 35 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
36 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \ 36 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
37 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \ 37 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
38 file://0016-Disable-ltcg-for-host_build.patch \
38" 39"
39 40
40# common for qtbase-native and nativesdk-qtbase 41# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch
new file mode 100644
index 00000000..8b961e60
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0016-Disable-ltcg-for-host_build.patch
@@ -0,0 +1,26 @@
1From 94383531bde019ba113cc416b5cf3627e18ffef3 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 23 Oct 2018 09:54:57 +0300
4Subject: [PATCH] Disable ltcg for host_build
5
6debug-prefix-map does not work correctly for static libraries
7when using ltcg, and since host_build compilations link agaist
8the libQt5Bootstrap.a library, it breaks source file packaging
9into debug packages.
10
11Task-number: QTBUG-71230
12Upstream-Status: Inappropriate [embedded specific]
13---
14 mkspecs/features/ltcg.prf | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
18index ccf0226272..482e5b573d 100644
19--- a/mkspecs/features/ltcg.prf
20+++ b/mkspecs/features/ltcg.prf
21@@ -1,4 +1,4 @@
22-CONFIG(release, debug|release) {
23+CONFIG(release, debug|release):!host_build {
24 # We need fat object files when creating static libraries on some platforms
25 # so the linker will know to load a particular object from the library
26 # in the first place. On others, we have special ar and nm to create the symbol
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index e8f967ec..e5585cd0 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -31,6 +31,7 @@ SRC_URI += "\
31 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \ 31 file://0013-Upgrade-double-conversion-to-v3.0.0.patch \
32 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \ 32 file://0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch \
33 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \ 33 file://0015-double-conversion-support-AARCH64EB-and-arm-BE.patch \
34 file://0016-Disable-ltcg-for-host_build.patch \
34" 35"
35 36
36 37