diff options
author | Steffen Sledz <sledz@dresearch-fe.de> | 2017-07-06 13:44:43 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-12 10:25:31 +0200 |
commit | aa0605d3c7364f226d655376ee89166dbcbe4cea (patch) | |
tree | 02371970e24957bf7c9513fe45f63ffaeb20943d | |
parent | 2c1d6b1e9377d10d1c66ae2a4f9b15b3781e96d8 (diff) | |
download | meta-qt5-aa0605d3c7364f226d655376ee89166dbcbe4cea.tar.gz |
qtquickcontrols2: fix compilation of examples/texteditor
git/examples/quickcontrols2/texteditor/documenthandler.cpp:284:18: error: invalid use of incomplete type 'class QDebug'
qWarning() << "load() called before DocumentHandler has QQmlEngine";
Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch | 28 | ||||
-rw-r--r-- | recipes-qt/qt5/qtquickcontrols2_git.bb | 4 |
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch b/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch new file mode 100644 index 00000000..d08c57e9 --- /dev/null +++ b/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 3696a416bd594d3f280c281cb2a66bc837829238 Mon Sep 17 00:00:00 2001 | ||
2 | From: Steffen Sledz <sledz@dresearch-fe.de> | ||
3 | Date: Thu, 6 Jul 2017 13:28:07 +0200 | ||
4 | Subject: [PATCH] qtquickcontrols2: fix compilation of examples/texteditor | ||
5 | |||
6 | git/examples/quickcontrols2/texteditor/documenthandler.cpp:284:18: error: invalid use of incomplete type 'class QDebug' | ||
7 | qWarning() << "load() called before DocumentHandler has QQmlEngine"; | ||
8 | |||
9 | Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de> | ||
10 | --- | ||
11 | examples/quickcontrols2/texteditor/documenthandler.cpp | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/examples/quickcontrols2/texteditor/documenthandler.cpp b/examples/quickcontrols2/texteditor/documenthandler.cpp | ||
15 | index e57946fd..94ca82ad 100644 | ||
16 | --- a/examples/quickcontrols2/texteditor/documenthandler.cpp | ||
17 | +++ b/examples/quickcontrols2/texteditor/documenthandler.cpp | ||
18 | @@ -59,6 +59,7 @@ | ||
19 | #include <QTextCharFormat> | ||
20 | #include <QTextCodec> | ||
21 | #include <QTextDocument> | ||
22 | +#include <QtCore/QDebug> | ||
23 | |||
24 | DocumentHandler::DocumentHandler(QObject *parent) | ||
25 | : QObject(parent) | ||
26 | -- | ||
27 | 2.13.2 | ||
28 | |||
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb index 42acb8ad..371f4aef 100644 --- a/recipes-qt/qt5/qtquickcontrols2_git.bb +++ b/recipes-qt/qt5/qtquickcontrols2_git.bb | |||
@@ -10,4 +10,8 @@ LIC_FILES_CHKSUM = " \ | |||
10 | 10 | ||
11 | DEPENDS += "qtdeclarative" | 11 | DEPENDS += "qtdeclarative" |
12 | 12 | ||
13 | SRC_URI += " \ | ||
14 | file://0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch \ | ||
15 | " | ||
16 | |||
13 | SRCREV = "6f7852a307c7ebbdb3b6efa00cbf7626b072bbc1" | 17 | SRCREV = "6f7852a307c7ebbdb3b6efa00cbf7626b072bbc1" |