summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-11-15 19:35:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-11-15 21:40:50 +0100
commit8eec0155083e62a07265daf15c110b0b33b1a301 (patch)
tree009d8e9a3ecce22c9758a1b6111eb0f551dcb1c9
parent3546f08c5b286913d21245ca6c531c67b3729e09 (diff)
downloadmeta-qt5-8eec0155083e62a07265daf15c110b0b33b1a301.tar.gz
qt5-native: change PV of 5.0.0-beta2 to sort lower then 5.0.0 when it's released
* also add version specific .inc files and move all version specific variables to it * upgrade 5.0.0-beta1 to 5.0.0-beta2 and add include for latest git Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-4.999+5.0.0-beta2.inc15
-rw-r--r--recipes-qt/qt5/qt5-4.999+git.inc18
-rw-r--r--recipes-qt/qt5/qt5-native.inc7
-rw-r--r--recipes-qt/qt5/qt5-native_4.999+5.0.0-beta2.bb7
-rw-r--r--recipes-qt/qt5/qt5-native_4.999+git.bb6
-rw-r--r--recipes-qt/qt5/qt5-native_5.0.0.bb6
6 files changed, 46 insertions, 13 deletions
diff --git a/recipes-qt/qt5/qt5-4.999+5.0.0-beta2.inc b/recipes-qt/qt5/qt5-4.999+5.0.0-beta2.inc
new file mode 100644
index 00000000..36ac896d
--- /dev/null
+++ b/recipes-qt/qt5/qt5-4.999+5.0.0-beta2.inc
@@ -0,0 +1,15 @@
1# Copyright (C) 2012 O.S. Systems Software LTDA.
2
3QT_VERSION ?= "5.0.0-beta2"
4
5SRC_URI += " \
6 http://releases.qt-project.org/qt5.0/beta2/submodules_tar/${QT_MODULE}-opensource-src-${QT_VERSION}.tar.xz \
7"
8
9S = "${WORKDIR}/${QT_MODULE}-opensource-src-${QT_VERSION}"
10
11LICENSE = "GFDL-1.3 & LGPLv2.1 | GPLv3"
12LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=02356821480f1d3d534b21e0343265b5 \
13 file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
14 file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
15 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e"
diff --git a/recipes-qt/qt5/qt5-4.999+git.inc b/recipes-qt/qt5/qt5-4.999+git.inc
new file mode 100644
index 00000000..b0fca1de
--- /dev/null
+++ b/recipes-qt/qt5/qt5-4.999+git.inc
@@ -0,0 +1,18 @@
1# Copyright (C) 2012 O.S. Systems Software LTDA.
2
3# each module needs to define valid SRCREV
4SRC_URI += " \
5 git://qt.gitorious.org/qt/${QT_MODULE}.git;protocol=git \
6"
7
8S = "${WORKDIR}/git"
9
10PV = "4.999+5.0.0-beta2+gitr${SRCPV}"
11
12DEFAULT_PREFERENCE = "-1"
13
14LICENSE = "GFDL-1.3 & LGPLv2.1 | GPLv3"
15LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=02356821480f1d3d534b21e0343265b5 \
16 file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
17 file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
18 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e"
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qt5-native.inc
index 1fe34457..76e2277d 100644
--- a/recipes-qt/qt5/qt5-native.inc
+++ b/recipes-qt/qt5/qt5-native.inc
@@ -4,15 +4,8 @@ SECTION = "libs"
4HOMEPAGE = "http://qt-project.org" 4HOMEPAGE = "http://qt-project.org"
5PROVIDES = "qt5-tools-native" 5PROVIDES = "qt5-tools-native"
6 6
7LICENSE = "LGPLv2.1 | GPLv3"
8LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=cc5963be04f8b19c3e3c46bc31f0f6e1 \
9 file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
10 file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
11
12INC_PR = "r0" 7INC_PR = "r0"
13 8
14include qt5.inc
15
16inherit native 9inherit native
17 10
18QT_MODULE = "qtbase" 11QT_MODULE = "qtbase"
diff --git a/recipes-qt/qt5/qt5-native_4.999+5.0.0-beta2.bb b/recipes-qt/qt5/qt5-native_4.999+5.0.0-beta2.bb
new file mode 100644
index 00000000..58915414
--- /dev/null
+++ b/recipes-qt/qt5/qt5-native_4.999+5.0.0-beta2.bb
@@ -0,0 +1,7 @@
1require qt5-native.inc
2require qt5-${PV}.inc
3
4PR = "${INC_PR}.0"
5
6SRC_URI[md5sum] = "735b6d6c3711f59ee7d5454dc6b8a2f2"
7SRC_URI[sha256sum] = "f62b238220f384d84587d0519fb7fa8961a4d70871d38d6a4bc4e4f013b8606f"
diff --git a/recipes-qt/qt5/qt5-native_4.999+git.bb b/recipes-qt/qt5/qt5-native_4.999+git.bb
new file mode 100644
index 00000000..b6072fa3
--- /dev/null
+++ b/recipes-qt/qt5/qt5-native_4.999+git.bb
@@ -0,0 +1,6 @@
1require qt5-native.inc
2require qt5-4.999+git.inc
3
4PR = "${INC_PR}.0"
5
6SRCREV = "f7d99ad50f11ee7c263d4c2bdbe024355a1ab3e9"
diff --git a/recipes-qt/qt5/qt5-native_5.0.0.bb b/recipes-qt/qt5/qt5-native_5.0.0.bb
deleted file mode 100644
index a3e5e769..00000000
--- a/recipes-qt/qt5/qt5-native_5.0.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require qt5-native.inc
2
3PR = "${INC_PR}.0"
4
5SRC_URI[md5sum] = "2e1e5198a3a139099bfefe75ed29e043"
6SRC_URI[sha256sum] = "d1a6b06fb3d44e83bbd5b7fe5bc1177ff437f992efafe0154cf37b18cfa87109"