summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-08-19 12:45:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-20 19:28:47 +0200
commit648f7b0a2eb202d4378ce50ae566b6ca450dd010 (patch)
tree299c347748d06586f0a7b87f474e4058c6365a90
parent209e7e6dd8e23bc6501ada7d7b4caa99e449de6a (diff)
downloadmeta-qt5-648f7b0a2eb202d4378ce50ae566b6ca450dd010.tar.gz
qtbase, qtgraphicaleffect, qtmultimedia, qtscript, qtlocation, qtwayland: disable gold to work around binutils bug
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb25
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb4
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb4
-rw-r--r--recipes-qt/qt5/qtscript_git.bb4
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb4
6 files changed, 44 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 8cd23a02..550968cd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -41,6 +41,28 @@ SRC_URI += "\
41# for syncqt 41# for syncqt
42RDEPENDS_${PN}-tools += "perl" 42RDEPENDS_${PN}-tools += "perl"
43 43
44# workaround for gold bug:
45# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842304
46# https://sourceware.org/bugzilla/show_bug.cgi?id=21712
47# it's triggered only in combination of gold and security_flags.inc,
48# because security_flags.inc now enable pie by default.
49# Adding -no-pie or changing -fuse-ld=gold to -fuse-ld=bfd
50# works around this issue, will use -fuse-ld=bfd as it's considered
51# binutils bug.
52# OE @ ~/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/tests/auto/corelib/kernel/qmetatype $ i586-oe-linux-g++ -m32 -march=i586 --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -fuse-ld=gold -Wl,--enable-new-dtags -o tst_qmetatype .obj/tst_qmetatype.o -L/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/lib -lQt5Test -lQt5Core -lpthread
53# .obj/tst_qmetatype.o(.qtversion+0x0): error: unexpected reloc 3 against global symbol qt_version_tag without base register in object file when generating a position-independent output file
54# collect2: error: ld returned 1 exit status
55#
56# with -no-pie:
57# OE @ ~/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/tests/auto/corelib/kernel/qmetatype $ i586-oe-linux-g++ -no-pie -m32 -march=i586 --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -fuse-ld=gold -Wl,--enable-new-dtags -o tst_qmetatype .obj/tst_qmetatype.o -L/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/lib -lQt5Test -lQt5Core -lpthread
58#
59# with -fuse-ld=gold replaced with -fuse-ld=bfd:
60# OE @ ~/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/tests/auto/corelib/kernel/qmetatype $ i586-oe-linux-g++ -m32 -march=i586 --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed --sysroot=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/recipe-sysroot -Wl,-O1 -fuse-ld=bfd -Wl,--enable-new-dtags -o tst_qmetatype .obj/tst_qmetatype.o -L/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtbase/5.9.0+gitAUTOINC+f6b36eaafe-r0/build/lib -lQt5Test -lQt5Core -lpthread
61#
62# http://errors.yoctoproject.org/Errors/Details/150329/
63QT_CONFIG_FLAGS_GOLD_x86 = "-no-use-gold-linker"
64LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
65
44# separate some parts of PACKAGECONFIG which are often changed 66# separate some parts of PACKAGECONFIG which are often changed
45PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" 67PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
46PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" 68PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
@@ -129,8 +151,9 @@ PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
129PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput" 151PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
130PACKAGECONFIG[journald] = "-journald,-no-journald,systemd" 152PACKAGECONFIG[journald] = "-journald,-no-journald,systemd"
131 153
154QT_CONFIG_FLAGS_GOLD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '-use-gold-linker', '-no-use-gold-linker', d)}"
132QT_CONFIG_FLAGS += " \ 155QT_CONFIG_FLAGS += " \
133 ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '-use-gold-linker', '-no-use-gold-linker', d)} \ 156 ${QT_CONFIG_FLAGS_GOLD} \
134 -shared \ 157 -shared \
135 -silent \ 158 -silent \
136 -no-pch \ 159 -no-pch \
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index f4b43e75..eadd4bc3 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -20,3 +20,7 @@ DEPENDS += "qtdeclarative"
20RDEPENDS_${PN}-dev = "" 20RDEPENDS_${PN}-dev = ""
21 21
22SRCREV = "1583bb5569cfc50141d879107a46146d5ccccf28" 22SRCREV = "1583bb5569cfc50141d879107a46146d5ccccf28"
23
24# The same issue as in qtbase:
25# http://errors.yoctoproject.org/Errors/Build/44912/
26LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index f25d57ef..ab96029e 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -21,3 +21,7 @@ PACKAGECONFIG[gypsy] = "-feature-gypsy,-no-feature-gypsy,gconf gypsy"
21EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" 21EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
22 22
23SRCREV = "41cc347040226d2c5c16b9df001d03f2724b87e5" 23SRCREV = "41cc347040226d2c5c16b9df001d03f2724b87e5"
24
25# The same issue as in qtbase:
26# http://errors.yoctoproject.org/Errors/Details/152640/
27LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 7d3c3cc0..aa79e3f0 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -34,3 +34,7 @@ SRC_URI += "\
34" 34"
35 35
36SRCREV = "544a8a4251ff9694780e563ddb6e4af1325e0115" 36SRCREV = "544a8a4251ff9694780e563ddb6e4af1325e0115"
37
38# The same issue as in qtbase:
39# http://errors.yoctoproject.org/Errors/Build/44914/
40LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 3f8b64a2..2875988e 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -26,3 +26,7 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
26DEPENDS += "qtbase" 26DEPENDS += "qtbase"
27 27
28SRCREV = "c35df2ec0ee05351912e768d298a7c627dbdd1ef" 28SRCREV = "c35df2ec0ee05351912e768d298a7c627dbdd1ef"
29
30# The same issue as in qtbase:
31# http://errors.yoctoproject.org/Errors/Build/44915/
32LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index bcddb32c..ffe22086 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -50,3 +50,7 @@ SRC_URI += " \
50" 50"
51 51
52BBCLASSEXTEND =+ "native nativesdk" 52BBCLASSEXTEND =+ "native nativesdk"
53
54# The same issue as in qtbase:
55# http://errors.yoctoproject.org/Errors/Details/152641/
56LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"