summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-19 14:12:59 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:48:05 +0200
commit0e5756c97ace089ddd9714f0eafffd71dd15c6ab (patch)
tree6ae1b404abfe8879f6634c64c09f09bd2137c6e5
parent8034aa98076649e452798ff23285249dac7f19fc (diff)
downloadmeta-qt5-0e5756c97ace089ddd9714f0eafffd71dd15c6ab.tar.gz
qtwebkit: add PACKAGECONFIGs for libxcomposite, libxrender, fontconfig
* fixes following QA: WARNING: qtwebkit-5.6.99+5.7.0-alpha+gitAUTOINC+e9b369b16f-r0 do_package_qa: QA Issue: qtwebkit rdepends on libxcomposite, but it isn't a build dependency? [build-deps] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 22efe82b..58b86c8a 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -24,7 +24,10 @@ SRC_URI += "\
24 file://0003-Exclude-backtrace-API-for-non-glibc-libraries.patch \ 24 file://0003-Exclude-backtrace-API-for-non-glibc-libraries.patch \
25" 25"
26 26
27PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel" 27PACKAGECONFIG ??= "gstreamer qtlocation qtmultimedia qtsensors qtwebchannel \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxrender', '', d)} \
29 fontconfig \
30"
28PACKAGECONFIG[gstreamer] = "OE_GSTREAMER_ENABLED,,gstreamer1.0 gstreamer1.0-plugins-base" 31PACKAGECONFIG[gstreamer] = "OE_GSTREAMER_ENABLED,,gstreamer1.0 gstreamer1.0-plugins-base"
29PACKAGECONFIG[gstreamer010] = "OE_GSTREAMER010_ENABLED,,gstreamer gst-plugins-base" 32PACKAGECONFIG[gstreamer010] = "OE_GSTREAMER010_ENABLED,,gstreamer gst-plugins-base"
30PACKAGECONFIG[qtlocation] = "OE_QTLOCATION_ENABLED,,qtlocation" 33PACKAGECONFIG[qtlocation] = "OE_QTLOCATION_ENABLED,,qtlocation"
@@ -32,6 +35,9 @@ PACKAGECONFIG[qtmultimedia] = "OE_QTMULTIMEDIA_ENABLED,,qtmultimedia"
32PACKAGECONFIG[qtsensors] = "OE_QTSENSORS_ENABLED,,qtsensors" 35PACKAGECONFIG[qtsensors] = "OE_QTSENSORS_ENABLED,,qtsensors"
33PACKAGECONFIG[qtwebchannel] = "OE_QTWEBCHANNEL_ENABLED,,qtwebchannel" 36PACKAGECONFIG[qtwebchannel] = "OE_QTWEBCHANNEL_ENABLED,,qtwebchannel"
34PACKAGECONFIG[libwebp] = "OE_LIBWEBP_ENABLED,,libwebp" 37PACKAGECONFIG[libwebp] = "OE_LIBWEBP_ENABLED,,libwebp"
38PACKAGECONFIG[libxcomposite] = "OE_LIBXCOMPOSITE_ENABLED,,libxcomposite"
39PACKAGECONFIG[libxrender] = "OE_LIBXRENDER_ENABLED,,libxrender"
40PACKAGECONFIG[fontconfig] = "OE_FONTCONFIG_ENABLED,,fontconfig"
35 41
36do_configure_prepend() { 42do_configure_prepend() {
37 export QMAKE_CACHE_EVAL="CONFIG+=${PACKAGECONFIG_CONFARGS}" 43 export QMAKE_CACHE_EVAL="CONFIG+=${PACKAGECONFIG_CONFARGS}"
@@ -50,6 +56,12 @@ do_configure_prepend() {
50 sed -e 's/\s\(qtHaveModule(webchannel)\)/ OE_QTWEBCHANNEL_ENABLED:\1/' -i ${S}/Source/WebKit2/WebKit2.pri 56 sed -e 's/\s\(qtHaveModule(webchannel)\)/ OE_QTWEBCHANNEL_ENABLED:\1/' -i ${S}/Source/WebKit2/WebKit2.pri
51 # disable libwebp test if it isn't enabled by PACKAGECONFIG 57 # disable libwebp test if it isn't enabled by PACKAGECONFIG
52 sed -e 's/\s\(config_libwebp: \)/ OE_LIBWEBP_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf 58 sed -e 's/\s\(config_libwebp: \)/ OE_LIBWEBP_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
59 # disable libxcomposite test if it isn't enabled by PACKAGECONFIG
60 sed -e 's/\s\(config_libXcomposite: \)/ OE_LIBXCOMPOSITE_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
61 # disable libxrender test if it isn't enabled by PACKAGECONFIG
62 sed -e 's/\s\(config_libXrender: \)/ OE_LIBXRENDER_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
63 # disable fontconfig test if it isn't enabled by PACKAGECONFIG
64 sed -e 's/\s\(config_fontconfig: \)/ OE_FONTCONFIG_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
53} 65}
54 66
55# qtwebkit gets terribly big when linking with all debug info, disable by default 67# qtwebkit gets terribly big when linking with all debug info, disable by default