summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-25 14:43:49 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 20:49:29 +0200
commita6df86ea4becebb434b13e6fe1c62760494d81d5 (patch)
tree27f4858f301bbc67c52fb63eeaef84c305d5fc8a
parent22c28fee3cbd394ae1b261854637696b1f5deeb5 (diff)
downloadmeta-qt5-a6df86ea4becebb434b13e6fe1c62760494d81d5.tar.gz
qttools: use one recipe for all compilations
Instead of separate recipes for target, native and nativesdk, use one recipe with BBCLASSEXTEND in place. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qttools_git.bb42
-rw-r--r--recipes-qt/qt5/qttools-native_git.bb24
-rw-r--r--recipes-qt/qt5/qttools_git.bb10
3 files changed, 9 insertions, 67 deletions
diff --git a/recipes-qt/qt5/nativesdk-qttools_git.bb b/recipes-qt/qt5/nativesdk-qttools_git.bb
deleted file mode 100644
index b217da1f..00000000
--- a/recipes-qt/qt5/nativesdk-qttools_git.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
2LIC_FILES_CHKSUM = " \
3 file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
4 file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \
5 file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
6 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
7"
8
9QT_MODULE = "qttools"
10
11DEPENDS = "nativesdk-qtbase qtbase-native"
12
13require nativesdk-qt5.inc
14require qt5-git.inc
15
16SRC_URI += "file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch"
17
18PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
19
20FILES_${PN}-dbg = " \
21 ${OE_QMAKE_PATH_BINS}/.debug \
22"
23
24FILES_${PN} = " \
25 ${OE_QMAKE_PATH_BINS}/* \
26"
27
28do_configure() {
29 ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S} CONFIG+=linguistonly
30}
31
32do_install() {
33 # Fix install paths for all
34 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_HOST},(INSTALL_ROOT),g"
35
36 oe_runmake install INSTALL_ROOT=${D}
37
38 # remove things unused in nativesdk
39 rm -rf ${D}${libdir}
40}
41
42SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c"
diff --git a/recipes-qt/qt5/qttools-native_git.bb b/recipes-qt/qt5/qttools-native_git.bb
deleted file mode 100644
index cb786978..00000000
--- a/recipes-qt/qt5/qttools-native_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DEPENDS = "qtbase-native"
2
3LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
6 file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \
7 file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
8 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
9"
10
11QT_MODULE = "qttools"
12
13require qt5-native.inc
14require qt5-git.inc
15
16do_configure() {
17 ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S} CONFIG+=linguistonly
18}
19
20do_install() {
21 oe_runmake install INSTALL_ROOT=${D}
22}
23
24SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index afc89849..a13fb747 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -9,9 +9,11 @@ LIC_FILES_CHKSUM = " \
9 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ 9 file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
10" 10"
11 11
12DEPENDS += "qtbase qtdeclarative qtxmlpatterns" 12DEPENDS += "qtbase"
13DEPENDS_class-target = "qtdeclarative qtxmlpatterns"
13 14
14SRC_URI += " \ 15SRC_URI += " \
16 file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \
15 file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ 17 file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \
16 file://0003-add-noqtwebkit-configuration.patch \ 18 file://0003-add-noqtwebkit-configuration.patch \
17" 19"
@@ -20,8 +22,14 @@ FILES_${PN}-tools += "${datadir}/${QT_DIR_NAME}/phrasebooks"
20FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples" 22FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples"
21 23
22PACKAGECONFIG ??= "" 24PACKAGECONFIG ??= ""
25PACKAGECONFIG_class-native ??= "linguistonly"
26PACKAGECONFIG_class-nativesdk ??= "linguistonly"
27PACKAGECONFIG[linguistonly] = ""
23PACKAGECONFIG[qtwebkit] = ",,qtwebkit" 28PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
24 29
25EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" 30EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
31EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}"
26 32
27SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" 33SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c"
34
35BBCLASSEXTEND = "native nativesdk"