summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-24 10:43:59 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-26 17:12:26 +0200
commit813103e622b721467f64f8a3c4e6a4eab4e346cc (patch)
tree58733c9de630b8e745dacfaf3a1c691abed39eaa
parentc16daba21756c661a008d3a9199d3d80aa914bdf (diff)
downloadmeta-qt5-813103e622b721467f64f8a3c4e6a4eab4e346cc.tar.gz
recipes, conf: Direct QT_GIT to use github mirrors
This helps in load balancing code.qt.io may be overloaded and bails out occasionally when doing fresh clones Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/layer.conf4
-rw-r--r--recipes-qt/examples/qt5everywheredemo_1.0.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 92558b33..f83bd967 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -5,7 +5,7 @@
5# Therefore if you want a given layer to be considered high priority 5# Therefore if you want a given layer to be considered high priority
6# for the .inc and .conf etc. then consider it adding at the beginning 6# for the .inc and .conf etc. then consider it adding at the beginning
7# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve 7# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
8# the recipe contention so the order of directories in BBFILES does 8# the recipe contention so the order of directories in BBFILES does
9# not matter. 9# not matter.
10 10
11# We have a conf and classes directory, append to BBPATH 11# We have a conf and classes directory, append to BBPATH
@@ -27,4 +27,4 @@ LICENSE_PATH += "${LAYERDIR}/licenses"
27 27
28IMAGE_FEATURES[validitems] += "qtcreator-debug" 28IMAGE_FEATURES[validitems] += "qtcreator-debug"
29 29
30QT_GIT ?= "git://code.qt.io" 30QT_GIT ?= "git://github.com/qtproject"
diff --git a/recipes-qt/examples/qt5everywheredemo_1.0.bb b/recipes-qt/examples/qt5everywheredemo_1.0.bb
index 0546b00c..057aaaa9 100644
--- a/recipes-qt/examples/qt5everywheredemo_1.0.bb
+++ b/recipes-qt/examples/qt5everywheredemo_1.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://main.cpp;md5=1187cb795a0f96bce64e63dd1a67dc2b"
7DEPENDS = "qtdeclarative qtgraphicaleffects" 7DEPENDS = "qtdeclarative qtgraphicaleffects"
8 8
9SRCREV = "c17fe9e0ec0882ac4c4dc1168095f569acab5d09" 9SRCREV = "c17fe9e0ec0882ac4c4dc1168095f569acab5d09"
10SRC_URI = "${QT_GIT}/qt-labs/qt5-everywhere-demo.git" 10SRC_URI = "${QT_GIT}/qt-labs-qt5-everywhere-demo"
11 11
12S = "${WORKDIR}/git/QtDemo" 12S = "${WORKDIR}/git/QtDemo"
13 13
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index ea37b55c..b73ce4fe 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -5,7 +5,7 @@ QT_MODULE_BRANCH ?= "5.5"
5 5
6# each module needs to define valid SRCREV 6# each module needs to define valid SRCREV
7SRC_URI = " \ 7SRC_URI = " \
8 ${QT_GIT}/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ 8 ${QT_GIT}/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \
9" 9"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 2933bf70..27873b77 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -75,7 +75,7 @@ RDEPENDS_${PN}-examples += " \
75QT_MODULE_BRANCH_CHROMIUM = "40.0.2214-based" 75QT_MODULE_BRANCH_CHROMIUM = "40.0.2214-based"
76 76
77SRC_URI += " \ 77SRC_URI += " \
78 ${QT_GIT}/qt/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \ 78 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};destsuffix=git/src/3rdparty \
79 file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ 79 file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
80 file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ 80 file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
81 file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ 81 file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \