summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe Chapuis <chris.chapuis@gmail.com>2015-09-19 15:57:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:53 +0200
commit52496ed3e2ec94d1d93426a766ec93ab400bc1df (patch)
tree25314e3196820e0fa72ba700ec93bc6b4c63cd6b
parent1ea73d69f49e18d67520f0d5edd0744244889ecb (diff)
downloadmeta-qt5-52496ed3e2ec94d1d93426a766ec93ab400bc1df.tar.gz
maliit-framework-qt5: bump to latest commit for getting Qt 5.5 compatibility
Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com>
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch43
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb3
2 files changed, 1 insertions, 45 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch b/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch
deleted file mode 100644
index 4f8890f3..00000000
--- a/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1Fix compatibility with qt-5.3
2
3https://bugs.launchpad.net/ubuntu/+source/maliit-framework/+bug/1323962
4
5Upstream-Status: Pending
6
7diff --git a/src/maliit/plugins/updateevent.cpp b/src/maliit/plugins/updateevent.cpp
8index 06a5228..85b7166 100644
9--- a/src/maliit/plugins/updateevent.cpp
10+++ b/src/maliit/plugins/updateevent.cpp
11@@ -38,7 +38,7 @@ bool MImUpdateEventPrivate::isFlagSet(Qt::InputMethodHint hint,
12 bool result = false;
13
14 if (update.contains(Maliit::Internal::inputMethodHints)) {
15- const Qt::InputMethodHints hints(static_cast<Qt::InputMethodHints>(
16+ const Qt::InputMethodHints hints(static_cast<int>(
17 update.value(Maliit::Internal::inputMethodHints).toLongLong()));
18
19 result = (hints & hint);
20@@ -89,8 +89,8 @@ QStringList MImUpdateEvent::propertiesChanged() const
21 Qt::InputMethodHints MImUpdateEvent::hints(bool *changed) const
22 {
23 Q_D(const MImUpdateEvent);
24- return static_cast<Qt::InputMethodHints>(
25- d->extractProperty(Maliit::Internal::inputMethodHints, changed).toLongLong());
26+ return Qt::InputMethodHints(static_cast<int>(
27+ d->extractProperty(Maliit::Internal::inputMethodHints, changed).toLongLong()));
28 }
29
30 bool MImUpdateEvent::westernNumericInputEnforced(bool *changed) const
31diff --git a/src/mimpluginmanager.cpp b/src/mimpluginmanager.cpp
32index 02788a4..3c5c99a 100644
33--- a/src/mimpluginmanager.cpp
34+++ b/src/mimpluginmanager.cpp
35@@ -1493,7 +1493,7 @@ void MIMPluginManager::handleWidgetStateChanged(unsigned int clientId,
36 }
37 }
38
39- const Qt::InputMethodHints lastHints = static_cast<Qt::InputMethodHints>(newState.value(Maliit::Internal::inputMethodHints).toLongLong());
40+ const Qt::InputMethodHints lastHints(static_cast<int>(newState.value(Maliit::Internal::inputMethodHints).toLongLong()));
41 MImUpdateEvent ev(newState, changedProperties, lastHints);
42
43 // general notification last
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 83da8cad..975892d6 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -9,10 +9,9 @@ inherit qmake5
9SRC_URI = "git://github.com/maliit/framework.git;branch=master \ 9SRC_URI = "git://github.com/maliit/framework.git;branch=master \
10 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ 10 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
11 file://maliit-server.desktop \ 11 file://maliit-server.desktop \
12 file://qt5.3-fix.patch \
13" 12"
14 13
15SRCREV = "17fdf8699c53ddfb2c15df8e11d46804e782fec5" 14SRCREV = "60b1b10de14f932420313c547ab801daf522d539"
16PV = "0.99.0+git${SRCPV}" 15PV = "0.99.0+git${SRCPV}"
17 16
18 17