summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-08-25 14:43:45 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-26 17:21:13 +0200
commit22c28fee3cbd394ae1b261854637696b1f5deeb5 (patch)
tree6dff0059317ea4715e57d935fb30d10ea967d208
parentf969c48953359c75199634867ab8e1d775b7e747 (diff)
downloadmeta-qt5-22c28fee3cbd394ae1b261854637696b1f5deeb5.tar.gz
qt5: improve support for native and nativesdk modules
Change qmake.bbclass to support building native and nativesdk packages, so that qmake or qt5-module can be inherited and BBCLASSEXTEND used to create native and nativesdk packages. qtxmlpatterns and qtdeclarative native and nativesdk modules are required for Qt Quick Compiler. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--classes/qmake5.bbclass8
-rw-r--r--classes/qmake5_base.bbclass11
-rw-r--r--recipes-qt/qt5/qt5.inc2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
5 files changed, 24 insertions, 1 deletions
diff --git a/classes/qmake5.bbclass b/classes/qmake5.bbclass
index b056ea75..2b43f2e3 100644
--- a/classes/qmake5.bbclass
+++ b/classes/qmake5.bbclass
@@ -13,3 +13,11 @@ do_configure() {
13do_install() { 13do_install() {
14 qmake5_base_do_install 14 qmake5_base_do_install
15} 15}
16
17do_install_class-native() {
18 qmake5_base_native_do_install
19}
20
21do_install_class-nativesdk() {
22 qmake5_base_nativesdk_do_install
23}
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index 44575c4c..ffb3103d 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -166,6 +166,17 @@ qmake5_base_do_configure () {
166 ${OE_QMAKE_QMAKE} -makefile -o Makefile ${OE_QMAKE_DEBUG_OUTPUT} ${OE_QMAKE_RECURSIVE} $QMAKE_VARSUBST_PRE $AFTER $PROFILES $QMAKE_VARSUBST_POST || die "Error calling $CMD" 166 ${OE_QMAKE_QMAKE} -makefile -o Makefile ${OE_QMAKE_DEBUG_OUTPUT} ${OE_QMAKE_RECURSIVE} $QMAKE_VARSUBST_PRE $AFTER $PROFILES $QMAKE_VARSUBST_POST || die "Error calling $CMD"
167} 167}
168 168
169qmake5_base_native_do_install() {
170 oe_runmake install INSTALL_ROOT=${D}
171}
172
173qmake5_base_nativesdk_do_install() {
174 # Fix install paths for all
175 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_HOST},(INSTALL_ROOT),g"
176
177 oe_runmake install INSTALL_ROOT=${D}
178}
179
169qmake5_base_do_install() { 180qmake5_base_do_install() {
170 # Fix install paths for all 181 # Fix install paths for all
171 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_TARGET},(INSTALL_ROOT),g" 182 find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_TARGET},(INSTALL_ROOT),g"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index ef849bf6..4c58ad69 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -50,7 +50,7 @@ PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmlplu
50ALLOW_EMPTY_${PN} = "1" 50ALLOW_EMPTY_${PN} = "1"
51ALLOW_EMPTY_${PN}-dbg = "1" 51ALLOW_EMPTY_${PN}-dbg = "1"
52 52
53RRECOMMENDS_${PN} = " \ 53RRECOMMENDS_${PN}_class-target = " \
54 ${PN}-plugins \ 54 ${PN}-plugins \
55 ${PN}-qmlplugins \ 55 ${PN}-qmlplugins \
56 " 56 "
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 421c4820..f9689e61 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,3 +33,5 @@ do_configure_prepend() {
33EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}" 33EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
34 34
35SRCREV = "cc0df64bb0e1dea2fe37950816095802f527a241" 35SRCREV = "cc0df64bb0e1dea2fe37950816095802f527a241"
36
37BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index cb6bf9df..3c273db5 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -13,3 +13,5 @@ LIC_FILES_CHKSUM = " \
13DEPENDS += "qtbase" 13DEPENDS += "qtbase"
14 14
15SRCREV = "ae6504efc85adf754d60a02f81413e5949282d78" 15SRCREV = "ae6504efc85adf754d60a02f81413e5949282d78"
16
17BBCLASSEXTEND =+ "native nativesdk"