summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-09-12 13:37:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:52 +0200
commit09caddadc395f7758f86a4a1b93616a02757e59b (patch)
treef86b33e70b713aaa7b9315bfcc65916288b04ee4
parent9c036b3bacea43dbbc937100b6dd2b5fe3f2ee8a (diff)
downloadmeta-qt5-09caddadc395f7758f86a4a1b93616a02757e59b.tar.gz
qtbase: fix build for PACKAGECONFIG gles2
fixes: | In file included from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/X11/Xlib.h:44:0, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglvivante.h:244, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglplatform.h:38, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/egl.h:39, | from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen_p.h:52, | from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen.cpp:34: | ../../include/QtCore/../../../git/src/corelib/io/qurl.h:131:9: error: expected identifier before numeric constant | None = 0x0, | ^ Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch49
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch b/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch
new file mode 100644
index 00000000..a1a8791e
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch
@@ -0,0 +1,49 @@
1From f8873b5ba0fa42cc0d2aadfd6c5a449b37799609 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sat, 12 Sep 2015 12:58:46 +0200
4Subject: [PATCH] qeglplatformscreen.cpp: reorder headers to fix build with egl
5 enabled
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10fixes:
11In file included from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/X11/Xlib.h:44:0,
12 from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglvivante.h:244,
13 from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglplatform.h:38,
14 from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/egl.h:39,
15 from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen_p.h:52,
16 from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen.cpp:34:
17../../include/QtCore/../../../git/src/corelib/io/qurl.h:131:9: error: expected identifier before numeric constant
18 None = 0x0,
19 ^
20
21This patch has a very limited lifetime: In branch dev and 5.6 the patched file is gone. Therefore:
22
23Upstream-Status: Pending
24
25Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
26---
27 src/platformsupport/eglconvenience/qeglplatformscreen.cpp | 4 ++--
28 1 file changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/src/platformsupport/eglconvenience/qeglplatformscreen.cpp b/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
31index 61f8cdd..ceec797 100644
32--- a/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
33+++ b/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
34@@ -31,10 +31,10 @@
35 **
36 ****************************************************************************/
37
38-#include "qeglplatformscreen_p.h"
39-#include "qeglplatformwindow_p.h"
40 #include <QtGui/qwindow.h>
41 #include <qpa/qwindowsysteminterface.h>
42+#include "qeglplatformscreen_p.h"
43+#include "qeglplatformwindow_p.h"
44 #include <QtPlatformSupport/private/qopenglcompositor_p.h>
45
46 QT_BEGIN_NAMESPACE
47--
482.1.0
49
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 70e35c23..ecae53be 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -25,6 +25,7 @@ SRC_URI += "\
25SRC_URI += "\ 25SRC_URI += "\
26 file://0009-qmake-don-t-build-it-in-configure-but-allow-to-build.patch \ 26 file://0009-qmake-don-t-build-it-in-configure-but-allow-to-build.patch \
27 file://0010-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \ 27 file://0010-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
28 file://0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch \
28" 29"
29 30
30DEPENDS += "qtbase-native" 31DEPENDS += "qtbase-native"