summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-11-22 15:52:52 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-11-23 18:21:34 +0200
commitfd86202d56c542011d24dc518457631bc00901c9 (patch)
treee495d6371c928c9c7dd95af50bf81d6608e9163b
parentdc302eae5414f6bbf7c79234ed285fac572f4cdc (diff)
downloadmeta-qt5-fd86202d56c542011d24dc518457631bc00901c9.tar.gz
qtwebengine: add clang fix
Incorrectly removed previously, added back after rebasing it and the next patch touching the same file. Change-Id: I6f588b92e9356eec48f8dab88eee65cf84cce3c2 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0003-chromium-fix-build-with-clang.patch91
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch12
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
3 files changed, 98 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-fix-build-with-clang.patch b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-fix-build-with-clang.patch
new file mode 100644
index 00000000..de3a29dc
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-fix-build-with-clang.patch
@@ -0,0 +1,91 @@
1From c7bc761969c45232b561092ae2531d5eebacd019 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Feb 2019 19:28:59 -0800
4Subject: [PATCH] chromium: fix build with clang
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 chromium/build/config/compiler/BUILD.gn | 27 ++-----------------------
10 1 file changed, 2 insertions(+), 25 deletions(-)
11
12diff --git a/chromium/build/config/compiler/BUILD.gn b/chromium/build/config/compiler/BUILD.gn
13index be485fd89b9..7179df05451 100644
14--- a/chromium/build/config/compiler/BUILD.gn
15+++ b/chromium/build/config/compiler/BUILD.gn
16@@ -773,8 +773,6 @@ config("compiler_cpu_abi") {
17 }
18 } else if (current_cpu == "arm") {
19 if (is_clang && !is_android && !is_nacl) {
20- cflags += [ "--target=arm-linux-gnueabihf" ]
21- ldflags += [ "--target=arm-linux-gnueabihf" ]
22 }
23 if (!is_nacl) {
24 cflags += [
25@@ -787,8 +785,6 @@ config("compiler_cpu_abi") {
26 }
27 } else if (current_cpu == "arm64") {
28 if (is_clang && !is_android && !is_nacl && !is_fuchsia) {
29- cflags += [ "--target=aarch64-linux-gnu" ]
30- ldflags += [ "--target=aarch64-linux-gnu" ]
31 }
32 } else if (current_cpu == "mipsel" && !is_nacl) {
33 ldflags += [ "-Wl,--hash-style=sysv" ]
34@@ -797,9 +793,6 @@ config("compiler_cpu_abi") {
35 if (is_android) {
36 cflags += [ "--target=mipsel-linux-android" ]
37 ldflags += [ "--target=mipsel-linux-android" ]
38- } else {
39- cflags += [ "--target=mipsel-linux-gnu" ]
40- ldflags += [ "--target=mipsel-linux-gnu" ]
41 }
42 } else {
43 cflags += [ "-EL" ]
44@@ -878,10 +871,7 @@ config("compiler_cpu_abi") {
45 } else if (current_cpu == "mips" && !is_nacl) {
46 ldflags += [ "-Wl,--hash-style=sysv" ]
47 if (custom_toolchain == "") {
48- if (is_clang) {
49- cflags += [ "--target=mips-linux-gnu" ]
50- ldflags += [ "--target=mips-linux-gnu" ]
51- } else {
52+ if (!is_clang) {
53 cflags += [ "-EB" ]
54 ldflags += [ "-EB" ]
55 }
56@@ -928,9 +918,6 @@ config("compiler_cpu_abi") {
57 if (is_android) {
58 cflags += [ "--target=mips64el-linux-android" ]
59 ldflags += [ "--target=mips64el-linux-android" ]
60- } else {
61- cflags += [ "--target=mips64el-linux-gnuabi64" ]
62- ldflags += [ "--target=mips64el-linux-gnuabi64" ]
63 }
64 } else {
65 cflags += [
66@@ -987,10 +974,7 @@ config("compiler_cpu_abi") {
67 } else if (current_cpu == "mips64") {
68 ldflags += [ "-Wl,--hash-style=sysv" ]
69 if (custom_toolchain == "") {
70- if (is_clang) {
71- cflags += [ "--target=mips64-linux-gnuabi64" ]
72- ldflags += [ "--target=mips64-linux-gnuabi64" ]
73- } else {
74+ if (!is_clang) {
75 cflags += [
76 "-EB",
77 "-mabi=64",
78@@ -1169,13 +1153,6 @@ config("compiler_deterministic") {
79 }
80 }
81 }
82-
83- # Tells the compiler not to use absolute paths when passing the default
84- # paths to the tools it invokes. We don't want this because we don't
85- # really need it and it can mess up the goma cache entries.
86- if (is_clang && !is_nacl) {
87- cflags += [ "-no-canonical-prefixes" ]
88- }
89 }
90
91 config("clang_revision") {
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch
index 5f7901e8..61d01fef 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch
@@ -1,4 +1,4 @@
1From f49c5d488951027f1577f79681d448c3f30f6ae3 Mon Sep 17 00:00:00 2001 1From e7fa0c8b3c0a0a2d80180b032b1c73593e496f82 Mon Sep 17 00:00:00 2001
2From: Johannes Pointner <johannes.pointner@br-automation.com> 2From: Johannes Pointner <johannes.pointner@br-automation.com>
3Date: Fri, 3 May 2019 09:12:38 +0200 3Date: Fri, 3 May 2019 09:12:38 +0200
4Subject: [PATCH] chromium: Do not try to set the guessed values for 4Subject: [PATCH] chromium: Do not try to set the guessed values for
@@ -17,12 +17,12 @@ Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com>
17 1 file changed, 9 deletions(-) 17 1 file changed, 9 deletions(-)
18 18
19diff --git a/chromium/build/config/compiler/BUILD.gn b/chromium/build/config/compiler/BUILD.gn 19diff --git a/chromium/build/config/compiler/BUILD.gn b/chromium/build/config/compiler/BUILD.gn
20index 127d0c444bd..b653e933d6f 100644 20index 7179df05451..884c9714bbb 100644
21--- a/chromium/build/config/compiler/BUILD.gn 21--- a/chromium/build/config/compiler/BUILD.gn
22+++ b/chromium/build/config/compiler/BUILD.gn 22+++ b/chromium/build/config/compiler/BUILD.gn
23@@ -749,15 +749,6 @@ config("compiler_cpu_abi") { 23@@ -774,15 +774,6 @@ config("compiler_cpu_abi") {
24 cflags += [ "--target=arm-linux-gnueabihf" ] 24 } else if (current_cpu == "arm") {
25 ldflags += [ "--target=arm-linux-gnueabihf" ] 25 if (is_clang && !is_android && !is_nacl) {
26 } 26 }
27- if (!is_nacl) { 27- if (!is_nacl) {
28- cflags += [ 28- cflags += [
@@ -35,4 +35,4 @@ index 127d0c444bd..b653e933d6f 100644
35- } 35- }
36 } else if (current_cpu == "arm64") { 36 } else if (current_cpu == "arm64") {
37 if (is_clang && !is_android && !is_nacl && !is_fuchsia) { 37 if (is_clang && !is_android && !is_nacl && !is_fuchsia) {
38 cflags += [ "--target=aarch64-linux-gnu" ] 38 }
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 918a9e00..27af7b7e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -154,6 +154,7 @@ SRC_URI_append_libc-musl = "\
154SRC_URI += " \ 154SRC_URI += " \
155 file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 155 file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
156 file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \ 156 file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
157 file://chromium/0003-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
157 file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \ 158 file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
158 file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \ 159 file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
159 file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \ 160 file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \