summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2011-05-17 15:38:23 +0800
committerXiaofeng Yan <xiaofeng.yan@windriver.com>2011-05-17 15:38:23 +0800
commitd137fda6ea39c5f309800599672fed11f44ade9e (patch)
treef5bc9de4516dd94f49533feffd005ea08f2e9104
parent422a054589a05844c9eced03abf3664ec6cd33a0 (diff)
downloadmeta-qt3-xiaofeng/README.tar.gz
README: Update README of meta-qt3xiaofeng/README
The README is about how to get qt3 library when users want to get qt3 for their project. Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
-rw-r--r--README47
1 files changed, 42 insertions, 5 deletions
diff --git a/README b/README
index 9be700e..f82f781 100644
--- a/README
+++ b/README
@@ -1,8 +1,45 @@
1meta-qt3
2========
3This layer is just for passing LSB test because qt3 is one test item of LSB.
4You can get qt3 with two kinds of images(LSB image or custom image) \
5according to the following steps.
1 6
2README for meta-qt3 7---------------------------
8Get LSB image including qt3
9---------------------------
101 Enter poky directory
11 $ls
12 bitbake ... meta meta-demoapps meta-rt meta-yocto oe-init-build-env ... scripts
3 13
4To use this branch, add the path to this directory to your 142 Add meta-qt3 path to build/conf/bblayers.conf file
5conf/bblayers.conf file.
6 15
7You may also have to set DISTRO = "poky-lsb" in your conf/local.conf 163 Set DISTRO = "poky-lsb" in build/conf/local.conf file
8file. 17
184 Build lsb-image including qt3
19 $ bitbake core-image-lsb-qt3
20
21Note: "core-image-lsb-qt3" is the image to meet the demands of LSB.
22
23-----------------------------
24Get qt3 for your custom image
25-----------------------------
261 Enter poky directory
27 $ls
28 bitbake build ... meta ... meta-qt3 ... meta-yocto oe-init-build-env ... scripts
29
302 Add meta-qt3 path to build/conf/bblayers.conf file
31
323 Add task-core-qt3 file to your custom image.
33 For example, core-image-custom.bb is your building image file.
34 Go to your directory including your core-image-custom.bb file.
35 $vi core-image-custom.bb
36 .......
37 IMAGE_INSTALL = "\
38 ${POKY_BASE_INSTALL} \
39 task-core-basic \
40+ task-core-qt3 \
41 "
42 ......
43
444 Build your custom image in build directory
45 $ bitbake core-image-custom