diff options
Diffstat (limited to 'toolchain-layer/recipes-devtools')
4 files changed, 3 insertions, 37 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb index 5c2435fc9..29ddd6773 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb | |||
@@ -2,22 +2,3 @@ inherit cross-canadian | |||
2 | 2 | ||
3 | require recipes-devtools/gcc/gcc-${PV}.inc | 3 | require recipes-devtools/gcc/gcc-${PV}.inc |
4 | require recipes-devtools/gcc/gcc-cross-canadian.inc | 4 | require recipes-devtools/gcc/gcc-cross-canadian.inc |
5 | require recipes-devtools/gcc/gcc-configure-sdk.inc | ||
6 | require recipes-devtools/gcc/gcc-package-sdk.inc | ||
7 | |||
8 | DEPENDS += "nativesdk-gmp nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils" | ||
9 | RDEPENDS_${PN} += "nativesdk-mpfr nativesdk-libmpc nativesdk-elfutils" | ||
10 | |||
11 | SYSTEMHEADERS = "/usr/include" | ||
12 | SYSTEMLIBS = "/lib/" | ||
13 | SYSTEMLIBS1 = "/usr/lib/" | ||
14 | |||
15 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | ||
16 | --disable-libgomp --disable-libmudflap \ | ||
17 | --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \ | ||
18 | --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}" | ||
19 | |||
20 | # to find libmpfr | ||
21 | # export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}" | ||
22 | |||
23 | PARALLEL_MAKE = "" | ||
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb index eb8896ca5..cdaa7e8cd 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross_4.6.bb | |||
@@ -1,8 +1,2 @@ | |||
1 | require recipes-devtools/gcc/gcc-${PV}.inc | 1 | require recipes-devtools/gcc/gcc-${PV}.inc |
2 | require recipes-devtools/gcc/gcc-cross4.inc | 2 | require recipes-devtools/gcc/gcc-cross.inc |
3 | |||
4 | EXTRA_OECONF += "--disable-libunwind-exceptions \ | ||
5 | --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \ | ||
6 | --with-system-zlib " | ||
7 | |||
8 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" | ||
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb index 13431c8b6..b755f555e 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc-runtime_4.6.bb | |||
@@ -1,8 +1,2 @@ | |||
1 | require recipes-devtools/gcc/gcc-${PV}.inc | 1 | require recipes-devtools/gcc/gcc-${PV}.inc |
2 | require recipes-devtools/gcc/gcc-configure-runtime.inc | 2 | require recipes-devtools/gcc/gcc-runtime.inc |
3 | require recipes-devtools/gcc/gcc-package-runtime.inc | ||
4 | |||
5 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}" | ||
6 | |||
7 | EXTRA_OECONF += "--disable-libunwind-exceptions" | ||
8 | EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu" | ||
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb index 97e6c324d..6ad8973b4 100644 --- a/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb +++ b/toolchain-layer/recipes-devtools/gcc/gcc_4.6.bb | |||
@@ -1,5 +1,2 @@ | |||
1 | require recipes-devtools/gcc/gcc-${PV}.inc | 1 | require recipes-devtools/gcc/gcc-${PV}.inc |
2 | require recipes-devtools/gcc/gcc-configure-target.inc | 2 | require recipes-devtools/gcc/gcc-target.inc |
3 | require recipes-devtools/gcc/gcc-package-target.inc | ||
4 | |||
5 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}" | ||