diff options
Diffstat (limited to 'toolchain-layer/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99304.patch')
-rw-r--r-- | toolchain-layer/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99304.patch | 81 |
1 files changed, 0 insertions, 81 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99304.patch b/toolchain-layer/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99304.patch deleted file mode 100644 index ab1296347b..0000000000 --- a/toolchain-layer/recipes-devtools/gcc/gcc-4.5/linaro/gcc-4.5-linaro-r99304.patch +++ /dev/null | |||
@@ -1,81 +0,0 @@ | |||
1 | 2010-07-10 Yao Qi <yao@codesourcery.com> | ||
2 | |||
3 | Merge from Sourcery G++ 4.4: | ||
4 | |||
5 | 2009-05-28 Julian Brown <julian@codesourcery.com> | ||
6 | |||
7 | Merged from Sourcery G++ 4.3: | ||
8 | |||
9 | libgcc/ | ||
10 | * config.host (arm*-*-linux*, arm*-*-uclinux*, arm*-*-eabi*) | ||
11 | (arm*-*-symbianelf): Add arm/t-divmod-ef to tmake_file. | ||
12 | * Makefile.in (LIB2_DIVMOD_EXCEPTION_FLAGS): Set to previous | ||
13 | default if not set by a target-specific Makefile fragment. | ||
14 | (lib2-divmod-o, lib2-divmod-s-o): Use above. | ||
15 | * config/arm/t-divmod-ef: New. | ||
16 | |||
17 | 2010-07-09 Sandra Loosemore <sandra@codesourcery.com> | ||
18 | |||
19 | Merge from Sourcery G++ 4.4: | ||
20 | |||
21 | === modified file 'libgcc/Makefile.in' | ||
22 | --- old/libgcc/Makefile.in 2010-03-30 12:08:52 +0000 | ||
23 | +++ new/libgcc/Makefile.in 2010-07-30 12:21:02 +0000 | ||
24 | @@ -400,18 +400,24 @@ | ||
25 | endif | ||
26 | endif | ||
27 | |||
28 | +ifeq ($(LIB2_DIVMOD_EXCEPTION_FLAGS),) | ||
29 | +# Provide default flags for compiling divmod functions, if they haven't been | ||
30 | +# set already by a target-specific Makefile fragment. | ||
31 | +LIB2_DIVMOD_EXCEPTION_FLAGS := -fexceptions -fnon-call-exceptions | ||
32 | +endif | ||
33 | + | ||
34 | # Build LIB2_DIVMOD_FUNCS. | ||
35 | lib2-divmod-o = $(patsubst %,%$(objext),$(LIB2_DIVMOD_FUNCS)) | ||
36 | $(lib2-divmod-o): %$(objext): $(gcc_srcdir)/libgcc2.c | ||
37 | $(gcc_compile) -DL$* -c $(gcc_srcdir)/libgcc2.c \ | ||
38 | - -fexceptions -fnon-call-exceptions $(vis_hide) | ||
39 | + $(LIB2_DIVMOD_EXCEPTION_FLAGS) $(vis_hide) | ||
40 | libgcc-objects += $(lib2-divmod-o) | ||
41 | |||
42 | ifeq ($(enable_shared),yes) | ||
43 | lib2-divmod-s-o = $(patsubst %,%_s$(objext),$(LIB2_DIVMOD_FUNCS)) | ||
44 | $(lib2-divmod-s-o): %_s$(objext): $(gcc_srcdir)/libgcc2.c | ||
45 | $(gcc_s_compile) -DL$* -c $(gcc_srcdir)/libgcc2.c \ | ||
46 | - -fexceptions -fnon-call-exceptions | ||
47 | + $(LIB2_DIVMOD_EXCEPTION_FLAGS) | ||
48 | libgcc-s-objects += $(lib2-divmod-s-o) | ||
49 | endif | ||
50 | |||
51 | |||
52 | === modified file 'libgcc/config.host' | ||
53 | --- old/libgcc/config.host 2010-04-02 02:02:18 +0000 | ||
54 | +++ new/libgcc/config.host 2010-07-30 12:21:02 +0000 | ||
55 | @@ -208,12 +208,15 @@ | ||
56 | arm*-*-netbsd*) | ||
57 | ;; | ||
58 | arm*-*-linux*) # ARM GNU/Linux with ELF | ||
59 | + tmake_file="${tmake_file} arm/t-divmod-ef" | ||
60 | ;; | ||
61 | arm*-*-uclinux*) # ARM ucLinux | ||
62 | + tmake_file="${tmake_file} arm/t-divmod-ef" | ||
63 | ;; | ||
64 | arm*-*-ecos-elf) | ||
65 | ;; | ||
66 | arm*-*-eabi* | arm*-*-symbianelf* ) | ||
67 | + tmake_file="${tmake_file} arm/t-divmod-ef" | ||
68 | ;; | ||
69 | arm*-*-rtems*) | ||
70 | ;; | ||
71 | |||
72 | === added directory 'libgcc/config/arm' | ||
73 | === added file 'libgcc/config/arm/t-divmod-ef' | ||
74 | --- old/libgcc/config/arm/t-divmod-ef 1970-01-01 00:00:00 +0000 | ||
75 | +++ new/libgcc/config/arm/t-divmod-ef 2010-07-30 12:21:02 +0000 | ||
76 | @@ -0,0 +1,4 @@ | ||
77 | +# On ARM, specifying -fnon-call-exceptions will needlessly pull in | ||
78 | +# the unwinder in simple programs which use 64-bit division. Omitting | ||
79 | +# the option is safe. | ||
80 | +LIB2_DIVMOD_EXCEPTION_FLAGS := -fexceptions | ||
81 | |||