summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/directfb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/directfb')
-rw-r--r--recipes-graphics/directfb/++dfb/dfb-api-change.patch13
-rw-r--r--recipes-graphics/directfb/++dfb_1.0.0.bb21
-rw-r--r--recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch22
-rw-r--r--recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch24
-rw-r--r--recipes-graphics/directfb/directfb-examples_1.0.0.bb14
-rw-r--r--recipes-graphics/directfb/directfb-examples_1.2.0.bb14
-rw-r--r--recipes-graphics/directfb/directfb.inc73
-rw-r--r--recipes-graphics/directfb/directfb_1.4.6.bb27
-rw-r--r--recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch47
-rw-r--r--recipes-graphics/directfb/files/dont-use-linux-config.patch12
-rw-r--r--recipes-graphics/directfb/files/fix-font-missing-char.patch11
-rw-r--r--recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch45
-rw-r--r--recipes-graphics/directfb/files/getpagesize.patch16
-rw-r--r--recipes-graphics/directfb/files/mkdfiff.patch11
-rw-r--r--recipes-graphics/directfb/files/ts_lib_autotools.patch16
-rw-r--r--recipes-graphics/directfb/files/use_limits_h.patch10
-rw-r--r--recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch23
-rw-r--r--recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb55
-rw-r--r--recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb36
19 files changed, 0 insertions, 490 deletions
diff --git a/recipes-graphics/directfb/++dfb/dfb-api-change.patch b/recipes-graphics/directfb/++dfb/dfb-api-change.patch
deleted file mode 100644
index bec4e4cd8..000000000
--- a/recipes-graphics/directfb/++dfb/dfb-api-change.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff -ruN ++DFB-1.0.0-orig/include/++dfb.h ++DFB-1.0.0/include/++dfb.h
2--- ++DFB-1.0.0-orig/include/++dfb.h 2007-02-02 23:48:36.000000000 +0100
3+++ ++DFB-1.0.0/include/++dfb.h 2010-06-09 11:53:07.000000000 +0200
4@@ -46,6 +46,9 @@
5
6 #include <directfb.h>
7
8+// Work around old lib expectations.
9+typedef u8 __u8;
10+
11 #undef IDirectFB
12 #undef IDirectFBScreen
13 #undef IDirectFBDisplayLayer
diff --git a/recipes-graphics/directfb/++dfb_1.0.0.bb b/recipes-graphics/directfb/++dfb_1.0.0.bb
deleted file mode 100644
index 40413b95d..000000000
--- a/recipes-graphics/directfb/++dfb_1.0.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
2HOMEPAGE = "http://directfb.org"
3SECTION = "libs"
4DEPENDS = "directfb"
5LICENSE = "LGPL"
6
7PR = "r1"
8SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz \
9 file://dfb-api-change.patch"
10S = "${WORKDIR}/++DFB-${PV}"
11RV = "0.9-25"
12
13inherit autotools pkgconfig
14
15do_install() {
16 oe_runmake 'DESTDIR=${D}' install
17}
18FILES_++dfb_append = " ${libdir}/*.so*"
19
20SRC_URI[md5sum] = "bfc2c45be253a5f25576587f61faff1b"
21SRC_URI[sha256sum] = "bc5b7766318ef6676defdf0103d1b53b48a3fee6b819fbe2076461caa9f94ec9"
diff --git a/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch b/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch
deleted file mode 100644
index 7c34b567d..000000000
--- a/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1---
2 configure.in | 7 +++++--
3 1 file changed, 5 insertions(+), 2 deletions(-)
4
5Index: DirectFB-1.2.8/configure.in
6===================================================================
7--- DirectFB-1.2.8.orig/configure.in
8+++ DirectFB-1.2.8/configure.in
9@@ -1288,8 +1288,11 @@ fi
10
11 enable_tslib=no
12 if test "$checkfor_tslib" = "yes"; then
13- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
14- AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
15+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
16+ if test "$enable_tslib" = "no"; then
17+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
18+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
19+ fi
20 fi
21
22 enable_ucb1x00_ts=no
diff --git a/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch b/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch
deleted file mode 100644
index 28bd534f3..000000000
--- a/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1diff -uNr DirectFB-1.4.6.orig/tools/mkdfiff.c DirectFB-1.4.6/tools/mkdfiff.c
2--- DirectFB-1.4.6.orig/tools/mkdfiff.c 2010-10-15 10:54:57.000000000 +0200
3+++ DirectFB-1.4.6/tools/mkdfiff.c 2010-10-15 10:54:15.000000000 +0200
4@@ -50,6 +50,8 @@
5
6 #include <dfiff.h>
7
8+#include <unistd.h>
9+
10 static DirectFBPixelFormatNames( format_names );
11
12 static const char *filename;
13diff -uNr DirectFB-1.4.6.orig/tools/mkdgifft.cpp DirectFB-1.4.6/tools/mkdgifft.cpp
14--- DirectFB-1.4.6.orig/tools/mkdgifft.cpp 2010-10-08 14:02:57.000000000 +0200
15+++ DirectFB-1.4.6/tools/mkdgifft.cpp 2010-10-15 10:56:06.000000000 +0200
16@@ -40,6 +40,8 @@
17 #include <errno.h>
18 #include <stdio.h>
19 #include <stdlib.h>
20+#include <sys/stat.h>
21+#include <sys/types.h>
22 #include <unistd.h>
23 #include <fcntl.h>
24 #include <sys/mman.h>
diff --git a/recipes-graphics/directfb/directfb-examples_1.0.0.bb b/recipes-graphics/directfb/directfb-examples_1.0.0.bb
deleted file mode 100644
index a6a374d6a..000000000
--- a/recipes-graphics/directfb/directfb-examples_1.0.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "DirectFB extra providers"
2DEPENDS = "directfb"
3SECTION = "libs"
4LICENSE = "GPL"
5
6SRC_URI = " \
7 http://www.directfb.org/downloads/Old/DirectFB-examples-${PV}.tar.gz \
8 "
9S = "${WORKDIR}/DirectFB-examples-${PV}"
10
11inherit autotools
12
13SRC_URI[md5sum] = "0cdfb4dd248eada3dc35db4f8cf75f8d"
14SRC_URI[sha256sum] = "c54e779a720841126e23d692de85243e23b0d94fb7792a958b96b5bd097a8b85"
diff --git a/recipes-graphics/directfb/directfb-examples_1.2.0.bb b/recipes-graphics/directfb/directfb-examples_1.2.0.bb
deleted file mode 100644
index 6040bc35d..000000000
--- a/recipes-graphics/directfb/directfb-examples_1.2.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "DirectFB extra providers"
2DEPENDS = "directfb"
3SECTION = "libs"
4LICENSE = "GPL"
5
6SRC_URI = " \
7 http://www.directfb.org/downloads/Extras/DirectFB-examples-${PV}.tar.gz \
8 "
9S = "${WORKDIR}/DirectFB-examples-${PV}"
10
11inherit autotools
12
13SRC_URI[md5sum] = "ce018f681b469a1d72ffc32650304b98"
14SRC_URI[sha256sum] = "830a1bd6775d8680523596a88a72fd8e4c6a74bf886d3e169b06d234a5cf7e3e"
diff --git a/recipes-graphics/directfb/directfb.inc b/recipes-graphics/directfb/directfb.inc
deleted file mode 100644
index ca22d24e7..000000000
--- a/recipes-graphics/directfb/directfb.inc
+++ /dev/null
@@ -1,73 +0,0 @@
1DESCRIPTION = "DirectFB is a thin library that provides developers \
2with hardware graphics acceleration, input device handling and \
3abstraction, an integrated windowing system with support for \
4translucent windows and multiple display layers on top of the \
5Linux framebuffer device."
6SECTION = "libs"
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
9
10HOMEPAGE = "http://directfb.org"
11DEPENDS = "jpeg libpng freetype zlib tslib"
12
13SRC_URI = " \
14 http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
15 file://fix-pkgconfig-cflags.patch \
16 file://fix-font-missing-char.patch \
17 file://getpagesize.patch \
18 file://mkdfiff.patch \
19 file://dont-use-linux-config.patch \
20 file://ts_lib_autotools.patch \
21"
22S = "${WORKDIR}/DirectFB-${PV}"
23
24LDFLAGS_append =" -lts -lm"
25
26inherit autotools binconfig pkgconfig
27
28EXTRA_OECONF = "\
29 --with-gfxdrivers=none \
30 --enable-libmpeg3=no \
31 --enable-freetype=yes \
32 --enable-sdl=no \
33 --enable-vnc=no \
34 --disable-x11 \
35"
36
37do_install() {
38 oe_runmake 'DESTDIR=${D}' install
39}
40
41
42#PACKAGES_DYNAMIC = "directfb-inputdrivers-*"
43#
44#python populate_packages_prepend () {
45# import os.path
46# inputdrivers_libdir = bb.data.expand('${libdir}/directfb-${RV}/inputdrivers', d)
47# do_split_packages(d, inputdrivers_libdir, '*.so$', 'directfb-inputdrivers-%s', 'Directfb plugin for %s')
48#}
49
50# NOTE: monolithic packaging for now, should improve that eventually
51
52
53
54FILES_${PN}-dbg += "\
55 ${libdir}/directfb-${RV}/*/*/.debug/*.so \
56 ${libdir}/directfb-${RV}/*/.debug/*.so \
57"
58
59FILES_${PN}-dev += "\
60 ${bindir}/directfb-config \
61 ${libdir}/directfb-${RV}/systems/*.la \
62 ${libdir}/directfb-${RV}/inputdrivers/*.la \
63 ${libdir}/directfb-${RV}/interfaces/*/*.la \
64 ${libdir}/directfb-${RV}/wm/*.la \
65"
66
67FILES_${PN} += "\
68 ${libdir}/directfb-${RV}/systems/*.so \
69 ${libdir}/directfb-${RV}/inputdrivers/*.so \
70 ${libdir}/directfb-${RV}/interfaces/*/*.so \
71 ${libdir}/directfb-${RV}/wm/*.so \
72 ${datadir}/directfb-${PV} \
73"
diff --git a/recipes-graphics/directfb/directfb_1.4.6.bb b/recipes-graphics/directfb/directfb_1.4.6.bb
deleted file mode 100644
index 70c0225bf..000000000
--- a/recipes-graphics/directfb/directfb_1.4.6.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1require directfb.inc
2
3RV = "1.4-5"
4PR = "r2"
5
6DEPENDS += "sysfsutils"
7
8SRC_URI = " \
9 http://directfb.org/downloads/Core/DirectFB-1.4/DirectFB-${PV}.tar.gz \
10 file://directfb-1.2.x-fix-pkgconfig-cflags.patch \
11 file://mkdfiff.patch \
12 file://dont-use-linux-config.patch \
13 "
14
15EXTRA_OECONF = "\
16 --enable-freetype=yes \
17 --enable-zlib \
18 --with-gfxdrivers=none \
19 --disable-sdl \
20 --disable-vnc \
21 --disable-x11 \
22"
23
24LEAD_SONAME = "libdirectfb-1.4.so.5"
25
26SRC_URI[md5sum] = "dbe1957932f81790742b58b94c1c7b84"
27SRC_URI[sha256sum] = "b18121e60e9a084ee347037a53a46cfaea1c09505bd99d673c2e65eca285e69b"
diff --git a/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
deleted file mode 100644
index 745c561cc..000000000
--- a/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1Index: DirectFB-1.1.1/directfb-internal.pc.in
2===================================================================
3--- DirectFB-1.1.1.orig/directfb-internal.pc.in 2007-08-07 21:43:00.000000000 +0200
4+++ DirectFB-1.1.1/directfb-internal.pc.in 2008-07-17 21:00:47.424654304 +0200
5@@ -2,10 +2,10 @@
6 exec_prefix=@exec_prefix@
7 moduledir=@MODULEDIR@
8 moduledirname=@MODULEDIRNAME@
9-includedir=@INTERNALINCLUDEDIR@
10+includedir=@includedir@
11
12 Name: DirectFB-Internal
13 Description: Third party module support package for DirectFB.
14 Version: @VERSION@
15 Requires: directfb = @VERSION@
16-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
17+Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
18Index: DirectFB-1.1.1/directfb.pc.in
19===================================================================
20--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
21+++ DirectFB-1.1.1/directfb.pc.in 2008-07-17 20:59:58.044985193 +0200
22@@ -9,4 +9,4 @@
23 Requires: fusion direct
24 Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
25 Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
26-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
27+Cflags: @THREADFLAGS@ -I${includedir}/directfb
28Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
29===================================================================
30--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in 2007-08-07 21:43:00.000000000 +0200
31+++ DirectFB-1.1.1/lib/fusion/fusion.pc.in 2008-07-17 20:58:07.051338866 +0200
32@@ -8,4 +8,4 @@
33 Version: @VERSION@
34 Requires: direct
35 Libs: -L${libdir} -lfusion
36-Cflags: -I@INCLUDEDIR@
37+Cflags: -I${includedir}/directfb -I${includedir}
38Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
39===================================================================
40--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in 2007-08-07 21:43:00.000000000 +0200
41+++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in 2008-07-17 20:58:07.054671842 +0200
42@@ -8,4 +8,4 @@
43 Version: @VERSION@
44 Requires: direct
45 Libs: -L${libdir} -lvoodoo
46-Cflags: -I@INCLUDEDIR@
47+Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes-graphics/directfb/files/dont-use-linux-config.patch b/recipes-graphics/directfb/files/dont-use-linux-config.patch
deleted file mode 100644
index f97166095..000000000
--- a/recipes-graphics/directfb/files/dont-use-linux-config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -urN DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S
2--- DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S 2007-08-07 21:43:00.000000000 +0200
3+++ DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S 2008-06-07 04:14:26.000000000 +0200
4@@ -34,8 +34,6 @@
5
6 #define __ASSEMBLY__
7
8-#include <linux/config.h>
9-
10 #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
11 #define L1_CACHE_LINE_SIZE 16
12 #define LG_L1_CACHE_LINE_SIZE 4
diff --git a/recipes-graphics/directfb/files/fix-font-missing-char.patch b/recipes-graphics/directfb/files/fix-font-missing-char.patch
deleted file mode 100644
index 4c5e5883f..000000000
--- a/recipes-graphics/directfb/files/fix-font-missing-char.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- git/src/media/idirectfbfont.c~org 2007-07-10 10:35:46.000000000 -0400
2+++ git/src/media/idirectfbfont.c 2007-07-10 10:36:09.000000000 -0400
3@@ -497,7 +497,7 @@
4
5 if (width<max_width && string >= end) {
6 *ret_next_line = NULL;
7- *ret_str_length = length-1;
8+ *ret_str_length = length;
9 *ret_width = width;
10
11 return DFB_OK;
diff --git a/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch
deleted file mode 100644
index ddaa276fc..000000000
--- a/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
2--- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
3+++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
4@@ -8,4 +8,4 @@
5 Description: Third party module support package for DirectFB.
6 Version: @VERSION@
7 Requires: directfb = @VERSION@
8-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
9+Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
10diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
11--- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
12+++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
13@@ -8,4 +8,4 @@
14 Version: @VERSION@
15 Requires: fusion direct
16 Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
17-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
18+Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
19diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
20--- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
21+++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
22@@ -7,4 +7,4 @@
23 Description: DirectFB base development library
24 Version: @VERSION@
25 Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
26-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
27+Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
28diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
29--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
30+++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
31@@ -8,4 +8,4 @@
32 Version: @VERSION@
33 Requires: direct
34 Libs: -L${libdir} -lfusion
35-Cflags: -I@INCLUDEDIR@
36+Cflags: -I${includedir}/directfb -I${includedir}
37diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
38--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
39+++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
40@@ -8,4 +8,4 @@
41 Version: @VERSION@
42 Requires: direct
43 Libs: -L${libdir} -lvoodoo
44-Cflags: -I@INCLUDEDIR@
45+Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes-graphics/directfb/files/getpagesize.patch b/recipes-graphics/directfb/files/getpagesize.patch
deleted file mode 100644
index 256b8db29..000000000
--- a/recipes-graphics/directfb/files/getpagesize.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1diff --git a/lib/direct/system.c b/lib/direct/system.c
2index 8dd3f12..0731fa2 100644
3--- a/lib/direct/system.c
4+++ b/lib/direct/system.c
5@@ -36,8 +36,9 @@
6
7 #if HAVE_ASM_PAGE_H
8 #include <asm/page.h>
9-#else
10-#define PAGE_SIZE sysconf( _SC_PAGESIZE )
11+#endif
12+#ifndef PAGE_SIZE
13+# define PAGE_SIZE (getpagesize())
14 #endif
15
16
diff --git a/recipes-graphics/directfb/files/mkdfiff.patch b/recipes-graphics/directfb/files/mkdfiff.patch
deleted file mode 100644
index cb56fd360..000000000
--- a/recipes-graphics/directfb/files/mkdfiff.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- DirectFB-1.0.0-rc1~org/tools/mkdfiff.c 2006-10-12 13:45:50.000000000 -0400
2+++ DirectFB-1.0.0-rc1/tools/mkdfiff.c 2006-10-12 13:57:38.000000000 -0400
3@@ -15,6 +15,8 @@
4
5 #include <dfiff.h>
6
7+#include <unistd.h>
8+
9 static DirectFBPixelFormatNames( format_names );
10
11 static const char *filename;
diff --git a/recipes-graphics/directfb/files/ts_lib_autotools.patch b/recipes-graphics/directfb/files/ts_lib_autotools.patch
deleted file mode 100644
index ced710478..000000000
--- a/recipes-graphics/directfb/files/ts_lib_autotools.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1Index: DirectFB-1.1.1/configure.in
2===================================================================
3--- DirectFB-1.1.1.orig/configure.in 2008-05-07 23:08:04.000000000 +0200
4+++ DirectFB-1.1.1/configure.in 2008-05-07 23:15:43.000000000 +0200
5@@ -1292,8 +1292,11 @@
6
7 enable_tslib=no
8 if test "$checkfor_tslib" = "yes"; then
9+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
10+ if test "$enable_tslib" = "no"; then
11 PKG_CHECK_MODULES([TSLIB], [tslib-0.0 >= 0.0.2], enable_tslib=yes, enable_tslib=no
12 AC_MSG_WARN([*** no tslib -- tslib driver will not be built.]))
13+ fi
14 fi
15
16 enable_ucb1x00_ts=no
diff --git a/recipes-graphics/directfb/files/use_limits_h.patch b/recipes-graphics/directfb/files/use_limits_h.patch
deleted file mode 100644
index 327cd7a16..000000000
--- a/recipes-graphics/directfb/files/use_limits_h.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1--- FusionSound-1.0.0.orig/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
2+++ FusionSound-1.0.0/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
3@@ -109,6 +109,7 @@ typedef struct {
4
5 #if defined(__linux__)
6
7+#include <limits.h>
8 #include <linux/cdrom.h>
9
10 static DFBResult
diff --git a/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
deleted file mode 100644
index 0eb4c7519..000000000
--- a/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1--- git/fusionsound.pc.in~org 2008-08-19 11:04:27.000000000 -0400
2+++ git/fusionsound.pc.in 2008-08-19 11:06:20.000000000 -0400
3@@ -8,4 +8,4 @@
4 Description: Multi application sound streaming and mixing
5 Version: @VERSION@
6 Libs: -L${libdir} -lfusionsound
7-Cflags: -I@INCLUDEDIR@
8+Cflags: -I${includedir}/fusionsound
9--- git/fusionsound-internal.pc.in~org 2008-08-19 11:11:57.000000000 -0400
10+++ git/fusionsound-internal.pc.in 2008-08-19 11:08:31.000000000 -0400
11@@ -1,10 +1,10 @@
12 prefix=@prefix@
13 exec_prefix=@exec_prefix@
14 moduledir=@MODULEDIR@
15-includedir=@INTERNALINCLUDEDIR@
16+includedir=@includedir@
17
18 Name: FusionSound-Internal
19 Description: Third party module support package for FusionSound.
20 Version: @VERSION@
21 Requires: fusionsound = @VERSION@
22-Cflags: -I@INTERNALINCLUDEDIR@
23+Cflags: -I${includedir}/fusionsound -I${includedir}
diff --git a/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb b/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb
deleted file mode 100644
index 2b580190c..000000000
--- a/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1DESCRIPTION = "FusionSound for DirectFB"
2DEPENDS = "directfb"
3SECTION = "libs"
4LICENSE = "LGPL"
5PR = "r2"
6
7SRC_URI = "git://git.directfb.org/git/directfb/core/FusionSound;protocol=git;tag=0b2162b570c8314fd1240b08d6ab4a8d074ccf37 \
8 file://fix-pkgconfig-cflags.patch \
9 file://use_limits_h.patch \
10"
11
12S = "${WORKDIR}/git"
13
14inherit autotools pkgconfig
15
16CFLAGS_append += " -I${STAGING_INCDIR}/directfb -I${STAGING_INCDIR}/directfb-internal"
17
18#Below are some of the configure options
19EXTRA_OECONF = " \
20 --disable-ieee-floats \
21 --disable-precision \
22 --enable-linear-filter \
23 --disable-dithering \
24 --enable-debug \
25 --enable-examples \
26 --enable-module \
27 --disable-timidity \
28 --disable-wave \
29 --enable-vorbis \
30 --enable-tremor \
31 --disable-mad \
32 --disable-cdda \
33 --disable-playlist \
34 "
35
36do_configure_append() {
37 find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
38}
39
40do_install() {
41 oe_runmake 'DESTDIR=${D}' install
42}
43
44FILES_fusionsound-dbg_append = " ${libdir}/directfb-1.1-0/*/*/.debug/*.so \
45 ${libdir}/directfb-1.1-0/*/.debug/*.so \
46 "
47
48FILES_fusionsound-dev_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.la \
49 ${libdir}/directfb-1.1-0/snddrivers/*.la \
50 "
51
52FILES_fusionsound_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.so \
53 ${libdir}/directfb-1.1-0/snddrivers/*.so \
54 "
55
diff --git a/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb b/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb
deleted file mode 100644
index 231a1efec..000000000
--- a/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1DESCRIPTION = "LiTE stands for Lightweight Toolkit Enabler. Its role is to \
2 facilitate the functions of DirectFB so that a toolbox could \
3 be written on top of DirectFB with less effort. As such LiTE \
4 has abstractions for the underlying graphics and event systems."
5
6DEPENDS = "directfb"
7SECTION = "libs"
8LICENSE = "LGPL"
9
10# this is a CVS only release
11
12SRC_URI = "cvs://anonymous@cvs.directfb.org/cvs/directfb;method=pserver;module=lite;date=${@bb.data.getVar('PV', d, 1)[10:]}"
13
14S = "${WORKDIR}/lite"
15
16inherit autotools pkgconfig
17
18do_configure_append() {
19 find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
20}
21
22do_install() {
23 oe_runmake 'DESTDIR=${D}' install
24}
25
26FILES_lite-dbg_append = " ${libdir}/directfb-1.0-0/*/*/.debug/*.so \
27 ${libdir}/directfb-1.0-0/*/.debug/*.so \
28 "
29FILES_lite-dev_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.la \
30 "
31
32FILES_lite_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.so \
33 ${datadir}/LiTE/* \
34 ${datadir}/fonts/truetype/* \
35 "
36