summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng-2.17/fdiskbsdlabel.h-nios2.patch14
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng-2.17/tls.patch70
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng-2.17/uclibc-compile.patch13
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng-2.17/util-linux-ng-replace-siginterrupt.patch23
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng.inc321
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng/chinook_libtool.patch13
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng/fix-make-c.patch41
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng/optional-uuid.patch55
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng/uclibc-compile.patch25
-rw-r--r--recipes-core/util-linux-ng/util-linux-ng_2.17.bb18
10 files changed, 0 insertions, 593 deletions
diff --git a/recipes-core/util-linux-ng/util-linux-ng-2.17/fdiskbsdlabel.h-nios2.patch b/recipes-core/util-linux-ng/util-linux-ng-2.17/fdiskbsdlabel.h-nios2.patch
deleted file mode 100644
index 5b5051e95..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng-2.17/fdiskbsdlabel.h-nios2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Index: util-linux-ng-2.17/fdisk/fdiskbsdlabel.h
2===================================================================
3--- util-linux-ng-2.17.orig/fdisk/fdiskbsdlabel.h 2010-07-07 14:13:04.073530165 +0200
4+++ util-linux-ng-2.17/fdisk/fdiskbsdlabel.h 2010-07-07 14:13:43.053535150 +0200
5@@ -48,7 +48,8 @@
6
7 #if defined (i386) || defined (__sparc__) || defined (__arm__) || \
8 defined (__mips__) || defined (__s390__) || defined (__sh__) || \
9- defined(__x86_64__) || defined (__avr32__) || defined(__cris__)
10+ defined(__x86_64__) || defined (__avr32__) || defined(__cris__) || \
11+ defined (__nios2__)
12 #define BSD_LABELSECTOR 1
13 #define BSD_LABELOFFSET 0
14 #elif defined (__alpha__) || defined (__powerpc__) || defined (__ia64__) || defined (__hppa__)
diff --git a/recipes-core/util-linux-ng/util-linux-ng-2.17/tls.patch b/recipes-core/util-linux-ng/util-linux-ng-2.17/tls.patch
deleted file mode 100644
index bdb29cae1..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng-2.17/tls.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1Index: util-linux-ng-2.16/m4/tls.m4
2===================================================================
3--- util-linux-ng-2.16.orig/m4/tls.m4 2009-07-04 01:20:03.000000000 +0200
4+++ util-linux-ng-2.16/m4/tls.m4 2009-07-30 01:57:30.151697033 +0200
5@@ -18,31 +18,26 @@
6 # version as well.
7 #
8 AC_DEFUN([AX_TLS], [
9- AC_MSG_CHECKING(for thread local storage (TLS) class)
10- AC_CACHE_VAL(ac_cv_tls, [
11- ax_tls_keywords="__thread __declspec(thread) none"
12- for ax_tls_keyword in $ax_tls_keywords; do
13- case $ax_tls_keyword in
14- none) ac_cv_tls=none ; break ;;
15- *)
16- AC_TRY_COMPILE(
17- [#include <stdlib.h>
18- static void
19- foo(void) {
20- static ] $ax_tls_keyword [ int bar;
21- exit(1);
22- }],
23- [],
24- [ac_cv_tls=$ax_tls_keyword ; break],
25- ac_cv_tls=none
26- )
27- esac
28- done
29-])
30+ AC_CACHE_CHECK([for thread local storage (TLS) class],
31+ ac_cv_tls,
32+ [AC_LINK_IFELSE([__thread int a; int b; int main() { return a = b; }],
33+ [chktls_save_LDFLAGS="$LDFLAGS"
34+ LDFLAGS="-shared -Wl,--no-undefined $LDFLAGS"
35+ chktls_save_CFLAGS="$CFLAGS"
36+ CFLAGS="-fPIC $CFLAGS"
37+ dnl If -shared works, test if TLS works in a shared library.
38+ AC_LINK_IFELSE([int f() { return 0; }],
39+ AC_LINK_IFELSE([__thread int a; int b; int f() { return a = b; }],
40+ [ac_cv_tls=yes],
41+ [ac_cv_tls=no]),
42+ [ac_cv_tls=yes])
43+ CFLAGS="$chktls_save_CFLAGS"
44+ LDFLAGS="$chktls_save_LDFLAGS"], [ac_cv_tls=no])
45+ ])
46
47- if test "$ac_cv_tls" != "none"; then
48- dnl AC_DEFINE([TLS], [], [If the compiler supports a TLS storage class define it to that here])
49- AC_DEFINE_UNQUOTED([TLS], $ac_cv_tls, [If the compiler supports a TLS storage class define it to that here])
50- fi
51- AC_MSG_RESULT($ac_cv_tls)
52+ AS_IF([test "x$ac_cv_tls" = "xyes"],
53+ [AC_DEFINE([TLS], 1,
54+ [Define this if the compiler supports __thread for Thread-Local Storage])
55+ $1],
56+ [$2])
57 ])
58Index: util-linux-ng-2.16/shlibs/uuid/src/gen_uuid.c
59===================================================================
60--- util-linux-ng-2.16.orig/shlibs/uuid/src/gen_uuid.c 2009-07-30 02:31:48.518159459 +0200
61+++ util-linux-ng-2.16/shlibs/uuid/src/gen_uuid.c 2009-07-30 02:32:04.867871183 +0200
62@@ -99,7 +99,7 @@
63 #endif
64
65 #ifdef TLS
66-#define THREAD_LOCAL static TLS
67+#define THREAD_LOCAL static __thread
68 #else
69 #define THREAD_LOCAL static
70 #endif
diff --git a/recipes-core/util-linux-ng/util-linux-ng-2.17/uclibc-compile.patch b/recipes-core/util-linux-ng/util-linux-ng-2.17/uclibc-compile.patch
deleted file mode 100644
index b2e8a8b95..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng-2.17/uclibc-compile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: util-linux-ng-2.16/misc-utils/cal.c
2===================================================================
3--- util-linux-ng-2.16.orig/misc-utils/cal.c 2009-07-03 16:20:01.000000000 -0700
4+++ util-linux-ng-2.16/misc-utils/cal.c 2009-07-18 23:21:37.000000000 -0700
5@@ -407,7 +407,7 @@
6 strcpy(day_headings,"");
7 strcpy(j_day_headings,"");
8
9-#ifdef HAVE_LANGINFO_H
10+#ifdef HAVE_LANGINFO_H && !defined(__UCLIBC__)
11 # define weekday(wd) nl_langinfo(ABDAY_1+wd)
12 #else
13 # define weekday(wd) _time_info->abbrev_wkday[wd]
diff --git a/recipes-core/util-linux-ng/util-linux-ng-2.17/util-linux-ng-replace-siginterrupt.patch b/recipes-core/util-linux-ng/util-linux-ng-2.17/util-linux-ng-replace-siginterrupt.patch
deleted file mode 100644
index 4b5eb7376..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng-2.17/util-linux-ng-replace-siginterrupt.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: util-linux-ng-2.14/login-utils/login.c
2===================================================================
3--- util-linux-ng-2.14.orig/login-utils/login.c 2008-05-28 16:01:02.000000000 -0700
4+++ util-linux-ng-2.14/login-utils/login.c 2009-03-04 18:31:42.000000000 -0800
5@@ -358,6 +358,7 @@
6 char *childArgv[10];
7 char *buff;
8 int childArgc = 0;
9+ struct sigaction act;
10 #ifdef HAVE_SECURITY_PAM_MISC_H
11 int retcode;
12 pam_handle_t *pamh = NULL;
13@@ -373,7 +374,9 @@
14 pid = getpid();
15
16 signal(SIGALRM, timedout);
17- siginterrupt(SIGALRM,1); /* we have to interrupt syscalls like ioclt() */
18+ (void) sigaction(SIGALRM, NULL, &act);
19+ act.sa_flags &= ~SA_RESTART;
20+ sigaction(SIGALRM, &act, NULL);
21 alarm((unsigned int)timeout);
22 signal(SIGQUIT, SIG_IGN);
23 signal(SIGINT, SIG_IGN);
diff --git a/recipes-core/util-linux-ng/util-linux-ng.inc b/recipes-core/util-linux-ng/util-linux-ng.inc
deleted file mode 100644
index 5d28b03eb..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng.inc
+++ /dev/null
@@ -1,321 +0,0 @@
1DESCRIPTION = "Util-linux-ng is a suite of essential utilities for any Linux system."
2SECTION = "base"
3LICENSE = "GPL"
4DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} zlib ncurses virtual/libintl"
5DEPENDS_virtclass-native = "zlib-native ncurses-native lzo-native gettext-native"
6
7inherit autotools gettext
8
9INC_PR = "r34"
10
11# allows for a release candidate
12RC ?= ""
13
14SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/util-linux-ng/v${PV}/util-linux-ng-${PV}${RC}.tar.bz2;name=archive"
15
16SRC_URI_append_chinook-compat = " file://chinook_libtool.patch "
17
18PACKAGES =+ "${PN}-fdisk ${PN}-cfdisk ${PN}-sfdisk ${PN}-swaponoff \
19 ${PN}-losetup ${PN}-umount ${PN}-mount ${PN}-readprofile \
20 ${PN}-fsck ${PN}-blkid ${PN}-mountall ${PN}-reset"
21
22PACKAGES_virtclass-native = ""
23
24PACKAGES_DYNAMIC = "libblkid* libuuid*"
25
26# Provide old util-linux names (several recipes still use DEPENDS or RDEPENDS_${PN} = "util-linux"):
27PROVIDES = "util-linux"
28RPROVIDES_${PN} = "util-linux"
29RPROVIDES_util-linux-ng-fdisk = "util-linux-fdisk"
30RPROVIDES_util-linux-ng-cfdisk = "util-linux-cfdisk"
31RPROVIDES_util-linux-ng-sfdisk = "util-linux-sfdisk"
32RPROVIDES_util-linux-ng-swaponoff = "util-linux-swaponoff"
33RPROVIDES_util-linux-ng-losetup = "util-linux-losetup"
34RPROVIDES_util-linux-ng-umount = "util-linux-umount"
35RPROVIDES_util-linux-ng-mount = "util-linux-mount"
36RPROVIDES_util-linux-ng-readprofile = "util-linux-readprofile"
37RPROVIDES_util-linux-ng-fsck = "e2fsprogs-fsck"
38RPROVIDES_util-linux-ng-blkid = "e2fsprogs-blkid"
39
40FILES_${PN}-doc += "/usr/share/misc/getopt/getopt-*.*"
41FILES_${PN} = "${bindir} ${sbindir} ${base_bindir} ${base_sbindir}"
42
43FILES_util-linux-ng-fdisk = "${base_sbindir}/fdisk.${PN}"
44FILES_util-linux-ng-cfdisk = "${base_sbindir}/cfdisk"
45# Moved to ${sbindir} in new versions:
46FILES_util-linux-ng-sfdisk = "${base_sbindir}/sfdisk ${sbindir}/sfdisk"
47FILES_util-linux-ng-swaponoff = "${base_sbindir}/swapon.${PN} ${base_sbindir}/swapoff.${PN}"
48FILES_util-linux-ng-losetup = "${base_sbindir}/losetup.${PN}"
49FILES_util-linux-ng-mount = "${base_bindir}/mount.${PN} ${sysconfdir}/default/mountall"
50FILES_util-linux-ng-umount = "${base_bindir}/umount.${PN}"
51# Moved to ${base_sbindir} by do_install:
52FILES_util-linux-ng-readprofile = "${sbindir}/readprofile.${PN}"
53FILES_util-linux-ng-fsck = "${base_sbindir}/fsck.${PN}"
54FILES_util-linux-ng-blkid = "${base_sbindir}/blkid.${PN}"
55FILES_${PN}-mountall = "${sysconfdir}/default/mountall.${PN}"
56FILES_${PN}-reset = "${bindir}/reset.${PN}"
57
58RREPLACES_util-linux-ng-blkid = "e2fsprogs-blkid"
59RREPLACES_${PN}-mountall = "busybox-mountall"
60
61RRECOMMENDS_${PN} = "${PN}-fdisk ${PN}-cfdisk ${PN}-sfdisk ${PN}-mount ${PN}-readprofile"
62RDEPENDS_${PN} = "${PN}-mountall ${PN}-umount ${PN}-swaponoff ${PN}-losetup ${PN}-fsck ${PN}-blkid"
63RDEPENDS_${PN}-reset = "ncurses-tools"
64
65RRECOMMENDS_${PN}_virtclass-native = ""
66RDEPENDS_${PN}_virtclass-native = ""
67
68EXTRA_OECONF = "--disable-use-tty-group --disable-makeinstall-chown \
69--enable-kill --enable-last --enable-mesg --enable-raw --enable-login-utils \
70--enable-arch --enable-init --enable-partx --enable-schedutils \
71--with-fsprobe=builtin --enable-libuuid --enable-libblkid \
72--enable-fsck --enable-reset"
73
74LDFLAGS_append_libc-uclibc = "${@['',' -lintl'][bb.data.getVar('USE_NLS', d, 1) == 'yes']}"
75LDFLAGS_virtclass-native = "${BUILD_LDFLAGS}"
76
77S = "${WORKDIR}/util-linux-ng-${PV}${RC}"
78
79do_configure_prepend_chinook-compat () {
80
81 for i in lt~obsolete.m4 ltsugar.m4 libtool.m4 ltoptions.m4 ltversion.m4
82 do
83 rm ${S}/m4/${i}
84 done
85}
86
87do_compile () {
88 set -e
89 oe_runmake ARCH=${TARGET_ARCH} CPU= CPUOPT= \
90 'OPT=${CFLAGS}' 'CC=${CC}' 'LD=${LD}' \
91 'LDFLAGS=${LDFLAGS}'
92}
93
94checklink() {
95 local targ link value
96 targ="$1"
97 link="$2"
98 ext="$3"
99 if test -h "$link"
100 then
101 value="$(readlink "$link")"
102 if test "$value" = "$targ"
103 then
104 rm "$link"
105 ln -s "$targ"."${PN}" "$link$ext"
106 return 0
107 else
108 echo "$link: '$value' found '$targ' expected" >&2
109 return 1
110 fi
111 else
112 echo "$link: not a symbolic link" >&2
113 return 1
114 fi
115}
116
117do_install () {
118 # with ccache the timestamps on compiled files may
119 # end up earlier than on their inputs, this allows
120 # for the resultant compilation in the install step.
121 oe_runmake ARCH=${TARGET_ARCH} CPU= CPUOPT= \
122 'OPT=${CFLAGS}' 'CC=${CC}' 'LD=${LD}' \
123 'LDFLAGS=${LDFLAGS}' 'DESTDIR=${D}' install
124 mkdir -p ${D}${base_bindir}
125
126 sbinprogs="agetty blockdev ctrlaltdel cfdisk"
127 sbinprogs_a="pivot_root hwclock mkswap shutdown mkfs.minix fsck.minix losetup swapon fdisk fsck blkid vigr vipw"
128 usrbinprogs_a="chfn chsh hexdump last logger mesg newgrp renice wall setsid chrt reset cal script flock"
129 usrsbinprogs_a="readprofile"
130 binprogs_a="dmesg kill more umount mount login"
131
132 if [ "${base_sbindir}" != "${sbindir}" ]; then
133 mkdir -p ${D}${base_sbindir}
134 for p in $sbinprogs $sbinprogs_a; do
135 if [ -f "${D}${sbindir}/$p" ]; then
136 mv "${D}${sbindir}/$p" "${D}${base_sbindir}/$p"
137 fi
138 done
139 fi
140
141 if [ "${base_bindir}" != "${bindir}" ]; then
142 mkdir -p ${D}${base_bindir}
143 for p in $binprogs_a; do
144 if [ -f "${D}${bindir}/$p" ]; then
145 mv "${D}${bindir}/$p" "${D}${base_bindir}/$p"
146 fi
147 done
148 fi
149
150 for p in $usrbinprogs_a; do
151 if [ -f "${D}${bindir}/$p" ]; then
152 mv "${D}${bindir}/$p" "${D}${bindir}/$p.${PN}"
153 fi
154 done
155
156 for p in $usrsbinprogs_a; do
157 if [ -f "${D}${sbindir}/$p" ]; then
158 mv "${D}${sbindir}/$p" "${D}${sbindir}/$p.${PN}"
159 fi
160 done
161
162 for p in $binprogs_a; do
163 if [ -f "${D}${base_bindir}/$p" ]; then
164 mv "${D}${base_bindir}/$p" "${D}${base_bindir}/$p.${PN}"
165 fi
166 done
167
168 for p in $sbinprogs_a; do
169 if [ -f "${D}${base_sbindir}/$p" ]; then
170 mv "${D}${base_sbindir}/$p" "${D}${base_sbindir}/$p.${PN}"
171 fi
172 done
173
174 install -d ${D}${sysconfdir}/default/
175 echo 'MOUNTALL="-t nonfs,nosmbfs,noncpfs"' > ${D}${sysconfdir}/default/mountall.${PN}
176
177 rm ${D}${sbindir}/swapoff -f
178 ln -sf ${base_sbindir}/swapon.${PN} ${D}${base_sbindir}/swapoff.${PN}
179 ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/reboot.${PN}
180 ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/halt.${PN}
181 ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/fastboot
182 ln -sf ${base_sbindir}/shutdown ${D}${base_sbindir}/fasthalt
183}
184
185python populate_packages_prepend () {
186 ulinxng_libdir = bb.data.expand('${libdir}', d)
187 ulinxng_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
188 do_split_packages(d, ulinxng_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev', allow_links=True)
189 do_split_packages(d, ulinxng_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev')
190 do_split_packages(d, ulinxng_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'util-linux-ng %s development package', extra_depends='${PN}-dev')
191 do_split_packages(d, ulinxng_libdir, '^lib(.*)\.so\.*', 'lib%s', 'util-linux-ng %s library', extra_depends='', allow_links=True)
192}
193
194
195pkg_postinst_${PN} () {
196 update-alternatives --install ${base_bindir}/dmesg dmesg dmesg.${PN} 100
197 update-alternatives --install ${base_bindir}/kill kill kill.${PN} 100
198 update-alternatives --install ${base_bindir}/more more more.${PN} 100
199 update-alternatives --install ${base_sbindir}/mkswap mkswap mkswap.${PN} 100
200 test -x ${base_sbindir}/pivot_root.${PN} && \
201 update-alternatives --install ${base_sbindir}/pivot_root pivot_root pivot_root.${PN} 100
202 update-alternatives --install ${base_sbindir}/sln sln sln.${PN} 100
203 update-alternatives --install ${base_sbindir}/mkfs.minix mkfs.minix mkfs.minix.${PN} 100
204 update-alternatives --install ${base_sbindir}/fsck.minix fsck.minix fsck.minix.${PN} 100
205 update-alternatives --install ${bindir}/hexdump hexdump hexdump.${PN} 100
206 update-alternatives --install ${bindir}/last last last.${PN} 100
207 update-alternatives --install ${bindir}/logger logger logger.${PN} 100
208 update-alternatives --install ${bindir}/mesg mesg mesg.${PN} 100
209 update-alternatives --install ${bindir}/renice renice renice.${PN} 100
210 update-alternatives --install ${bindir}/wall wall wall.${PN} 100
211 update-alternatives --install ${bindir}/chfn chfn chfn.${PN} 100
212 update-alternatives --install ${bindir}/newgrp newgrp newgrp.${PN} 100
213 update-alternatives --install ${bindir}/chsh chsh chsh.${PN} 100
214 update-alternatives --install ${bindir}/cal cal cal.${PN} 100
215 update-alternatives --install ${bindir}/script script script.${PN} 100
216 update-alternatives --install ${bindir}/flock flock flock.${PN} 100
217 update-alternatives --install ${base_bindir}/login login login.${PN} 100
218 update-alternatives --install ${base_sbindir}/vipw vipw vipw.${PN} 100
219 update-alternatives --install ${base_sbindir}/vigr vigr vigr.${PN} 100
220 update-alternatives --install ${bindir}/setsid setsid setsid.${PN} 100
221 update-alternatives --install ${bindir}/chrt chrt chrt.${PN} 100
222
223 # There seems to be problem, atleast on nslu2, with these, until they are
224 # fixed the busybox ones have higher priority
225 update-alternatives --install ${base_sbindir}/hwclock hwclock hwclock.${PN} 10
226 update-alternatives --install ${base_sbindir}/shutdown shutdown shutdown.${PN} 10
227 update-alternatives --install ${base_sbindir}/reboot reboot reboot.${PN} 10
228 update-alternatives --install ${base_sbindir}/halt halt halt.${PN} 10
229}
230
231pkg_prerm_${PN} () {
232 test -x ${base_sbindir}/pivot_root.${PN} && \
233 update-alternatives --remove pivot_root pivot_root.${PN}
234
235 for i in dmesg kill more halt hwclock mkswap reboot shutdown sln mkfs.minix fsck.minix hexdump setsid chrt last logger mesg renice wall vipw vigr chfn newgrp chsh login cal script flock; do
236 update-alternatives --remove $i $i.${PN}
237 done
238}
239
240pkg_postinst_util-linux-ng-reset() {
241 update-alternatives --install ${bindir}/reset reset reset.${PN} 100
242}
243
244pkg_prerm_util-linux-ng-reset () {
245 update-alternatives --remove reset reset.${PN}
246}
247
248pkg_postinst_util-linux-ng-fdisk () {
249 update-alternatives --install ${base_sbindir}/fdisk fdisk fdisk.${PN} 100
250}
251
252pkg_prerm_util-linux-ng-fdisk () {
253 update-alternatives --remove fdisk fdisk.${PN}
254}
255
256pkg_postinst_util-linux-ng-mount () {
257 update-alternatives --install ${base_bindir}/mount mount mount.${PN} 100
258}
259
260pkg_prerm_util-linux-ng-mount () {
261 update-alternatives --remove mount mount.${PN}
262}
263
264pkg_postinst_util-linux-ng-umount () {
265 update-alternatives --install ${base_bindir}/umount umount umount.${PN} 100
266}
267
268pkg_prerm_util-linux-ng-umount () {
269 update-alternatives --remove umount umount.${PN}
270}
271
272pkg_postinst_util-linux-ng-losetup () {
273 update-alternatives --install ${base_sbindir}/losetup losetup losetup.${PN} 100
274}
275
276pkg_prerm_util-linux-ng-losetup () {
277 update-alternatives --remove losetup losetup.${PN}
278}
279
280pkg_postinst_util-linux-ng-swaponoff () {
281 update-alternatives --install ${base_sbindir}/swapoff swapoff swapon.${PN} 100
282 update-alternatives --install ${base_sbindir}/swapon swapon swapon.${PN} 100
283}
284
285pkg_prerm_util-linux-ng-swaponoff () {
286 update-alternatives --remove swapoff swapon.${PN}
287 update-alternatives --remove swapon swapon.${PN}
288}
289
290pkg_postinst_util-linux-ng-readprofile() {
291 update-alternatives --install ${sbindir}/readprofile readprofile readprofile.${PN} 100
292}
293
294pkg_prerm_util-linux-ng-readprofile () {
295 update-alternatives --remove readprofile readprofile.${PN} 100
296}
297
298pkg_postinst_util-linux-ng-mountall () {
299 update-alternatives --install ${sysconfdir}/default/mountall default_mountall mountall.${PN} 100
300}
301pkg_prerm_util-linux-ng-mountall () {
302 update-alternatives --remove default_mountall mountall.${PN}
303}
304
305pkg_postinst_util-linux-ng-fsck () {
306 update-alternatives --install ${base_sbindir}/fsck fsck fsck.${PN} 100
307}
308
309pkg_prerm_util-linux-ng-fsck () {
310 update-alternatives --remove fsck fsck.${PN}
311}
312
313pkg_postinst_util-linux-ng-blkid () {
314 update-alternatives --install ${base_sbindir}/blkid blkid blkid.${PN} 100
315}
316
317pkg_prerm_util-linux-ng-blkid () {
318 update-alternatives --remove blkid blkid.${PN}
319}
320
321BBCLASSEXTEND = "native"
diff --git a/recipes-core/util-linux-ng/util-linux-ng/chinook_libtool.patch b/recipes-core/util-linux-ng/util-linux-ng/chinook_libtool.patch
deleted file mode 100644
index 6ffdb77a4..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng/chinook_libtool.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: util-linux-ng-2.16/configure.ac
2===================================================================
3--- util-linux-ng-2.16.orig/configure.ac 2009-07-22 20:14:46.896898772 +0200
4+++ util-linux-ng-2.16/configure.ac 2009-07-22 20:15:08.223644774 +0200
5@@ -70,7 +70,7 @@
6 AC_C_BIGENDIAN
7
8 dnl libtool-2
9-LT_INIT
10+AM_PROG_LIBTOOL
11
12 PKG_PROG_PKG_CONFIG
13
diff --git a/recipes-core/util-linux-ng/util-linux-ng/fix-make-c.patch b/recipes-core/util-linux-ng/util-linux-ng/fix-make-c.patch
deleted file mode 100644
index bf1082e85..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng/fix-make-c.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From: Karel Zak <kzak@redhat.com>
2Date: Mon, 11 May 2009 09:49:00 +0000 (+0200)
3Subject: build-sys: fix "make -C" bug
4X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=2ef7d41e6bbb7c842c06e911ffc562335a467b5d
5
6build-sys: fix "make -C" bug
7
8Running:
9
10./configure --with-fsprobe=builtin
11make -C mount mount
12
13causes the following error:
14
15gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -include ../config.h
16-I../include -DLOCALEDIR=\"/home/matthew/util-linux-ng/share/locale\"
17-fsigned-char -I../libs/blkid/src -g -O2 -MT mount-setproctitle.o
18-MD -MP -MF .deps/mount-setproctitle.Tpo -c -o mount-setproctitle.o
19`test -f '../lib/setproctitle.c' || echo './'`../lib/setproctitle.c mv
20-f .deps/mount-setproctitle.Tpo .deps/mount-setproctitle.Po
21make -C
22make: option requires an argument -- 'C'
23Usage: make [options] [target] ...
24...
25
26Reported-by: Matthew Burgess <matthew@linuxfromscratch.org>
27Signed-off-by: Karel Zak <kzak@redhat.com>
28---
29
30diff --git a/config/include-Makefile.am b/config/include-Makefile.am
31index b42a0c3..d5da619 100644
32--- a/config/include-Makefile.am
33+++ b/config/include-Makefile.am
34@@ -17,6 +17,7 @@ dist_noinst_DATA = $(dist_man_MANS)
35 # Paths to in-tree libraries (use ul_ prefix to avoid possible collisions)
36 #
37 ul_libblkid_srcdir = $(top_srcdir)/libs/blkid/src
38+ul_libblkid_builddir = $(top_builddir)/libs/blkid/src
39 ul_libblkid_la = $(top_builddir)/libs/blkid/src/libblkid.la
40
41 $(ul_libblkid_la):
diff --git a/recipes-core/util-linux-ng/util-linux-ng/optional-uuid.patch b/recipes-core/util-linux-ng/util-linux-ng/optional-uuid.patch
deleted file mode 100644
index 2d0ea43cd..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng/optional-uuid.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From: Karel Zak <kzak@redhat.com>
2Date: Tue, 12 May 2009 19:22:19 +0000 (+0200)
3Subject: blkid: make libuuid optional
4X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=cdd17c7a73cab10a34bf80616225b8215ac4e2ed
5
6blkid: make libuuid optional
7
8read.c:28:23: error: uuid/uuid.h: No such file or directory
9make[3]: *** [read.lo] Error 1
10make[3]: *** Waiting for unfinished jobs....
11
12Reported-by: Olaf <mailinglists@ban-solms.de>
13Signed-off-by: Karel Zak <kzak@redhat.com>
14---
15
16diff --git a/libs/blkid/src/config.c b/libs/blkid/src/config.c
17index 2e59218..9091736 100644
18--- a/libs/blkid/src/config.c
19+++ b/libs/blkid/src/config.c
20@@ -24,9 +24,6 @@
21 #include <errno.h>
22 #endif
23 #include <stdint.h>
24-#ifdef HAVE_LIBUUID
25-#include <uuid/uuid.h>
26-#endif
27 #include <stdarg.h>
28
29 #include "blkdev.h"
30diff --git a/libs/blkid/src/evaluate.c b/libs/blkid/src/evaluate.c
31index a9c9fba..f0ae126 100644
32--- a/libs/blkid/src/evaluate.c
33+++ b/libs/blkid/src/evaluate.c
34@@ -27,9 +27,6 @@
35 #include <errno.h>
36 #endif
37 #include <stdint.h>
38-#ifdef HAVE_LIBUUID
39-#include <uuid/uuid.h>
40-#endif
41 #include <stdarg.h>
42
43 #include "pathnames.h"
44diff --git a/libs/blkid/src/read.c b/libs/blkid/src/read.c
45index 4163874..b5e9cd0 100644
46--- a/libs/blkid/src/read.c
47+++ b/libs/blkid/src/read.c
48@@ -25,7 +25,6 @@
49 #endif
50
51 #include "blkidP.h"
52-#include "uuid/uuid.h"
53
54 #ifdef HAVE_STRTOULL
55 #define STRTOULL strtoull /* defined in stdlib.h if you try hard enough */
diff --git a/recipes-core/util-linux-ng/util-linux-ng/uclibc-compile.patch b/recipes-core/util-linux-ng/util-linux-ng/uclibc-compile.patch
deleted file mode 100644
index def233604..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng/uclibc-compile.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1Index: util-linux-ng-2.15/libs/blkid/src/blkidP.h
2===================================================================
3--- util-linux-ng-2.15.orig/libs/blkid/src/blkidP.h 2009-07-01 23:09:57.000000000 +0200
4+++ util-linux-ng-2.15/libs/blkid/src/blkidP.h 2009-07-01 23:10:09.000000000 +0200
5@@ -18,6 +18,7 @@
6
7 #include <sys/types.h>
8 #include <stdio.h>
9+#include <stdarg.h>
10
11 #include "bitops.h" /* $(top_srcdir)/include/ */
12 #include "blkid.h"
13Index: util-linux-ng-2.15/misc-utils/cal.c
14===================================================================
15--- util-linux-ng-2.15.orig/misc-utils/cal.c 2009-07-01 23:16:54.000000000 +0200
16+++ util-linux-ng-2.15/misc-utils/cal.c 2009-07-01 23:17:08.000000000 +0200
17@@ -291,7 +291,7 @@
18 * the locale database, which can be overridden with the
19 * -s (Sunday) or -m (Monday) options.
20 */
21-#ifdef HAVE_LANGINFO_H
22+#if defined(HAVE_LANGINFO_H) && !defined(__UCLIBC__)
23 /*
24 * You need to use 2 locale variables to get the first day of the week.
25 * This is needed to support first_weekday=2 and first_workday=1 for
diff --git a/recipes-core/util-linux-ng/util-linux-ng_2.17.bb b/recipes-core/util-linux-ng/util-linux-ng_2.17.bb
deleted file mode 100644
index a68a49225..000000000
--- a/recipes-core/util-linux-ng/util-linux-ng_2.17.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1require util-linux-ng.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5PR = "${INC_PR}.2"
6
7SRC_URI += "file://uclibc-compile.patch \
8 file://util-linux-ng-replace-siginterrupt.patch \
9 file://fdiskbsdlabel.h-nios2.patch \
10 "
11
12# fallocate is glibc 2.10, fallocate64 is glibc 2.11
13# we need to disable it for older versions
14EXTRA_OECONF += "ac_cv_func_fallocate=no"
15EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
16
17SRC_URI[archive.md5sum] = "11cc8a0138019e7060dd275d47dbc096"
18SRC_URI[archive.sha256sum] = "8720f7233394b68d17095707c195ebb014943c1075a18fb5fd21ec108f012be3"