summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpiod/libgpiod.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpiod/libgpiod.bb')
-rw-r--r--meta/recipes-support/libgpiod/libgpiod.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpiod/libgpiod.bb b/meta/recipes-support/libgpiod/libgpiod.bb
new file mode 100644
index 000000000..fe56f7b5c
--- /dev/null
+++ b/meta/recipes-support/libgpiod/libgpiod.bb
@@ -0,0 +1,30 @@
1SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2HOMEPAGE = "https://github.com/brgl/libgpiod"
3
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
6
7UPSTREAM_CHECK_URI = "git://github.com/brgl/libgpiod/releases"
8
9SRC_URI = "git://github.com/brgl/libgpiod.git"
10
11SRCREV = "7ab5e53b69cce313ba87033a442cabd417f5d895"
12
13PV = "0.2+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17SRC_URI[md5sum] = "68f039487e940c15bbfc50a10ab4715b"
18SRC_URI[sha256sum] = "7d7085d4e9cb811742ca8c5fe03458067efaeaa8abc23968d2e3c56bcc2d2ef8"
19
20inherit autotools pkgconfig
21
22# enable tools
23PACKAGECONFIG ?= "tools"
24
25PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
26PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
27
28PACKAGES += " ${PN}-tools"
29
30FILES_${PN}-tools = "${bindir}/*"