summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch15
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb (renamed from meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.16.3.bb)4
2 files changed, 11 insertions, 8 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
index 1adb14552..10c456f45 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -13,15 +13,19 @@ Content-Transfer-Encoding: 8bit
13Upstream-Status: Pending 13Upstream-Status: Pending
14 14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> 15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16
17Rebase for xfce4 4.18.0.
18
19Signed-off-by: Kai Kang <kai.kang@windriver.com>
16--- 20---
17 plugins/windowmenu/windowmenu.c | 10 +++++----- 21 plugins/windowmenu/windowmenu.c | 10 +++++-----
18 1 file changed, 5 insertions(+), 5 deletions(-) 22 1 file changed, 5 insertions(+), 5 deletions(-)
19 23
20diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c 24diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
21index f47e993e..061d6544 100644 25index ba245a3..f8fdee8 100644
22--- a/plugins/windowmenu/windowmenu.c 26--- a/plugins/windowmenu/windowmenu.c
23+++ b/plugins/windowmenu/windowmenu.c 27+++ b/plugins/windowmenu/windowmenu.c
24@@ -251,7 +251,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin) 28@@ -250,7 +250,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
25 g_signal_connect (G_OBJECT (plugin->button), "toggled", 29 g_signal_connect (G_OBJECT (plugin->button), "toggled",
26 G_CALLBACK (window_menu_plugin_menu), plugin); 30 G_CALLBACK (window_menu_plugin_menu), plugin);
27 31
@@ -30,16 +34,14 @@ index f47e993e..061d6544 100644
30 gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon); 34 gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
31 gtk_widget_show (plugin->icon); 35 gtk_widget_show (plugin->icon);
32 } 36 }
33@@ -640,7 +640,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen, 37@@ -680,19 +680,19 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
34 /* skip 'fake' windows */ 38 /* skip 'fake' windows */
35 type = wnck_window_get_window_type (window); 39 type = wnck_window_get_window_type (window);
36 if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK) 40 if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
37- goto show_desktop_icon; 41- goto show_desktop_icon;
38+ goto show_no_icon; 42+ goto show_no_icon;
39 43
40 /* get the window icon and set the tooltip */ 44 window_menu_plugin_set_icon (plugin, window);
41 gtk_widget_set_tooltip_text (GTK_WIDGET (icon),
42@@ -660,12 +660,12 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
43 } 45 }
44 else 46 else
45 { 47 {
@@ -47,6 +49,7 @@ index f47e993e..061d6544 100644
47+ show_no_icon: 49+ show_no_icon:
48 50
49 /* desktop is shown right now */ 51 /* desktop is shown right now */
52 icon_size = xfce_panel_plugin_get_icon_size (XFCE_PANEL_PLUGIN (plugin));
50- gtk_image_set_from_icon_name (GTK_IMAGE (icon), "user-desktop", icon_size); 53- gtk_image_set_from_icon_name (GTK_IMAGE (icon), "user-desktop", icon_size);
51+ gtk_image_set_from_icon_name (GTK_IMAGE (icon), NULL, icon_size); 54+ gtk_image_set_from_icon_name (GTK_IMAGE (icon), NULL, icon_size);
52 gtk_image_set_pixel_size (GTK_IMAGE (icon), icon_size); 55 gtk_image_set_pixel_size (GTK_IMAGE (icon), icon_size);
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.16.3.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb
index 46d26159a..5dcd69d35 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.16.3.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb
@@ -1,6 +1,6 @@
1SUMMARY = "Xfce4 Panel" 1SUMMARY = "Xfce4 Panel"
2SECTION = "x11" 2SECTION = "x11"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee" 4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native" 5DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native"
6 6
@@ -10,11 +10,11 @@ inherit xfce gtk-doc gobject-introspection features_check mime-xdg
10# cairo would at least needed to be built with xlib. 10# cairo would at least needed to be built with xlib.
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" 11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12 12
13SRC_URI[sha256sum] = "5934eaed8a76da52c29b734ccd79600255420333dd6ebd8fd9f066379af1e092"
14SRC_URI += " \ 13SRC_URI += " \
15 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ 14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
16 file://0002-use-lxdm-to-replace-dm-tool.patch \ 15 file://0002-use-lxdm-to-replace-dm-tool.patch \
17" 16"
17SRC_URI[sha256sum] = "be80023fd546587831bab25ded15ae4c9e346289a75744b6ba4cf4ee53794710"
18 18
19EXTRA_OECONF += "--disable-vala" 19EXTRA_OECONF += "--disable-vala"
20 20