summaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/machine-host.bb17
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb2
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/machine-host.bb b/meta-xfce/recipes-xfce/xfce4-session/machine-host.bb
new file mode 100644
index 000000000..03bd205a2
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/machine-host.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Meta package adding machine name to known hosts"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5ALLOW_EMPTY_${PN} = "1"
6
7LOCALHOSTMACHINE = "127.0.0.1 ${MACHINE}"
8
9# on some machines starting applications as xfce4-terminal take ages without
10# machine name in hosts
11pkg_postinst_${PN} () {
12if ! grep -q '${LOCALHOSTMACHINE}' $D/etc/hosts ; then
13 echo '${LOCALHOSTMACHINE}' >> $D/etc/hosts
14fi
15}
16
17PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
index 81c56ccfa..215aec32b 100644
--- a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
@@ -26,3 +26,5 @@ FILES_${PN} += " \
26" 26"
27 27
28FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug" 28FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug"
29
30RDEPENDS_${PN} += "machine-host"