summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb
new file mode 100644
index 000000000..b72d44f79
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_git.bb
@@ -0,0 +1,40 @@
1DESCRIPTION="Xfce4 Window Manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
5DEPENDS = "virtual/libx11 libxpm gtk+ libxfce4util libxfce4ui xfconf libwnck dbus-glib startup-notification"
6
7inherit xfce update-alternatives
8
9SRC_URI = " \
10 git://git.xfce.org/xfce/xfwm4;protocol=git \
11 file://0001-don-t-block-display-events-when-time-is-set-backward.patch \
12"
13
14SRCREV = "bce3062d0879ab8504c446f99ad57c9fd76c5097"
15S = "${WORKDIR}/git"
16PV = "4.10.1+git${SRCPV}"
17
18EXTRA_OECONF += "--enable-maintainer-mode"
19
20do_configure_prepend() {
21 NOCONFIGURE=yes ./autogen.sh
22}
23
24python populate_packages_prepend () {
25 themedir = d.expand('${datadir}/themes')
26 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
27}
28
29PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
30
31ALTERNATIVE_${PN} = "x-window-manager"
32ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
33ALTERNATIVE_PRIORITY[x-window-manager] = "30"
34
35RDEPENDS_${PN} = "xfwm4-theme-default"
36FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
37 ${datadir}/xfwm4/defaults \
38"
39FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
40