summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch')
-rw-r--r--meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch b/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch
new file mode 100644
index 000000000..ef68f7acd
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfconf/files/0001-Simplify-checks.patch
@@ -0,0 +1,112 @@
1From 233f7d3a9b0f98b794548433cead77633aab5f7d Mon Sep 17 00:00:00 2001
2From: Nick Schermer <nick@xfce.org>
3Date: Sun, 6 Jan 2013 12:46:47 +0100
4Subject: [PATCH] Simplify checks.
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: backport [1]
10
11[1] http://git.xfce.org/xfce/xfconf/commit/?id=233f7d3a9b0f98b794548433cead77633aab5f7d
12
13Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
14---
15 tests/Makefile.am | 1 -
16 tests/Makefile.inc | 9 +--------
17 tests/test-template.sh.in | 49 -----------------------------------------------
18 3 files changed, 1 insertion(+), 58 deletions(-)
19 delete mode 100644 tests/test-template.sh.in
20
21diff --git a/tests/Makefile.am b/tests/Makefile.am
22index 57165d9..57ba7e8 100644
23--- a/tests/Makefile.am
24+++ b/tests/Makefile.am
25@@ -13,5 +13,4 @@ clean-local:
26
27 EXTRA_DIST = \
28 $(test_scripts) \
29- test-template.sh.in \
30 tests-common.h
31diff --git a/tests/Makefile.inc b/tests/Makefile.inc
32index 2ed3431..7a5a715 100644
33--- a/tests/Makefile.inc
34+++ b/tests/Makefile.inc
35@@ -13,9 +13,7 @@
36 # along with this program; if not, write to the Free Software
37 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
38
39-check_SCRIPTS = $(addsuffix .sh,$(check_PROGRAMS))
40-
41-TESTS = $(check_SCRIPTS)
42+TESTS = $(check_PROGRAMS)
43 TESTS_ENVIRONMENT = XDG_CONFIG_HOME="$(top_builddir)/tests/test-xdg_config_home" XFCONFD="$(top_builddir)/xfconfd/xfconfd"
44
45 AM_CFLAGS = \
46@@ -27,8 +25,3 @@ AM_CFLAGS = \
47 LIBS = \
48 $(top_builddir)/xfconf/libxfconf-$(LIBXFCONF_VERSION_API).la
49
50-%.sh: $(top_srcdir)/tests/test-template.sh.in Makefile
51- sed -e 's/@TEST_NAME@/$@/; s/\.sh//;' <$(top_srcdir)/tests/test-template.sh.in >$@
52- chmod 755 $@
53-
54-CLEANFILES = $(check_SCRIPTS)
55diff --git a/tests/test-template.sh.in b/tests/test-template.sh.in
56deleted file mode 100644
57index 2e638a8..0000000
58--- a/tests/test-template.sh.in
59+++ /dev/null
60@@ -1,49 +0,0 @@
61-#!/bin/sh
62-
63-cleanup() {
64- if [ "$XFCONFD_PID" ]; then
65- kill -TERM $XFCONFD_PID 2>/dev/null
66- sleep 1
67- kill -KILL $XFCONFD_PID 2>/dev/null
68- fi
69-
70- kill -TERM $DBUS_SESSION_BUS_PID 2>/dev/null
71- sleep 1
72- kill -KILL $DBUS_SESSION_BUS_PID 2>/dev/null
73-}
74-
75-die() {
76- [ "$1" ] && echo "$1" >&2
77- cleanup
78- exit 1
79-}
80-
81-# some buildbots have problems with the tests (dbus not
82-# working properly without an X11 server).
83-if [ -n "$XFCONF_SKIP_TESTS" ]; then
84- echo "Warning: Tests disabled, skipping @TEST_NAME@" >&2
85- exit 0
86-fi
87-
88-unset DBUS_SESSION_BUS_ADDRESS
89-unset DBUS_SESSION_BUS_PID
90-unset XFCONFD_PID
91-
92-eval `dbus-launch --sh-syntax`
93-export DBUS_SESSION_BUS_ADDRESS
94-export DBUS_SESSION_BUS_PID
95-
96-[ "$DBUS_SESSION_BUS_PID" ] || die "DBus failed to start"
97-
98-trap "die Interrupted" INT
99-
100-eval `$XFCONFD --daemon 2>/dev/null` || die "Failed to start xfconfd"
101-
102-export XDG_CONFIG_HOME # make sure it's exported from the makefile
103-export XDG_CONFIG_DIRS=""
104-
105-./@TEST_NAME@ || die "Test Failed"
106-
107-cleanup
108-
109-exit 0
110--
1111.8.3.1
112