summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
new file mode 100644
index 000000000..290ec3de5
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-settings/xfce4-settings_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Xfce4 settings"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = "exo exo-native garcon gtk+ libxfce4util libxfce4ui xfconf dbus-glib libxi virtual/libx11 xrandr libnotify libxcursor libxklavier upower"
6
7inherit xfce xfce-git
8
9SRC_URI = " git://gitorious.org/xfce/xfce4-settings.git;protocol=git;branch=for-oe \
10 file://0001-xsettings.xml-remove-trouble-causing-comment.patch \
11 file://0002-xsettings.xml-Set-default-themes.patch \
12 file://touchscreen/invisible \
13 file://touchscreen/wait \
14 file://touchscreen/0001-add-cursor-theme-xfce-invisible.patch \
15 file://touchscreen/0002-mouse-settings-dialog-add-touchscreen-pointer-option.patch \
16 file://touchscreen/0003-XfcePointersHelper-gets-a-pointer-to-XfceXSettingsHe.patch \
17 file://touchscreen/0004-XfceXSettingsHelper-gets-a-property-touchscreen-poin.patch \
18 file://touchscreen/0005-pointers-detect-a-change-of-pointer-device-used-and-.patch \
19"
20SRCREV = "b7a0e1fd77f5bb5c372223ff62aec7acf252f061"
21S = "${WORKDIR}/git"
22PV = "4.11.0+git${SRCPV}"
23
24EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
25
26PACKAGECONFIG ??= " \
27 ${@base_contains('DISTRO_FEATURES','systemd','datetime-setter','',d)} \
28 ${@base_contains('DISTRO_FEATURES','alsa','sound-setter', base_contains('DISTRO_FEATURES','pulseaudio','sound-setter','',d),d)} \
29"
30PACKAGECONFIG[datetime-setter] = "--enable-datetime-settings, --disable-datetime-settings,, tzdata"
31PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify"
32PACKAGECONFIG[sound-setter] = "--enable-sound-settings, --disable-sound-settings, libcanberra, libcanberra-gtk2 sound-theme-freedesktop"
33
34FILES_${PN} += " \
35 ${libdir}/xfce4 \
36 ${datadir}/xfce4 \
37"
38
39do_install_prepend() {
40 # somehow binary files are not patched correctly by oe-patch - so copy them
41 cp ${WORKDIR}/touchscreen/invisible ${S}/cursors
42 cp ${WORKDIR}/touchscreen/wait ${S}/cursors
43}
44
45RRECOMMENDS_${PN} += "gnome-icon-theme"
46RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','alsa','libcanberra-alsa','',d)}"
47RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES','pulseaudio','libcanberra-pulse','',d)}"