summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
new file mode 100644
index 000000000..74289fb35
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.10.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
5DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck dbus dbus-glib xfconf"
6RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth upower"
7
8inherit xfce update-alternatives
9
10SRC_URI[md5sum] = "1757657c1d590aa6274b7b7cbba33352"
11SRC_URI[sha256sum] = "0154fabdc398798c3445374ccc52a2f5bcb2d867fc94bc54114395b24f9cfc83"
12SRC_URI += " \
13 file://0001-configure.in-hard-code-path-to-iceauth.patch \
14"
15
16ALTERNATIVE_${PN} = "x-session-manager"
17ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/xfce4-session"
18ALTERNATIVE_PRIORITY_${PN} = "100"
19
20# protect from frightening message that xfce might not work correctly
21pkg_postinst_${PN} () {
22 echo 127.0.0.1 ${MACHINE} >> /etc/hosts
23}
24
25PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
26PACKAGECONFIG[systemd] = "--enable-systemd, --disable-systemd, polkit, systemd"
27PACKAGECONFIG[consolekit] = ",,,consolekit"
28
29FILES_${PN} += "${libdir}/xfce4/*/*/*.so \
30 ${libdir}/xfce4/session/*-*-* \
31 ${datadir}/xsessions \
32 ${datadir}/themes/Default/balou/*"
33
34FILES_${PN}-dbg += "${libdir}/xfce4/*/*/.debug"
35
36FILES_${PN}-staticdev += "${libdir}/xfce4/*/*/*.*a"