summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb
new file mode 100644
index 000000000..a4aaf668d
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-power-manager/xfce4-power-manager_1.4.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Power manager for the Xfce desktop environment"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
3SECTION = "x11"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8inherit xfce
9
10DEPENDS = "gtk+ glib-2.0 dbus-glib xfconf libxfce4ui libxfce4util libnotify \
11 libxrandr virtual/libx11 libxext xfce4-panel"
12
13SRC_URI[md5sum] = "808a2630487d75e6eae915e464b7fda3"
14SRC_URI[sha256sum] = "16a9e9bf3e0f8480d05b248817fbdc59e701e9161d3d0c7e53f3de28ed491f58"
15
16EXTRA_OECONF = " \
17 --enable-network-manager \
18 --enable-panel-plugins \
19"
20
21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','systemd','systemd','',d)}"
22PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit"
23
24PACKAGES += "xfce4-powermanager-plugin"
25
26FILES_${PN} += " \
27 ${datadir}/polkit-1 \
28 ${datadir}/appdata \
29"
30
31FILES_xfce4-powermanager-plugin = " \
32 ${libdir}/xfce4 \
33 ${datadir}/xfce4 \
34"
35
36RDEPENDS_xfce4-powermanager-plugin = "${PN}"
37RDEPENDS_${PN} = "networkmanager udisks upower ${@base_contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
38
39# xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
40RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
41RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
42RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin"