summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb
new file mode 100644
index 000000000..08703e788
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ dbus cairo virtual/libx11 libxml2 libwnck"
6
7inherit xfce
8
9SRC_URI[md5sum] = "8a1f8371fc725ba00f4594c5c0f81c59"
10SRC_URI[sha256sum] = "573052ed1b65e247415f92df120c8a78f9e4152c2636d38c923f82e32b8475d6"
11
12python populate_packages_prepend() {
13 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
14 plugin_name = d.expand('${PN}-plugin-%s')
15 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
16 '${PN} plugin for %s', extra_depends='', prepend=True,
17 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
18 '${sysconfdir}/xdg/xfce/panel/%s-*',
19 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
20 '${bindir}/*%s*'])
21}
22
23PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
24
25FILES_${PN} += "${libdir}/xfce4/panel/migrate \
26 ${libdir}/xfce4/panel/wrapper"
27
28FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
29"