summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/packagegroups')
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb35
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb56
2 files changed, 91 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb
new file mode 100644
index 000000000..28cfc7f0f
--- /dev/null
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-base.bb
@@ -0,0 +1,35 @@
1SUMMARY = "All packages required for a base installation of XFCE"
2SECTION = "x11/wm"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5PR = "r5"
6
7inherit packagegroup
8
9RDEPENDS_${PN} = " \
10 xfwm4 \
11 xfce4-session \
12 xfconf \
13 xfdesktop \
14 xfce4-panel \
15 \
16 gtk-xfce-engine \
17 \
18 xfce4-panel-plugin-actions \
19 xfce4-panel-plugin-applicationsmenu \
20 xfce4-panel-plugin-clock \
21 xfce4-panel-plugin-directorymenu \
22 xfce4-panel-plugin-launcher \
23 xfce4-panel-plugin-pager \
24 xfce4-panel-plugin-separator \
25 xfce4-panel-plugin-showdesktop \
26 xfce4-panel-plugin-systray \
27 xfce4-panel-plugin-tasklist \
28 xfce4-panel-plugin-windowmenu \
29 xfce4-settings \
30 \
31 xfce4-notifyd \
32 xfce4-terminal \
33 thunar \
34 thunar-volman \
35"
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
new file mode 100644
index 000000000..af8977d38
--- /dev/null
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
@@ -0,0 +1,56 @@
1SUMMARY = "All packages for full XFCE installation"
2SECTION = "x11/wm"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
5
6PR = "r10"
7
8inherit packagegroup
9
10# mandatory
11RDEPENDS_${PN} = " \
12 packagegroup-xfce-base \
13"
14
15# nice to have
16RRECOMMENDS_${PN} = " \
17 xfwm4-theme-daloa \
18 xfwm4-theme-kokodi \
19 xfwm4-theme-moheli \
20 \
21 xfce4-cpufreq-plugin \
22 xfce4-cpugraph-plugin \
23 xfce4-datetime-plugin \
24 xfce4-eyes-plugin \
25 xfce4-clipman-plugin \
26 xfce4-diskperf-plugin \
27 xfce4-netload-plugin \
28 xfce4-genmon-plugin \
29 xfce4-xkb-plugin \
30 xfce4-wavelan-plugin \
31 xfce4-places-plugin \
32 xfce4-systemload-plugin \
33 xfce4-time-out-plugin \
34 xfce4-embed-plugin \
35 xfce4-weather-plugin \
36 xfce4-fsguard-plugin \
37 xfce4-battery-plugin \
38 xfce4-mount-plugin \
39 xfce4-powermanager-plugin \
40 xfce4-closebutton-plugin \
41 xfce4-equake-plugin \
42 xfce4-notes-plugin \
43 xfce4-whiskermenu-plugin \
44 xfce4-mailwatch-plugin \
45 \
46 thunar-media-tags-plugin \
47 thunar-archive-plugin \
48 \
49 xfce4-appfinder \
50 xfce4-screenshooter \
51 xfce4-power-manager \
52 xfce4-mixer \
53 ristretto \
54 xfce4-taskmanager \
55 gigolo \
56"