summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/libxfce4ui
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/libxfce4ui')
-rw-r--r--meta-xfce/recipes-xfce/libxfce4ui/files/0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch31
-rw-r--r--meta-xfce/recipes-xfce/libxfce4ui/files/0002-configure.ac.in-remove-optional-gtk3-support.patch37
-rw-r--r--meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb29
3 files changed, 97 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/libxfce4ui/files/0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch b/meta-xfce/recipes-xfce/libxfce4ui/files/0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch
new file mode 100644
index 000000000..b8c917883
--- /dev/null
+++ b/meta-xfce/recipes-xfce/libxfce4ui/files/0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch
@@ -0,0 +1,31 @@
1From 708e59caaf1c0c271a96a4d1fe46b122aff45e34 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 27 Aug 2012 09:16:29 +0200
4Subject: [PATCH] libxfce4kbd-private/xfce4-keyboard-shortcuts.xml: fix xfwm4
5 crash on first start
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10Upstream-Status: Pending
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 libxfce4kbd-private/xfce4-keyboard-shortcuts.xml | 4 ++++
14 1 files changed, 4 insertions(+), 0 deletions(-)
15
16diff --git a/libxfce4kbd-private/xfce4-keyboard-shortcuts.xml b/libxfce4kbd-private/xfce4-keyboard-shortcuts.xml
17index 723a10d..e6502f3 100644
18--- a/libxfce4kbd-private/xfce4-keyboard-shortcuts.xml
19+++ b/libxfce4kbd-private/xfce4-keyboard-shortcuts.xml
20@@ -66,4 +66,8 @@
21 <property name="&lt;Control&gt;F12" type="string" value="workspace_12_key"/>
22 </property>
23 </property>
24+ <property name="providers" type="array">
25+ <value type="string" value="commands"/>
26+ <value type="string" value="xfwm4"/>
27+ </property>
28 </channel>
29--
301.7.6.5
31
diff --git a/meta-xfce/recipes-xfce/libxfce4ui/files/0002-configure.ac.in-remove-optional-gtk3-support.patch b/meta-xfce/recipes-xfce/libxfce4ui/files/0002-configure.ac.in-remove-optional-gtk3-support.patch
new file mode 100644
index 000000000..a93fabfac
--- /dev/null
+++ b/meta-xfce/recipes-xfce/libxfce4ui/files/0002-configure.ac.in-remove-optional-gtk3-support.patch
@@ -0,0 +1,37 @@
1From d61dc6718a2abaf70d19f17d34128cb7e161e057 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Wed, 18 Sep 2013 20:50:11 +0200
4Subject: [PATCH] configure.ac.in: remove optional gtk3 support
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9it drags in gtk3 if that was build before. This is not yet wanted
10
11Upstream-Status: Inappropriate [configuration]
12
13Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
14---
15 configure.ac.in | 6 ------
16 1 file changed, 6 deletions(-)
17
18diff --git a/configure.ac.in b/configure.ac.in
19index e47df04..b6edab1 100644
20--- a/configure.ac.in
21+++ b/configure.ac.in
22@@ -129,12 +129,6 @@ XDT_CHECK_PACKAGE([GOBJECT], [gobject-2.0], [2.28.0])
23 XDT_CHECK_PACKAGE([GTK2], [gtk+-2.0], [2.24.0])
24 XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0])
25
26-dnl ***********************************************************
27-dnl *** Optional support for a GTK+3 version of the library ***
28-dnl ***********************************************************
29-XDT_CHECK_OPTIONAL_PACKAGE([GTK3],
30- [gtk+-3.0], [3.2.0], [gtk3],
31- [GTK+ 3 support])
32 AM_CONDITIONAL([ENABLE_GTK3_LIBRARY], [test "x$GTK3_FOUND" = "xyes"])
33
34 dnl *************************************************
35--
361.8.3.1
37
diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
new file mode 100644
index 000000000..6534f940c
--- /dev/null
+++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Xfce4 Widget library and X Window System interaction"
2SECTION = "x11/libs"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
5DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf xfce4-dev-tools virtual/libx11 libsm libice"
6
7inherit autotools gettext gtk-doc xfce xfce-git
8
9SRC_URI = " \
10 git://git.xfce.org/xfce/libxfce4ui;protocol=git \
11 file://0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch \
12 file://0002-configure.ac.in-remove-optional-gtk3-support.patch \
13"
14SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
15PV = "4.10.0+git${SRCPV}"
16S = "${WORKDIR}/git"
17
18EXTRA_OECONF += "--enable-maintainer-mode --disable-debug --with-vendor-info=${DISTRO}"
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
22PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
23
24FILES_${PN}-dbg += "${libdir}/glade3/modules/.debug"
25FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
26 ${datadir}/glade3/catalogs/*.in"
27PACKAGES += "${PN}-glade"
28FILES_${PN}-glade = "${libdir}/glade3 \
29 ${datadir}/glade3"