summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo_0.10.2.bb')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
new file mode 100644
index 000000000..ef8e55fa6
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
@@ -0,0 +1,37 @@
1DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
7PR = "r4"
8
9inherit xfce pythonnative perlnative gtk-doc
10
11# SRC_URI must follow inherited one
12SRC_URI += " \
13 file://exo-no-tests-0.8.patch \
14 file://configure.patch \
15"
16
17SRC_URI_append_class-native = " \
18 file://reduce-build-to-exo-csource-only.patch \
19"
20
21SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748"
22SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce"
23
24PACKAGES =+ "exo-csource"
25
26# Note: python bindings did not work in oe-dev and are about to be moved to
27# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
28FILES_${PN} += "${datadir}/xfce4/ \
29 ${libdir}/xfce4/exo-1 \
30"
31
32FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
33"
34
35FILES_exo-csource += "${bindir}/exo-csource"
36
37BBCLASSEXTEND = "native"