summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/configure.patch43
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.8.patch31
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch80
3 files changed, 154 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/configure.patch b/meta-xfce/recipes-xfce/exo/exo/configure.patch
new file mode 100644
index 000000000..ef27e423b
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/configure.patch
@@ -0,0 +1,43 @@
1--- a/configure.ac 2007-12-02 10:37:06.000000000 -0200
2+++ b/configure.ac 2008-06-05 17:21:42.000000000 -0300
3@@ -127,22 +127,24 @@
4 dnl ***************************************
5 dnl *** Check for strftime() extensions ***
6 dnl ***************************************
7-AC_TRY_RUN([
8- #include <string.h>
9- #include <time.h>
10- int
11- main (int argc, char **argv)
12- {
13- struct tm tm;
14- char buffer[16];
15- tm.tm_year = 81;
16- if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
17- return 0;
18- return 1;
19- }
20-], [
21- AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
22-])
23+dnl grrrr... this doesn't work for cross compiling, define it for OE
24+AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
25+dnl AC_TRY_RUN([
26+dnl #include <string.h>
27+dnl #include <time.h>
28+dnl int
29+dnl main (int argc, char **argv)
30+dnl {
31+dnl struct tm tm;
32+dnl char buffer[16];
33+dnl tm.tm_year = 81;
34+dnl if (strftime (buffer, 16, "%EY", &tm) == 4 && strcmp (buffer, "1981") == 0)
35+dnl return 0;
36+dnl return 1;
37+dnl }
38+dnl ], [
39+dnl AC_DEFINE([HAVE_STRFTIME_EXTENSION], 1, [Define if strftime supports %E and %O modifiers.])
40+dnl ])
41
42 dnl ******************************
43 dnl *** Check for i18n support ***
diff --git a/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.8.patch b/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.8.patch
new file mode 100644
index 000000000..ac8bca5f3
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/exo-no-tests-0.8.patch
@@ -0,0 +1,31 @@
1From 5f1e19860d89647488bdd32a02fb332f69434405 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 18 May 2012 21:13:00 +0200
4Subject: [PATCH] Do not run tests at build time
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8Upstream-Status: Not-Applicable
9
10Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
11---
12 Makefile.am | 3 +--
13 1 files changed, 1 insertions(+), 2 deletions(-)
14
15diff --git a/Makefile.am b/Makefile.am
16index 0ab3853..3e72391 100644
17--- a/Makefile.am
18+++ b/Makefile.am
19@@ -8,8 +8,7 @@ SUBDIRS = \
20 docs \
21 icons \
22 pixmaps \
23- po \
24- tests
25+ po
26
27 AUTOMAKE_OPTIONS = \
28 1.9 \
29--
301.7.4.4
31
diff --git a/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch
new file mode 100644
index 000000000..84b237096
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch
@@ -0,0 +1,80 @@
1From e710d8d4a3e3480416826c70d56ea3d2598a77e4 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 28 Mar 2013 23:41:03 +0100
4Subject: [PATCH] reduce build to exo-csource only
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9exo-csource creates c-header files from glade resource output files. When
10building xfce-packages from git instead of tarball this exo-csource-native is
11required.
12
13Upstream-Status: Inappropriate [configuration]
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 Makefile.am | 10 +---------
18 configure.ac | 20 --------------------
19 2 files changed, 1 insertions(+), 29 deletions(-)
20
21diff --git a/Makefile.am b/Makefile.am
22index c2e3fff..79b0931 100644
23--- a/Makefile.am
24+++ b/Makefile.am
25@@ -1,13 +1,5 @@
26 SUBDIRS = \
27- exo \
28- exo-csource \
29- exo-desktop-item-edit \
30- exo-helper \
31- exo-open \
32- docs \
33- icons \
34- pixmaps \
35- po
36+ exo-csource
37
38 AUTOMAKE_OPTIONS = \
39 1.9 \
40diff --git a/configure.ac b/configure.ac
41index efcd62e..aac2495 100644
42--- a/configure.ac
43+++ b/configure.ac
44@@ -110,15 +110,6 @@ AC_PROG_CC()
45 AM_PROG_CC_C_O()
46 AC_PROG_INSTALL()
47 AC_PROG_INTLTOOL([0.31], [no-xml])
48-AC_CHECK_PROGS([PERL], [perl5 perl])
49-
50-dnl ***************************************
51-dnl *** Check for required Perl modules ***
52-dnl ***************************************
53-AC_PROG_PERL_MODULES([URI::Escape URI::file URI::URL], [],
54-[
55- AC_MSG_ERROR([Atleast one of the required Perl modules (URI::Escape, URI::file and URI::URL) was not found on your system])
56-])
57
58 dnl ***************************************
59 dnl *** Check for standard header files ***
60@@ -165,17 +156,6 @@ dnl ***********************************
61 dnl *** Check for required packages ***
62 dnl ***********************************
63 XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.30.0])
64-XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.30.0])
65-XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.24.0])
66-XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.30.0])
67-XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0])
68-XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.10.0])
69-XDT_CHECK_OPTIONAL_PACKAGE([GIO_UNIX], [gio-unix-2.0], [2.30.0], [gio-unix], [GIO-Unix features])
70-
71-dnl *********************
72-dnl *** Check for X11 ***
73-dnl *********************
74-XDT_CHECK_LIBX11_REQUIRE()
75
76 dnl *************************
77 dnl *** Check for gtk-doc ***
78--
791.7.4.4
80