summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch')
-rw-r--r--meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch50
1 files changed, 26 insertions, 24 deletions
diff --git a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
index dcc2a3719..e2165c2fa 100644
--- a/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
+++ b/meta-xfce/recipes-panel-plugins/mount/xfce4-mount-plugin/0001-check-for-fstab.h-during-configure.patch
@@ -10,16 +10,19 @@ plugin
10Makes it compile/build with musl 10Makes it compile/build with musl
11 11
12Signed-off-by: Khem Raj <raj.khem@gmail.com> 12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13
14Patch Reworked for xfce4-mount-plugin 0.6.4->1.1.2
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
13--- 16---
14 configure.ac | 1 + 17 configure.ac | 1 +
15 panel-plugin/devices.c | 22 ++++++++++++++++++---- 18 panel-plugin/devices.c | 22 +++++++++++++++++++---
16 2 files changed, 19 insertions(+), 4 deletions(-) 19 2 files changed, 20 insertions(+), 3 deletions(-)
17 20
18diff --git a/configure.ac b/configure.ac 21diff --git a/configure.ac b/configure.ac
19index 34d6f7f..52ecc4a 100644 22index b131117..c633fef 100644
20--- a/configure.ac 23--- a/configure.ac
21+++ b/configure.ac 24+++ b/configure.ac
22@@ -67,6 +67,7 @@ AC_CHECK_HEADERS([sys/socket.h]) 25@@ -69,6 +69,7 @@ AC_CHECK_HEADERS([sys/socket.h])
23 AC_CHECK_HEADERS([sys/time.h]) 26 AC_CHECK_HEADERS([sys/time.h])
24 AC_CHECK_HEADERS([unistd.h]) 27 AC_CHECK_HEADERS([unistd.h])
25 AC_CHECK_HEADERS([sys/sockio.h]) 28 AC_CHECK_HEADERS([sys/sockio.h])
@@ -28,10 +31,10 @@ index 34d6f7f..52ecc4a 100644
28 AC_PROG_GCC_TRADITIONAL 31 AC_PROG_GCC_TRADITIONAL
29 AC_TYPE_SIZE_T 32 AC_TYPE_SIZE_T
30diff --git a/panel-plugin/devices.c b/panel-plugin/devices.c 33diff --git a/panel-plugin/devices.c b/panel-plugin/devices.c
31index afa954e..345b603 100644 34index 797b079..d29df56 100644
32--- a/panel-plugin/devices.c 35--- a/panel-plugin/devices.c
33+++ b/panel-plugin/devices.c 36+++ b/panel-plugin/devices.c
34@@ -24,8 +24,9 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. 37@@ -24,8 +24,10 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
35 #ifdef HAVE_CONFIG_H 38 #ifdef HAVE_CONFIG_H
36 #include <config.h> 39 #include <config.h>
37 #endif 40 #endif
@@ -39,41 +42,40 @@ index afa954e..345b603 100644
39+#if HAVE_FSTAB_H 42+#if HAVE_FSTAB_H
40 #include <fstab.h> 43 #include <fstab.h>
41+#endif 44+#endif
45+
42 #include <glib.h> 46 #include <glib.h>
43 #include <stdio.h> 47 #include <stdio.h>
44 #include <string.h> 48 #include <string.h>
45@@ -370,14 +371,15 @@ out: 49@@ -468,11 +470,12 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
46 GPtrArray *
47 disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
48 { 50 {
49- GPtrArray * pdisks; /* to be returned */ 51 GPtrArray * pdisks; /* to be returned */
50+ GtkWidget *dialog;
51 t_disk * pdisk; 52 t_disk * pdisk;
52- struct fstab *pfstab; 53- struct fstab *pfstab;
53+ GPtrArray * pdisks; /* to be returned */
54 gboolean has_valid_mount_device; 54 gboolean has_valid_mount_device;
55- GtkWidget *dialog;
56 55
57 pdisks = g_ptr_array_new(); 56 pdisks = g_ptr_array_new();
58+#if HAVE_FSTAB_H
59 57
58+#if HAVE_FSTAB_H
60+ struct fstab *pfstab; 59+ struct fstab *pfstab;
61 /* open fstab */ 60 /* open fstab */
62 if (setfsent()!=1) 61 if (setfsent()!=1)
63 { 62 {
64@@ -422,6 +424,18 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length) 63@@ -526,7 +529,20 @@ disks_new (gboolean include_NFSs, gboolean *showed_fstab_dialog, gint length)
64 } /* end for */
65 65
66 endfsent(); /* close file */ 66 endfsent(); /* close file */
67 67-
68+#else 68+#else
69+ /* popup notification dialog */
69+ if (! (*showed_fstab_dialog) ) { 70+ if (! (*showed_fstab_dialog) ) {
70+ dialog = gtk_message_dialog_new (NULL, GTK_DIALOG_DESTROY_WITH_PARENT, 71+ xfce_message_dialog (NULL,
71+ GTK_MESSAGE_INFO, GTK_BUTTONS_OK, 72+ _("Xfce 4 Mount Plugin"),
72+ "Your /etc/fstab could not be read because fstab is not supported. This will severely degrade the plugin's abilities."); 73+ "dialog-info",
73+ /* gtk_dialog_run (GTK_DIALOG (dialog)); */ 74+ _("Your /etc/fstab could not be read because fstab is not supported. This will severely degrade the plugin's abilities."),
74+ g_signal_connect (dialog, "response", 75+ NULL,
75+ G_CALLBACK (gtk_widget_destroy), dialog); 76+ "gtk-ok",
76+ gtk_widget_show (dialog); 77+ GTK_RESPONSE_OK,
78+ NULL);
77+ *showed_fstab_dialog = TRUE; 79+ *showed_fstab_dialog = TRUE;
78+ } 80+ }
79+#endif 81+#endif
@@ -81,5 +83,5 @@ index afa954e..345b603 100644
81 } 83 }
82 84
83-- 85--
842.12.0 862.9.3
85 87