summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb')
-rw-r--r--meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb b/meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb
new file mode 100644
index 000000000..479f1a4df
--- /dev/null
+++ b/meta-xfce/recipes-multimedia/parole/parole_1.0.0.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/parole"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6inherit xfce-app gtk-doc mime
7
8DEPENDS += " \
9 glib-2.0 \
10 dbus-glib \
11 gtk+3 \
12 \
13 xfce4-dev-tools-native \
14 libxfce4util \
15 libxfce4ui \
16 xfconf \
17 \
18 gstreamer1.0-plugins-base \
19 taglib \
20"
21
22SRC_URI[md5sum] = "d00d3ca571900826bf5e1f6986e42992"
23SRC_URI[sha256sum] = "6666b335aeb690fb527f77b62c322baf34834b593659fdcd21d21ed3f1e14010"
24
25RDEPENDS_${PN} += "gstreamer1.0-plugins-good"
26
27EXTRA_OECONF = "--disable-gtk-doc"
28
29PACKAGECONFIG ??= "notify"
30PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
31PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
32
33FILES_${PN} += " \
34 ${datadir}/appdata \
35 ${libdir}/parole-0/*.so \
36"
37FILES_${PN}-dbg += "${libdir}/parole-0/.debug"
38FILES_${PN}-dev += "${libdir}/parole-0/*.la"