summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch')
-rw-r--r--meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch b/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch
new file mode 100644
index 000000000..98ce875b7
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-screenshooter/files/0001-Fix-panel-plugin-build.patch
@@ -0,0 +1,43 @@
1From 08053be7adc6d4a83191efed735c3f565bcbcf1f Mon Sep 17 00:00:00 2001
2From: Samuli Suominen <ssuominen@gentoo.org>
3Date: Sat, 5 May 2012 17:13:45 +0200
4Subject: [PATCH] Fix panel plugin build.
5
6- Don't use a versioned library.
7- Build as a module.
8- Only export needed symbols.
9---
10Upstream-Status: applied
11 Makefile.am | 12 +++++++++---
12 1 files changed, 9 insertions(+), 3 deletions(-)
13
14diff --git a/Makefile.am b/Makefile.am
15index 45100fd..d0c0adb 100644
16--- a/Makefile.am
17+++ b/Makefile.am
18@@ -132,13 +132,19 @@ panel_plugin_libscreenshooterplugin_la_CFLAGS = \
19 @SOUP_CFLAGS@
20
21 panel_plugin_libscreenshooterplugin_la_LDFLAGS = \
22+ -avoid-version \
23+ -module \
24+ -no-undefined \
25+ -export-symbols-regex '^xfce_panel_module_(preinit|init|construct)' \
26+ $(PLATFORM_LDFLAGS)
27+
28+panel_plugin_libscreenshooterplugin_la_LIBADD = \
29 @EXO_LIBS@ \
30 @LIBXFCE4PANEL_LIBS@ \
31 @GTHREAD_LIBS@ \
32 @SOUP_LIBS@ \
33- @LIBXFCE4UI_LIBS@
34-
35-panel_plugin_libscreenshooterplugin_la_LIBADD = lib/libscreenshooter.la
36+ @LIBXFCE4UI_LIBS@ \
37+ lib/libscreenshooter.la
38
39 panel_plugin_libscreenshooterplugin_la_SOURCES = \
40 panel-plugin/screenshooter-plugin.c
41--
421.7.4.4
43