diff options
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb | 10 | ||||
-rwxr-xr-x | meta-webserver/recipes-httpd/apache2/files/init | 6 |
2 files changed, 10 insertions, 6 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb index 15c4d024f..0eb53275c 100644 --- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb +++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb | |||
@@ -6,7 +6,7 @@ DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util" | |||
6 | RDEPENDS_${PN} += "openssl libgcc" | 6 | RDEPENDS_${PN} += "openssl libgcc" |
7 | SECTION = "net" | 7 | SECTION = "net" |
8 | LICENSE = "Apache-2.0" | 8 | LICENSE = "Apache-2.0" |
9 | PR = "r0" | 9 | PR = "r1" |
10 | 10 | ||
11 | SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ | 11 | SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ |
12 | file://server-makefile.patch \ | 12 | file://server-makefile.patch \ |
@@ -68,8 +68,12 @@ do_install_append() { | |||
68 | # Expat should be found in the staging area via DEPENDS... | 68 | # Expat should be found in the staging area via DEPENDS... |
69 | rm -f ${D}/${libdir}/libexpat.* | 69 | rm -f ${D}/${libdir}/libexpat.* |
70 | 70 | ||
71 | # Ensure configuration file pulls in modules.d | 71 | install -d ${D}${sysconfdir}/${PN}/conf.d |
72 | printf "\nInclude ${sysconfdir}/${PN}/modules.d/*\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf | 72 | install -d ${D}${sysconfdir}/${PN}/modules.d |
73 | |||
74 | # Ensure configuration file pulls in conf.d and modules.d | ||
75 | printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf | ||
76 | printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf | ||
73 | } | 77 | } |
74 | 78 | ||
75 | SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" | 79 | SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" |
diff --git a/meta-webserver/recipes-httpd/apache2/files/init b/meta-webserver/recipes-httpd/apache2/files/init index 85af74283..346dc0d52 100755 --- a/meta-webserver/recipes-httpd/apache2/files/init +++ b/meta-webserver/recipes-httpd/apache2/files/init | |||
@@ -9,12 +9,12 @@ | |||
9 | # implementing the current HTTP standards. | 9 | # implementing the current HTTP standards. |
10 | ### END INIT INFO | 10 | ### END INIT INFO |
11 | 11 | ||
12 | ARGS="-D SSL -k start" | 12 | ARGS="-D SSL -D PHP5 -k start" |
13 | NAME=apache2 | 13 | NAME=apache2 |
14 | PATH=/bin:/usr/bin:/sbin:/usr/sbin | 14 | PATH=/bin:/usr/bin:/sbin:/usr/sbin |
15 | DAEMON=/usr/sbin/httpd | 15 | DAEMON=/usr/sbin/httpd |
16 | SUEXEC=/usr/lib/apache/suexec | 16 | SUEXEC=/usr/lib/apache/suexec |
17 | PIDFILE=/var/run/$NAME.pid | 17 | PIDFILE=/var/apache2/logs/httpd.pid |
18 | CONF=/etc/apache2/httpd.conf | 18 | CONF=/etc/apache2/httpd.conf |
19 | APACHECTL=/usr/sbin/apachectl | 19 | APACHECTL=/usr/sbin/apachectl |
20 | 20 | ||
@@ -40,7 +40,7 @@ case "$1" in | |||
40 | 40 | ||
41 | reload) | 41 | reload) |
42 | echo -n "Reloading $NAME configuration" | 42 | echo -n "Reloading $NAME configuration" |
43 | $APACHECTL reload | 43 | kill -HUP `cat $PIDFILE` |
44 | ;; | 44 | ;; |
45 | 45 | ||
46 | reload-modules) | 46 | reload-modules) |