diff options
Diffstat (limited to 'meta-webserver')
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch | 31 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/nginx_1.10.0.bb | 6 | ||||
-rw-r--r-- | meta-webserver/recipes-httpd/nginx/nginx_1.8.1.bb | 6 |
3 files changed, 18 insertions, 25 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch b/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch index 46792ba06..5e96644aa 100644 --- a/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch +++ b/meta-webserver/recipes-httpd/nginx/files/nginx-cross.patch | |||
@@ -6,7 +6,7 @@ Upstream-Status: Pending | |||
6 | diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature | 6 | diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature |
7 | --- nginx-1.0.11.orig/auto/feature 2011-05-11 06:50:19.000000000 -0500 | 7 | --- nginx-1.0.11.orig/auto/feature 2011-05-11 06:50:19.000000000 -0500 |
8 | +++ nginx-1.0.11/auto/feature 2011-12-27 13:56:42.323370040 -0600 | 8 | +++ nginx-1.0.11/auto/feature 2011-12-27 13:56:42.323370040 -0600 |
9 | @@ -48,12 +48,20 @@ | 9 | @@ -49,12 +49,20 @@ |
10 | 10 | ||
11 | if [ -x $NGX_AUTOTEST ]; then | 11 | if [ -x $NGX_AUTOTEST ]; then |
12 | 12 | ||
@@ -29,7 +29,7 @@ diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature | |||
29 | ngx_found=yes | 29 | ngx_found=yes |
30 | 30 | ||
31 | if test -n "$ngx_feature_name"; then | 31 | if test -n "$ngx_feature_name"; then |
32 | @@ -67,17 +75,27 @@ | 32 | @@ -68,17 +75,27 @@ |
33 | 33 | ||
34 | value) | 34 | value) |
35 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages | 35 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages |
@@ -61,7 +61,7 @@ diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature | |||
61 | else | 61 | else |
62 | echo " found but is not working" | 62 | echo " found but is not working" |
63 | fi | 63 | fi |
64 | @@ -85,7 +103,7 @@ | 64 | @@ -86,7 +105,7 @@ |
65 | 65 | ||
66 | bug) | 66 | bug) |
67 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages | 67 | # /bin/sh is used to intercept "Killed" or "Abort trap" messages |
@@ -73,8 +73,8 @@ diff -uraN nginx-1.0.11.orig/auto/feature nginx-1.0.11/auto/feature | |||
73 | diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options | 73 | diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options |
74 | --- nginx-1.0.11.orig/auto/options 2011-12-14 07:34:16.000000000 -0600 | 74 | --- nginx-1.0.11.orig/auto/options 2011-12-14 07:34:16.000000000 -0600 |
75 | +++ nginx-1.0.11/auto/options 2011-12-27 13:56:42.323370040 -0600 | 75 | +++ nginx-1.0.11/auto/options 2011-12-27 13:56:42.323370040 -0600 |
76 | @@ -289,6 +289,18 @@ | 76 | @@ -353,6 +353,18 @@ |
77 | --test-build-rtsig) NGX_TEST_BUILD_RTSIG=YES ;; | 77 | --test-build-epoll) NGX_TEST_BUILD_EPOLL=YES ;; |
78 | --test-build-solaris-sendfilev) NGX_TEST_BUILD_SOLARIS_SENDFILEV=YES ;; | 78 | --test-build-solaris-sendfilev) NGX_TEST_BUILD_SOLARIS_SENDFILEV=YES ;; |
79 | 79 | ||
80 | + # cross compile support | 80 | + # cross compile support |
@@ -92,7 +92,7 @@ diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options | |||
92 | *) | 92 | *) |
93 | echo "$0: error: invalid option \"$option\"" | 93 | echo "$0: error: invalid option \"$option\"" |
94 | exit 1 | 94 | exit 1 |
95 | @@ -434,6 +446,17 @@ | 95 | @@ -533,6 +445,17 @@ |
96 | 96 | ||
97 | --with-debug enable debug logging | 97 | --with-debug enable debug logging |
98 | 98 | ||
@@ -110,7 +110,7 @@ diff -uraN nginx-1.0.11.orig/auto/options nginx-1.0.11/auto/options | |||
110 | END | 110 | END |
111 | 111 | ||
112 | exit 1 | 112 | exit 1 |
113 | @@ -455,6 +478,8 @@ | 113 | @@ -554,6 +577,8 @@ |
114 | 114 | ||
115 | if [ ".$NGX_PLATFORM" = ".win32" ]; then | 115 | if [ ".$NGX_PLATFORM" = ".win32" ]; then |
116 | NGX_WINE=$WINE | 116 | NGX_WINE=$WINE |
@@ -137,14 +137,14 @@ diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | |||
137 | 137 | ||
138 | #include <sys/types.h> | 138 | #include <sys/types.h> |
139 | #include <sys/time.h> | 139 | #include <sys/time.h> |
140 | @@ -33,20 +36,20 @@ | 140 | @@ -33,15 +36,16 @@ |
141 | END | 141 | END |
142 | 142 | ||
143 | 143 | ||
144 | -ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | 144 | -ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ |
145 | - -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | 145 | - -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" |
146 | + ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ | 146 | + ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \ |
147 | + -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" | 147 | + -o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs" |
148 | 148 | ||
149 | -eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | 149 | -eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" |
150 | + eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" | 150 | + eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1" |
@@ -153,20 +153,13 @@ diff -uraN nginx-1.0.11.orig/auto/types/sizeof nginx-1.0.11/auto/types/sizeof | |||
153 | -if [ -x $NGX_AUTOTEST ]; then | 153 | -if [ -x $NGX_AUTOTEST ]; then |
154 | - ngx_size=`$NGX_AUTOTEST` | 154 | - ngx_size=`$NGX_AUTOTEST` |
155 | - echo " $ngx_size bytes" | 155 | - echo " $ngx_size bytes" |
156 | -fi | ||
157 | + if [ -x $NGX_AUTOTEST ]; then | 156 | + if [ -x $NGX_AUTOTEST ]; then |
158 | + ngx_size=`$NGX_AUTOTEST` | 157 | + ngx_size=`$NGX_AUTOTEST` |
159 | + echo " $ngx_size bytes" | 158 | + echo " $ngx_size bytes" |
160 | + fi | 159 | + fi |
160 | fi | ||
161 | 161 | ||
162 | 162 | ||
163 | -rm -rf $NGX_AUTOTEST* | ||
164 | - | ||
165 | + rm -rf $NGX_AUTOTEST* | ||
166 | +fi | ||
167 | |||
168 | case $ngx_size in | ||
169 | 4) | ||
170 | diff -uraN nginx-1.0.11.orig/auto/unix nginx-1.0.11/auto/unix | 163 | diff -uraN nginx-1.0.11.orig/auto/unix nginx-1.0.11/auto/unix |
171 | --- nginx-1.0.11.orig/auto/unix 2011-12-14 07:34:16.000000000 -0600 | 164 | --- nginx-1.0.11.orig/auto/unix 2011-12-14 07:34:16.000000000 -0600 |
172 | +++ nginx-1.0.11/auto/unix 2011-12-27 13:56:42.327370060 -0600 | 165 | +++ nginx-1.0.11/auto/unix 2011-12-27 13:56:42.327370060 -0600 |
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.10.0.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.10.0.bb new file mode 100644 index 000000000..53cce00d3 --- /dev/null +++ b/meta-webserver/recipes-httpd/nginx/nginx_1.10.0.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require nginx.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0bb58ed0dfd4f5dbece3b52aba79f023" | ||
4 | |||
5 | SRC_URI[md5sum] = "c184c873d2798c5ba92be95ed1209c02" | ||
6 | SRC_URI[sha256sum] = "8ed647c3dd65bc4ced03b0e0f6bf9e633eff6b01bac772bcf97077d58bc2be4d" | ||
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.8.1.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.8.1.bb deleted file mode 100644 index 089f547e8..000000000 --- a/meta-webserver/recipes-httpd/nginx/nginx_1.8.1.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | require nginx.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3845852aedfa8d6d7765f55d06cc3ebd" | ||
4 | |||
5 | SRC_URI[md5sum] = "2e91695074dbdfbf1bcec0ada9fda462" | ||
6 | SRC_URI[sha256sum] = "8f4b3c630966c044ec72715754334d1fdf741caa1d5795fb4646c27d09f797b7" | ||