summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
index 0eb53275c..2c0fa6b92 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.2.bb
@@ -6,11 +6,10 @@ DEPENDS = "libtool-native apache2-native openssl expat pcre apr apr-util"
6RDEPENDS_${PN} += "openssl libgcc" 6RDEPENDS_${PN} += "openssl libgcc"
7SECTION = "net" 7SECTION = "net"
8LICENSE = "Apache-2.0" 8LICENSE = "Apache-2.0"
9PR = "r1" 9PR = "r2"
10 10
11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \ 11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
12 file://server-makefile.patch \ 12 file://server-makefile.patch \
13 file://fix-libtool-name.patch \
14 file://httpd-2.4.1-corelimit.patch \ 13 file://httpd-2.4.1-corelimit.patch \
15 file://httpd-2.4.1-export.patch \ 14 file://httpd-2.4.1-export.patch \
16 file://httpd-2.4.1-selinux.patch \ 15 file://httpd-2.4.1-selinux.patch \
@@ -37,8 +36,8 @@ CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
37EXTRA_OECONF = "--enable-ssl \ 36EXTRA_OECONF = "--enable-ssl \
38 --with-ssl=${STAGING_LIBDIR}/.. \ 37 --with-ssl=${STAGING_LIBDIR}/.. \
39 --with-expat=${STAGING_LIBDIR}/.. \ 38 --with-expat=${STAGING_LIBDIR}/.. \
40 --with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 39 --with-apr=${WORKDIR}/apr-1-config \
41 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ 40 --with-apr-util=${WORKDIR}/apu-1-config \
42 --enable-info \ 41 --enable-info \
43 --enable-rewrite \ 42 --enable-rewrite \
44 --with-dbm=sdbm \ 43 --with-dbm=sdbm \
@@ -54,6 +53,15 @@ EXTRA_OECONF = "--enable-ssl \
54 --enable-mpms-shared \ 53 --enable-mpms-shared \
55 ac_cv_have_threadsafe_pollset=no" 54 ac_cv_have_threadsafe_pollset=no"
56 55
56do_configure_prepend() {
57 # FIXME: this hack is required to work around an issue with apr/apr-util
58 # Can be removed when fixed in OE-Core (also revert --with-* options above)
59 # see http://bugzilla.yoctoproject.org/show_bug.cgi?id=3267
60 cp ${STAGING_BINDIR_CROSS}/apr-1-config ${STAGING_BINDIR_CROSS}/apu-1-config ${WORKDIR}
61 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apr-1-config
62 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apu-1-config
63}
64
57do_install_append() { 65do_install_append() {
58 install -d ${D}/${sysconfdir}/init.d 66 install -d ${D}/${sysconfdir}/init.d
59 cat ${WORKDIR}/init | \ 67 cat ${WORKDIR}/init | \