summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch')
-rw-r--r--meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch b/meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch
new file mode 100644
index 000000000..11d7a9292
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/ajenti/ajenti/0001-setup.py-remove-extra-data-files.patch
@@ -0,0 +1,33 @@
1From 37bf4c471f23140e00fe87dde6f7c3cf38933c22 Mon Sep 17 00:00:00 2001
2From: Paul Eggleton <paul.eggleton@linux.intel.com>
3Date: Mon, 12 Mar 2012 02:01:48 +0000
4Subject: [PATCH] setup.py: remove extra data files
5
6Don't install files using setup.py, since this fails due to absolute
7paths and we can easily install these within the recipe instead.
8
9Upstream-Status: Inappropriate [config]
10
11Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
12---
13 setup.py | 6 ------
14 1 files changed, 0 insertions(+), 6 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index 8daea4c..11e3acb 100755
18--- a/setup.py
19+++ b/setup.py
20@@ -18,10 +18,4 @@ setup(
21 packages = find_packages(),
22 package_data={'': ['files/*.*', 'files/*/*.*', 'files/*/*/*.*', 'templates/*.*', 'widgets/*.*', 'layout/*.*']},
23 scripts=['ajenti-panel', 'ajenti-pkg'],
24- data_files=[
25- ('/etc/ajenti', ['packaging/files/ajenti.conf']),
26- ('/etc/ajenti/users', ['packaging/files/admin.conf']),
27- ('/etc/init.d', ['packaging/files/ajenti']),
28- ('/var/lib/ajenti/plugins', ['packaging/files/.placeholder']),
29- ],
30 )
31--
321.7.5.4
33