summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-support/fcgi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-support/fcgi')
-rw-r--r--meta-webserver/recipes-support/fcgi/fcgi/Fix_EOF_not_declared_issue.patch17
-rw-r--r--meta-webserver/recipes-support/fcgi/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch18
-rw-r--r--meta-webserver/recipes-support/fcgi/fcgi_2.4.0.bb15
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-webserver/recipes-support/fcgi/fcgi/Fix_EOF_not_declared_issue.patch b/meta-webserver/recipes-support/fcgi/fcgi/Fix_EOF_not_declared_issue.patch
new file mode 100644
index 000000000..51ddeaac2
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi/fcgi/Fix_EOF_not_declared_issue.patch
@@ -0,0 +1,17 @@
1Upstream-Status: Pending
2
3Fix EOF not declared issue, following is the error log.
4fcgio.cpp:70:72: error: 'EOF' was not declared in this scope
5 if (FCGX_PutStr(pbase(), plen, this->fcgx) != plen) return EOF;
6
7Signed-off-by: Yang Haibo <b40869@freescale.com>
8--- fcgi-ori/libfcgi/fcgio.cpp 2014-07-28 18:01:00.000000000 +0800
9+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2014-07-28 18:01:22.000000000 +0800
10@@ -22,6 +22,7 @@
11 #define DLLAPI __declspec(dllexport)
12 #endif
13
14+#include <stdio.h>
15 #include <limits.h>
16 #include "fcgio.h"
17
diff --git a/meta-webserver/recipes-support/fcgi/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch b/meta-webserver/recipes-support/fcgi/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch
new file mode 100644
index 000000000..eca694adc
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch
@@ -0,0 +1,18 @@
1Upstream-Status: Pending
2
3use automake options "foreign" to set the strictness as appropriate
4
5Signed-off-by: Yang Haibo <b40869@freescale.com>
6--- fcgi-ori/configure.in 2014-08-05 14:58:35.000000000 +0800
7+++ fcgi-2.4.0/configure.in 2014-08-05 14:59:08.000000000 +0800
8@@ -4,8 +4,8 @@
9 dnl generate the file "configure", which is run during the build
10 dnl to configure the system for the local environment.
11
12-AC_INIT
13-AM_INIT_AUTOMAKE(fcgi, 2.4.0)
14+AC_INIT([fcgi], [2.4.0])
15+AM_INIT_AUTOMAKE([foreign])
16
17 AM_CONFIG_HEADER(fcgi_config.h)
18
diff --git a/meta-webserver/recipes-support/fcgi/fcgi_2.4.0.bb b/meta-webserver/recipes-support/fcgi/fcgi_2.4.0.bb
new file mode 100644
index 000000000..ed718aefd
--- /dev/null
+++ b/meta-webserver/recipes-support/fcgi/fcgi_2.4.0.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "FastCGI is a protocol for interfacing interactive programs with a web server."
2HOMEPAGE = "http://www.fastcgi.com"
3LICENSE = "OML"
4LIC_FILES_CHKSUM = "file://LICENSE.TERMS;md5=e3aacac3a647af6e7e31f181cda0a06a"
5
6SRC_URI = "http://fossies.org/linux/www/${BP}.tar.gz \
7 file://Fix_EOF_not_declared_issue.patch \
8 file://add_foreign_to_AM_INIT_AUTOMAKE.patch \
9"
10SRC_URI[md5sum] = "d15060a813b91383a9f3c66faf84867e"
11SRC_URI[sha256sum] = "66fc45c6b36a21bf2fbbb68e90f780cc21a9da1fffbae75e76d2b4402d3f05b9"
12
13inherit autotools
14
15PARALLEL_MAKE = ""