diff options
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.6.1.bb')
-rw-r--r-- | meta-webserver/recipes-php/xdebug/xdebug_2.6.1.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.6.1.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.6.1.bb new file mode 100644 index 000000000..773dbf33b --- /dev/null +++ b/meta-webserver/recipes-php/xdebug/xdebug_2.6.1.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "Debugging and profiling extension for PHP" | ||
2 | LICENSE = "Xdebug" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16" | ||
4 | |||
5 | DEPENDS = "php re2c-native" | ||
6 | |||
7 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" | ||
8 | |||
9 | SRC_URI[md5sum] = "35cc0f2e8b7d40556a9ad9afd9c49aee" | ||
10 | SRC_URI[sha256sum] = "dae691d6c052073b886e0c6e1306a707bca9fd18a1e3485384ef6c4aacf1bd77" | ||
11 | |||
12 | UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" | ||
17 | |||
18 | do_configure() { | ||
19 | cd ${S} | ||
20 | ${STAGING_BINDIR_CROSS}/phpize | ||
21 | cd ${B} | ||
22 | |||
23 | # Running autoreconf as autotools_do_configure would do here | ||
24 | # breaks the libtool configuration resulting in a failure later | ||
25 | # in do_compile. It's possible this may be fixable, however the | ||
26 | # easiest course of action for the moment is to avoid doing that. | ||
27 | oe_runconf | ||
28 | } | ||
29 | |||
30 | do_install() { | ||
31 | oe_runmake install INSTALL_ROOT=${D} | ||
32 | } | ||
33 | |||
34 | FILES_${PN} += "${libdir}/php*/extensions/*/*.so" | ||
35 | FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug" | ||