summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
new file mode 100644
index 000000000..cc5bf0d24
--- /dev/null
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.5.1.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16"
4
5DEPENDS = "php"
6
7SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
8
9SRC_URI[md5sum] = "6167b1e104f1108d77f08eb561a12b22"
10SRC_URI[sha256sum] = "7fda9020fd5a2c549ae5a692fcabbb00f74e39dda81d53d25e622bdab4880ec2"
11
12inherit autotools
13
14EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
15
16do_configure() {
17 cd ${S}
18 ${STAGING_BINDIR_CROSS}/phpize
19 cd ${B}
20
21 # Running autoreconf as autotools_do_configure would do here
22 # breaks the libtool configuration resulting in a failure later
23 # in do_compile. It's possible this may be fixable, however the
24 # easiest course of action for the moment is to avoid doing that.
25 oe_runconf
26}
27
28do_install() {
29 oe_runmake install INSTALL_ROOT=${D}
30}
31
32FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
33FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
34
35PNBLACKLIST[xdebug] ?= "Depends on blacklisted php"