summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
new file mode 100644
index 000000000..ffff13565
--- /dev/null
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.5.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16"
4
5DEPENDS = "modphp"
6
7
8SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
9
10SRC_URI[md5sum] = "7e571ce8eb6fa969fd8263969019849d"
11SRC_URI[sha256sum] = "adc6fe92dcff2368be94d20a5997aadb4d46d74551e2dd6602a704a35a195a6f"
12
13inherit autotools
14
15EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
16
17do_configure() {
18 cd ${S}
19 ${STAGING_BINDIR_CROSS}/phpize
20 cd ${B}
21
22 # Running autoreconf as autotools_do_configure would do here
23 # breaks the libtool configuration resulting in a failure later
24 # in do_compile. It's possible this may be fixable, however the
25 # easiest course of action for the moment is to avoid doing that.
26 oe_runconf
27}
28
29do_install() {
30 oe_runmake install INSTALL_ROOT=${D}
31}
32
33FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
34FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
35