summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb')
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
new file mode 100644
index 000000000..3e9c982a2
--- /dev/null
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.3.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16"
4
5DEPENDS = "modphp"
6
7PR = "r0"
8
9SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
10
11SRC_URI[md5sum] = "e49cec9861b45dc0b36eae33bf8a14fa"
12SRC_URI[sha256sum] = "b351872da46ed8378dff90a87673f5ec1e0bdd94324558ebc898e1d115e9d71c"
13
14inherit autotools
15
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17
18do_configure() {
19 ${STAGING_BINDIR_CROSS}/phpize
20
21 # Running autoreconf as autotools_do_configure would do here
22 # breaks the libtool configuration resulting in a failure later
23 # in do_compile. It's possible this may be fixable, however the
24 # easiest course of action for the moment is to avoid doing that.
25 oe_runconf
26}
27
28do_install() {
29 oe_runmake install INSTALL_ROOT=${D}
30}
31
32FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
33FILES_${PN}-dbg += "${libdir}/php5/extensions/*/.debug"
34