summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb')
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb
new file mode 100644
index 000000000..0298f6b9d
--- /dev/null
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.2.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=eb723b61539feef013de476e68b5c50a \
6 file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/phpmyadmin/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
9 file://apache.conf"
10
11SRC_URI[md5sum] = "f787bcf5c98a1702d9c8c653e72eb689"
12SRC_URI[sha256sum] = "fef460aa493f696b8536c273ef126bb142b88dd15c7ef584aca90d2ea07d3bbc"
13
14S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
15
16inherit allarch
17
18do_install() {
19 install -d ${D}${datadir}/${BPN}
20 cp -a * ${D}${datadir}/${BPN}
21
22 install -d ${D}${sysconfdir}/apache2/conf.d
23 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
24
25 # Remove a few scripts that explicitly require bash (!)
26 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
27}
28
29FILES_${PN} = "${datadir}/${BPN} \
30 ${sysconfdir}/apache2/conf.d"
31