summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb')
-rw-r--r--meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb
new file mode 100644
index 000000000..2de98f453
--- /dev/null
+++ b/meta-webserver/recipes-httpd/monkey/monkey_1.5.1.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Fast and Lightweight HTTP Server for Linux"
2HOMEPAGE = "http://monkey-project.com"
3BUGTRACKER = "https://github.com/monkey/monkey/issues"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
7
8SECTION = "net"
9
10SRC_URI = "http://monkey-project.com/releases/1.5/monkey-${PV}.tar.gz \
11 file://monkey.service \
12 file://monkey.init"
13
14SRC_URI[md5sum] = "2fe04135728f5c3a86c3a412059e0da3"
15SRC_URI[sha256sum] = "28dfc5e57bbcd305727e7af6a1a0587868db1c1286498757bfeb72edddf457e7"
16
17EXTRA_OECONF = " \
18 --plugdir=${libdir}/monkey/ \
19 --logdir=${localstatedir}/log/monkey/ \
20 --pidfile=${localstatedir}/run/monkey.pid \
21 --default-user=www-data \
22 --datadir=${localstatedir}/www/monkey/ \
23 --sysconfdir=${sysconfdir}/monkey/ \
24 --enable-plugins=* \
25 --disable-plugins=polarssl \
26 --debug \
27 --malloc-libc"
28
29inherit autotools-brokensep pkgconfig update-rc.d systemd
30
31INITSCRIPT_NAME = "monkey"
32INITSCRIPT_PARAMS = "defaults 70"
33
34SYSTEMD_SERVICE_${PN} = "monkey.service"
35
36FILES_${PN} += "${localstatedir}/www/monkey/"
37
38# temporarily remove, because ipk doesn't allow directories in CONFFILES
39# CONFFILES_${PN} = "${sysconfdir}/monkey/"
40
41do_install_append() {
42
43 mkdir -p ${D}${sysconfdir}/init.d
44 install -m 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey
45
46 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
47 install -d ${D}${systemd_unitdir}/system
48 install -m 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system
49 fi
50}