summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb')
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
new file mode 100644
index 000000000..b9fa5cde8
--- /dev/null
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.2.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Lightweight secure web server"
2HOMEPAGE = "http://www.hiawatha-webserver.org"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "libxml2 libxslt"
6
7SECTION = "net"
8
9SRC_URI = "http://hiawatha-webserver.org/files/${BP}.tar.gz \
10 file://hiawatha-init \
11 file://hiawatha.service "
12
13SRC_URI[md5sum] = "a77f044634884c4cc5d21dab44e822a3"
14SRC_URI[sha256sum] = "5d9cdec51c618bb3efab747030e593d9bd49dfaf3236254c8e0cb60715716dbf"
15
16INITSCRIPT_NAME = "hiawatha"
17INITSCRIPT_PARAMS = "defaults 70"
18
19SYSTEMD_SERVICE_${PN} = "hiawatha.service"
20
21inherit cmake update-rc.d systemd
22
23EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
24 -DENABLE_CACHE=OFF \
25 -DENABLE_DEBUG=OFF \
26 -DENABLE_SSL=OFF \
27 -DENABLE_TOOLKIT=OFF \
28 -DENABLE_CHROOT=OFF \
29 -DENABLE_XSLT=ON \
30 -DENABLE_TOMAHAWK=OFF \
31 -DCMAKE_INSTALL_MANDIR=${mandir} \
32 -DCMAKE_INSTALL_BINDIR=${bindir} \
33 -DCMAKE_INSTALL_SBINDIR=${sbindir} \
34 -DCMAKE_INSTALL_SYSCONFDIR=${sysconfdir} \
35 -DCMAKE_INSTALL_LIBDIR=${libdir} \
36 -DLOG_DIR=/var/log/hiawatha \
37 -DPID_DIR=/var/run \
38 -DWEBROOT_DIR=/var/www/hiawatha \
39 -DWORK_DIR=/var/lib/hiawatha "
40
41do_install_append() {
42 # Copy over init script and sed in the correct sbin path
43 sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init
44 mkdir -p ${D}${sysconfdir}/init.d
45 install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha
46
47 # configure php-fcgi to have a working configuration
48 # by default if php is installed
49 echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
50
51 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
52 install -d ${D}/${systemd_unitdir}/system
53 install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
54 fi
55
56 rmdir "${D}${localstatedir}/run"
57 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
58}
59
60CONFFILES_${PN} = " \
61 ${sysconfdir}/hiawatha/cgi-wrapper.conf \
62 ${sysconfdir}/hiawatha/hiawatha.conf \
63 ${sysconfdir}/hiawatha/index.xslt \
64 ${sysconfdir}/hiawatha/mimetype.conf \
65 ${sysconfdir}/hiawatha/php-fcgi.conf \
66"