summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb')
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
new file mode 100644
index 000000000..054858ed3
--- /dev/null
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Cherokee Web Server fast and secure"
2SUMMARY_cget = "Small downloader based in the Cherokee client library"
3HOMEPAGE = "http://www.cherokee-project.com/"
4SECTION = "network"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8PR = "r9"
9
10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
11
12SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \
13 file://cherokee.init \
14 file://cherokee.service \
15 file://cherokee-install-configured.py-once.patch \
16"
17SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
18SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
19
20inherit autotools pkgconfig binconfig update-rc.d systemd
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav"
24PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
25
26EXTRA_OECONF = "--disable-static \
27 --disable-nls \
28 ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
29 --with-wwwroot=${localstatedir}/www/cherokee \
30"
31
32do_install_append () {
33 install -m 0755 -d ${D}${sysconfdir}/init.d
34 install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
35
36 # clean up .la files for plugins
37 rm -f ${D}${libdir}/cherokee/*.la
38
39 install -d ${D}${systemd_unitdir}/system
40 install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
41 rmdir "${D}${localstatedir}/run"
42 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
43}
44
45# Put -dev near the front so we can move the .la files into it with a wildcard
46PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
47
48FILES_cget = "${bindir}/cget"
49FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
50FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
51FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
52
53# Pack the htdocs
54FILES_${PN} += "${localstatedir}/www/cherokee"
55
56CONFFILES_${PN} = " \
57 ${sysconfdir}/cherokee/cherokee.conf \
58 ${sysconfdir}/init.d/cherokee \
59"
60
61INITSCRIPT_NAME = "cherokee"
62INITSCRIPT_PARAMS = "defaults 91 91"
63
64RPROVIDES_${PN} += "${PN}-systemd"
65RREPLACES_${PN} += "${PN}-systemd"
66RCONFLICTS_${PN} += "${PN}-systemd"
67SYSTEMD_SERVICE_${PN} = "cherokee.service"