summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/cherokee/cherokee
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/cherokee/cherokee')
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch40
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init32
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.service10
3 files changed, 82 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
new file mode 100644
index 000000000..3336f7df7
--- /dev/null
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
@@ -0,0 +1,40 @@
1From 98a0f19df0a31d5649ad89d395fd1b8de5591827 Mon Sep 17 00:00:00 2001
2From: Robert Yang <liezhi.yang@windriver.com>
3Date: Thu, 3 Apr 2014 21:33:25 +0800
4Subject: [PATCH] admin/Makefile.am: only install configured.py once
5
6Both the two rules install-adminpyDATA and install-generatedDATA will
7install the configured.py to the same location, they can run parallel,
8and they use "install -m", which would might build failures:
9
10/usr/bin/install: setting permissions for `/path/to/configured.py': No such file or directory
11
12This is because the first install is setting the permission while the
13second install is removing the file an re-install.
14
15Only install the configured.py once will fix the problem, I think that
16there is no side effect since it installed the same file to the same
17location twice in the past.
18
19Upstream-Status: Pending
20
21Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
22---
23 admin/Makefile.am | 1 -
24 1 file changed, 1 deletion(-)
25
26diff --git a/admin/Makefile.am b/admin/Makefile.am
27index ce5937b..6f96934 100644
28--- a/admin/Makefile.am
29+++ b/admin/Makefile.am
30@@ -73,7 +73,6 @@ SystemStatsWidgets.py \
31 Wizard.py \
32 XMLServerDigest.py \
33 config_version.py \
34-configured.py \
35 consts.py \
36 util.py \
37 popen.py \
38--
391.8.2.1
40
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init
new file mode 100644
index 000000000..93603b84d
--- /dev/null
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.init
@@ -0,0 +1,32 @@
1#!/bin/sh
2DAEMON=/usr/sbin/cherokee
3CONFIG=/etc/cherokee/cherokee.conf
4PIDFILE=/var/run/cherokee.pid
5NAME="cherokee"
6DESC="Cherokee http server"
7
8test -r /etc/default/cherokee && . /etc/default/cherokee
9test -x "$DAEMON" || exit 0
10test ! -r "$CONFIG" && exit 0
11
12case "$1" in
13 start)
14 echo "Starting $DESC: "
15 start-stop-daemon --oknodo -S -x $DAEMON -- -d -C $CONFIG
16 ;;
17
18 stop)
19 echo "Stopping $DESC:"
20 start-stop-daemon -K -p $PIDFILE
21 ;;
22
23 restart)
24 $0 stop >/dev/null 2>&1
25 $0 start
26 ;;
27
28 *)
29 echo "Usage: $0 {start|stop|restart}"
30 exit 0
31 ;;
32esac
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.service b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.service
new file mode 100644
index 000000000..a2d703185
--- /dev/null
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Cherokee web server
3After=syslog.target
4
5[Service]
6Type=forking
7ExecStart=/usr/sbin/cherokee -d -C /etc/cherokee/cherokee.conf
8
9[Install]
10WantedBy=multi-user.target