summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb126
1 files changed, 63 insertions, 63 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
index a221e1da7..a7f358666 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
@@ -30,67 +30,67 @@ inherit autotools update-rc.d
30CFLAGS_append = " -DPATH_MAX=4096" 30CFLAGS_append = " -DPATH_MAX=4096"
31CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl " 31CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
32EXTRA_OECONF = "--enable-ssl \ 32EXTRA_OECONF = "--enable-ssl \
33 --with-ssl=${STAGING_LIBDIR}/.. \ 33 --with-ssl=${STAGING_LIBDIR}/.. \
34 --with-expat=${STAGING_LIBDIR}/.. \ 34 --with-expat=${STAGING_LIBDIR}/.. \
35 --with-apr=${WORKDIR}/apr-1-config \ 35 --with-apr=${WORKDIR}/apr-1-config \
36 --with-apr-util=${WORKDIR}/apu-1-config \ 36 --with-apr-util=${WORKDIR}/apu-1-config \
37 --enable-info \ 37 --enable-info \
38 --enable-rewrite \ 38 --enable-rewrite \
39 --with-dbm=sdbm \ 39 --with-dbm=sdbm \
40 --with-berkeley-db=no \ 40 --with-berkeley-db=no \
41 --localstatedir=/var/${PN} \ 41 --localstatedir=/var/${PN} \
42 --with-gdbm=no \ 42 --with-gdbm=no \
43 --with-ndbm=no \ 43 --with-ndbm=no \
44 --includedir=${includedir}/${PN} \ 44 --includedir=${includedir}/${PN} \
45 --datadir=${datadir}/${PN} \ 45 --datadir=${datadir}/${PN} \
46 --sysconfdir=${sysconfdir}/${PN} \ 46 --sysconfdir=${sysconfdir}/${PN} \
47 --libexecdir=${libdir}/${PN}/modules \ 47 --libexecdir=${libdir}/${PN}/modules \
48 ap_cv_void_ptr_lt_long=no \ 48 ap_cv_void_ptr_lt_long=no \
49 --enable-mpms-shared \ 49 --enable-mpms-shared \
50 ac_cv_have_threadsafe_pollset=no" 50 ac_cv_have_threadsafe_pollset=no"
51 51
52do_configure_prepend() { 52do_configure_prepend() {
53 # FIXME: this hack is required to work around an issue with apr/apr-util 53 # FIXME: this hack is required to work around an issue with apr/apr-util
54 # Can be removed when fixed in OE-Core (also revert --with-* options above) 54 # Can be removed when fixed in OE-Core (also revert --with-* options above)
55 # see http://bugzilla.yoctoproject.org/show_bug.cgi?id=3267 55 # see http://bugzilla.yoctoproject.org/show_bug.cgi?id=3267
56 cp ${STAGING_BINDIR_CROSS}/apr-1-config ${STAGING_BINDIR_CROSS}/apu-1-config ${WORKDIR} 56 cp ${STAGING_BINDIR_CROSS}/apr-1-config ${STAGING_BINDIR_CROSS}/apu-1-config ${WORKDIR}
57 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apr-1-config 57 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apr-1-config
58 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apu-1-config 58 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apu-1-config
59} 59}
60 60
61do_install_append() { 61do_install_append() {
62 install -d ${D}/${sysconfdir}/init.d 62 install -d ${D}/${sysconfdir}/init.d
63 cat ${WORKDIR}/init | \ 63 cat ${WORKDIR}/init | \
64 sed -e 's,/usr/sbin/,${sbindir}/,g' \ 64 sed -e 's,/usr/sbin/,${sbindir}/,g' \
65 -e 's,/usr/bin/,${bindir}/,g' \ 65 -e 's,/usr/bin/,${bindir}/,g' \
66 -e 's,/usr/lib,${libdir}/,g' \ 66 -e 's,/usr/lib,${libdir}/,g' \
67 -e 's,/etc/,${sysconfdir}/,g' \ 67 -e 's,/etc/,${sysconfdir}/,g' \
68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${PN} 68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${PN}
69 chmod 755 ${D}/${sysconfdir}/init.d/${PN} 69 chmod 755 ${D}/${sysconfdir}/init.d/${PN}
70 # remove the goofy original files... 70 # remove the goofy original files...
71 rm -rf ${D}/${sysconfdir}/${PN}/original 71 rm -rf ${D}/${sysconfdir}/${PN}/original
72 # Expat should be found in the staging area via DEPENDS... 72 # Expat should be found in the staging area via DEPENDS...
73 rm -f ${D}/${libdir}/libexpat.* 73 rm -f ${D}/${libdir}/libexpat.*
74 74
75 install -d ${D}${sysconfdir}/${PN}/conf.d 75 install -d ${D}${sysconfdir}/${PN}/conf.d
76 install -d ${D}${sysconfdir}/${PN}/modules.d 76 install -d ${D}${sysconfdir}/${PN}/modules.d
77 77
78 # Ensure configuration file pulls in conf.d and modules.d 78 # Ensure configuration file pulls in conf.d and modules.d
79 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf 79 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf
80 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf 80 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf
81} 81}
82 82
83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" 83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
84 84
85apache_sysroot_preprocess () { 85apache_sysroot_preprocess () {
86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/
88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${PN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${PN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
90 90
91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
94} 94}
95 95
96# 96#
@@ -103,21 +103,21 @@ LEAD_SONAME = "libapr-1.so.0"
103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}" 103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
104 104
105CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \ 105CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \
106 ${sysconfdir}/${PN}/magic \ 106 ${sysconfdir}/${PN}/magic \
107 ${sysconfdir}/${PN}/mime.types \ 107 ${sysconfdir}/${PN}/mime.types \
108 ${sysconfdir}/init.d/${PN} " 108 ${sysconfdir}/init.d/${PN} "
109 109
110# we override here rather than append so that .so links are 110# we override here rather than append so that .so links are
111# included in the runtime package rather than here (-dev) 111# included in the runtime package rather than here (-dev)
112# and to get build, icons, error into the -dev package 112# and to get build, icons, error into the -dev package
113FILES_${PN}-dev = "${datadir}/${PN}/build \ 113FILES_${PN}-dev = "${datadir}/${PN}/build \
114 ${datadir}/${PN}/icons \ 114 ${datadir}/${PN}/icons \
115 ${datadir}/${PN}/error \ 115 ${datadir}/${PN}/error \
116 ${bindir}/apr-config ${bindir}/apu-config \ 116 ${bindir}/apr-config ${bindir}/apu-config \
117 ${libdir}/apr*.exp \ 117 ${libdir}/apr*.exp \
118 ${includedir}/${PN} \ 118 ${includedir}/${PN} \
119 ${libdir}/*.la \ 119 ${libdir}/*.la \
120 ${libdir}/*.a" 120 ${libdir}/*.a"
121 121
122# manual to manual 122# manual to manual
123FILES_${PN}-doc += " ${datadir}/${PN}/manual" 123FILES_${PN}-doc += " ${datadir}/${PN}/manual"
@@ -126,8 +126,8 @@ FILES_${PN}-doc += " ${datadir}/${PN}/manual"
126# override this too - here is the default, less datadir 126# override this too - here is the default, less datadir
127# 127#
128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \ 128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \
129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \ 129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \
130 ${libdir}/${PN}" 130 ${libdir}/${PN}"
131 131
132# we want htdocs and cgi-bin to go with the binary 132# we want htdocs and cgi-bin to go with the binary
133FILES_${PN} += "${datadir}/${PN}/htdocs ${datadir}/${PN}/cgi-bin" 133FILES_${PN} += "${datadir}/${PN}/htdocs ${datadir}/${PN}/cgi-bin"