summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch b/meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch
new file mode 100644
index 000000000..fed6b5010
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/apache2/0007-apache2-allow-to-disable-selinux-support.patch
@@ -0,0 +1,40 @@
1From 964ef2c1af74984602f46e7db938d3b95b148385 Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Mon, 1 Dec 2014 02:08:27 -0500
4Subject: [PATCH] apache2: allow to disable selinux support
5
6Upstream-Status: Pending
7
8Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
9---
10 configure.in | 14 ++++++++++----
11 1 file changed, 10 insertions(+), 4 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index caa6f54..eab2090 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -466,10 +466,16 @@ getloadavg
18 dnl confirm that a void pointer is large enough to store a long integer
19 APACHE_CHECK_VOID_PTR_LEN
20
21-AC_CHECK_LIB(selinux, is_selinux_enabled, [
22- AC_DEFINE(HAVE_SELINUX, 1, [Defined if SELinux is supported])
23- APR_ADDTO(AP_LIBS, [-lselinux])
24-])
25+# SELinux support
26+AC_ARG_ENABLE(selinux,APACHE_HELP_STRING(--enable-selinux,Enable SELinux support [default=auto]),
27+ [],[enable_selinux=auto])
28+
29+if test x$enable_selinux != xno; then
30+ AC_CHECK_LIB(selinux, is_selinux_enabled, [
31+ AC_DEFINE(HAVE_SELINUX, 1, [Defined if SELinux is supported])
32+ APR_ADDTO(AP_LIBS, [-lselinux])
33+ ])
34+fi
35
36 AC_CACHE_CHECK([for gettid()], ac_cv_gettid,
37 [AC_TRY_RUN(#define _GNU_SOURCE
38--
392.7.4
40