summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb
new file mode 100644
index 000000000..aaa7e607d
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.9.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \
2extensible web server."
3SUMMARY = "Apache HTTP Server"
4HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "expat-native pcre-native apr-native apr-util-native"
6SECTION = "net"
7LICENSE = "Apache-2.0"
8
9inherit native
10
11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2"
12
13S = "${WORKDIR}/httpd-${PV}"
14
15LIC_FILES_CHKSUM = "file://LICENSE;md5=dbff5a2b542fa58854455bf1a0b94b83"
16SRC_URI[md5sum] = "2ef4e65353497606b24fa9bb3e5a3c40"
17SRC_URI[sha256sum] = "f78cc90dfa47caf3d83ad18fd6b4e85f237777c1733fc9088594b70ce2847603"
18
19do_configure () {
20 ./configure --with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
21 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \
22 --prefix=${prefix} --datadir=${datadir}/apache2
23}
24
25do_install () {
26 install -d ${D}${bindir} ${D}${libdir}
27 cp server/gen_test_char ${D}${bindir}
28 install -m 755 support/apxs ${D}${bindir}/
29 install -m 755 httpd ${D}${bindir}/
30 install -d ${D}${datadir}/apache2/build
31 cp build/*.mk ${D}${datadir}/apache2/build
32 cp build/instdso.sh ${D}${datadir}/apache2/build
33
34 install -d ${D}${includedir}/apache2
35 cp include/* ${D}${includedir}/apache2
36 cp os/unix/os.h ${D}${includedir}/apache2
37 cp os/unix/unixd.h ${D}${includedir}/apache2
38
39 cp support/envvars-std ${D}${bindir}/envvars
40 chmod 755 ${D}${bindir}/envvars
41}
42